PDA

View Full Version : BFG 6800GT OC + Ravenshield = reboot exiting game


Freq
12-03-04, 07:53 PM
Ever since I've moved to my BFG 6800GT OC, When I exit Raven Shield my PC completely reboots! No blue screen, just an entry in the event logs stating:

Event Type: Information
Event Source: Save Dump
Event Category: None
Event ID: 1001
Date: 12/3/2004
Time: 8:41:41 PM
User: N/A
Computer: WARROOM
Description:
The computer has rebooted from a bugcheck. The bugcheck was: 0x1000000a (0x9d086240, 0x00000002, 0x00000000, 0x8051ec1c). A dump was saved in: C:\WINDOWS\Minidump\Mini120304-01.dmp.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Here is the log from the game itself - doesn't have much to it that would point out the problem:

Log: Log file open, 12/03/04 20:35:36
Init: Name subsystem initialized
Init: Detected: Microsoft Windows XP 5.1 (Build: 2600)
Init: Version: 387
Init: Compiled: Feb 12 2004 20:14:15
Init: Command line:
Init: Base directory: C:\Program Files\Red Storm Entertainment\RavenShield\System\
Init: Character set: Unicode
Log: Bound to Window.dll
Log: Bound to Core.dll
Log: Bound to Engine.dll
Init: Object subsystem initialized
Init: Computer: WARROOM
Init: User: JWhipple
Init: CPU Page size=4096, Processors=1
Init: CPU Detected: Unknown processor (AuthenticAMD)
Init: CPU Features: CMov FPU RDTSC PAE MMX SSE
Init: CPU Speed=2002.150735 MHz
Init: Memory total: Phys=1048048K Pagef=2519712K Virt=2097024K
Init: Working set: 32000 / 159000
Log: Bound to R6Game.dll
Log: Bound to R6Abstract.dll
Log: Bound to R6Weapons.dll
Log: Bound to R6Engine.dll
Log: Bound to IpDrv.dll
Log: Bound to R6GameService.dll
Init: Raven Shield engine initialized
Log: Bound to WinDrv.dll
Init: Client initialized
Log: Bound to D3DDrv.dll
Log: D3D Device: 256M of video memory
Init: Direct3D adapters detected:
Log: nv4_disp.dll/NVIDIA GeForce 6800 GT
Init: D3D Driver: MaxTextureBlendStages=8
Init: D3D Driver: MaxSimultaneousTextures=8
Init: D3D Driver: MaxActiveLights=8
Init: D3D Driver: MaxPrimitiveCount=1048575
Init: D3D Driver: MaxVertexIndex=1048575
Init: D3D Driver: MaxStreams=16
Init: D3D Driver: MaxStreamStride=255
Init: D3D Driver: MaxVertexShaderConst=256
Init: D3D Driver: D3DVSDT_UBYTE4 allowed: Yes.
Init: D3D Driver: VertexShaderVersion=1.1
Init: D3D Driver: PixelShaderVersion=1.4
Init: D3D Driver: MaxUserClipPlanes=6
Init: D3D Driver: AGP support detected
Init: D3D Driver: D3DDEVCAPS_NPATCHES=0
Init: D3D Driver: Supports trilinear
Init: D3D Driver: Supports BLENDDIFFUSEALPHA
Init: D3D Driver: Supports LOD biasing
Init: D3D Driver: Supports Z biasing
Init: D3D Driver: Supports D3DTOP_ADDSIGNED2X
Init: D3D Driver: Supports D3DTOP_BUMPENVMAP
Init: D3D Driver: Supports D3DTOP_BUMPENVMAPLUMINANCE
Init: D3D Driver: Supports D3DTOP_DOTPRODUCT3
Init: D3D Driver: Supports D3DTOP_MODULATEALPHA_ADDCOLOR
Init: D3D Driver: Supports D3DTOP_MODULATECOLOR_ADDALPHA
Init: D3D Driver: Textures (4096x4096), Max aspect 4096
Init: Raven Shield Engine Direct3D support
Init: D3D Device: szDriver=nv4_disp.dll
Init: D3D Device: szDescription=NVIDIA GeForce 6800 GT
Init: D3D Device: wProduct=6
Init: D3D Device: wVersion=14
Init: D3D Device: wSubVersion=10
Init: D3D Device: wBuild=6693
Init: D3D Device: dwVendorId=4318
Init: D3D Device: dwDeviceId=69
Init: D3D Device: dwSubSysId=0
Init: D3D Device: dwRevision=161
Init: D3D Detected: NVidia video card
Init: D3D Device: using cubemaps [with mipmaps]
Log: (Karma): Beginning Karma for game.
Log: (Karma): Creating MeAssetDB.
Log: (Karma): Loading: ragdoll.ka
Log: (Karma): Finished Creating MeAssetDB (2 Assets).
Log: LoadMap: Entry
Log: LoadMap: Entry
Log: StaticMeshBatcher using 0K
Log: Initializing PhysicsVolumes list
Log: Game class is 'GameInfo'
Log: Starting portals/doors association...
Log: Finnished.
Log: Level is Level Entry.MyLevel
Log: Bringing Level Entry.MyLevel up for play (0)...
ScriptLog: InitGame:
ScriptLog: ### MutatorClass: Engine.Mutator
ScriptLog: Base Mutator is Entry.Mutator0
Log: Removed 0 non-realtime actors.
Log: Browse: Entry.rsm?Name=JOHNDOE?team=255?CLASS=R6Characters .R6RainbowMediumEuro?Skin=?Face=
Log: LoadMap: Entry.rsm?Name=JOHNDOE?team=255?CLASS=R6Characters .R6RainbowMediumEuro?Skin=?Face=
Log: LoadMap: Entry.rsm?Name=JOHNDOE?team=255?CLASS=R6Characters .R6RainbowMediumEuro?Skin=?Face=
Log: Starting portals/doors association...
Log: Finnished.
Log: Removed 0 non-realtime actors.
Log: Raven Shield Engine
Log: Copyright 2002 Ubi Soft
Log:
Log:
ScriptLog: Team 255
ScriptLog: Login: JOHNDOE
Log: Possessed PlayerPawn: PlayerController Entry.PlayerController0
Log: PlayerController0 got player WindowsViewport0
Init: Input system initialized for WindowsViewport0
Init: Input system initialized for Window

I've gone as far as a complete reload of Windows! Any ideas what's happening? Any known issues with this game and a 6800GT?

No, the video card isn't overclocked, nor is anything else in my machine..

My machine is as follows:

Athlon 64 3000+ (Socket 754)
MSI K8T Neo motherboard
Audigy 2
1 GB DDR PC3200
TV Master TV Tuner
Lite-on DVD Rom
Lite-on DVDRW
120 GB Maxtor drive
480 Watt Antec PS

I don't have a single problem with any other games!

Any ideas?

Freq
12-03-04, 08:35 PM
Here's one more log from the game. I closed the game, and instead of an immediate crash I got an error message on the screen.

After I clicked OK the machine rebooted :cry:

I created a text document with the message from the error and saved it before clicking OK, but I guess because of write-behind being enabled on my machine (as it is on most I believe!), the text document is totally blank :(

Here is the most recent log from the game (And yes , it is the whole log - it appears to have been cut off by the write-behind as well!)

Log: Log file open, 12/03/04 21:19:51
Init: Name subsystem initialized
Init: Detected: Microsoft Windows XP 5.1 (Build: 2600)
Init: Version: 412
Init: Compiled: Oct 7 2004 13:09:56
Init: Command line:
Init: Base directory: C:\Program Files\Red Storm Entertainment\RavenShield\system\
Init: Character set: Unicode
Log: Bound to Window.dll
Log: Bound to Core.dll
Log: Bound to Engine.dll
Init: Object subsystem initialized
Init: Computer: WARROOM
Init: User: JWhipple
Init: CPU Page size=4096, Processors=1
Init: CPU Detected: Unknown processor (AuthenticAMD)
Init: CPU Features: CMov FPU RDTSC PAE MMX SSE
Init: CPU Speed=2002.136535 MHz
Init: Memory total: Phys=1048048K Pagef=2519712K Virt=2097024K
Init: Working set: 32000 / 159000
Log: Bound to R6GameService.dll
Log: Bound to R6Abstract.dll
Log: Bound to IpDrv.dll
Log: Bound to R6Game.dll
Log: Bound to R6Weapons.dll
Log: Bound to R6Engine.dll
Init: Raven Shield engine initialized
Log: Bound to WinDrv.dll
Init: Client initialized
Log: Bound to D3DDrv.dll
Log: D3D Device: 256M of video memory
Init: Direct3D adapters detected:
Log: nv4_disp.dll/NVIDIA GeForce 6800 GT
Init: D3D Driver: MaxTextureBlendStages=8
Init: D3D Driver: MaxSimultaneousTextures=8
Init: D3D Driver: MaxActiveLights=8
Init: D3D Driver: MaxPrimitiveCount=1048575
Init: D3D Driver: MaxVertexIndex=1048575
Init: D3D Driver: MaxStreams=16
Init: D3D Driver: MaxStreamStride=255
Init: D3D Driver: MaxVertexShaderConst=256
Init: D3D Driver: D3DVSDT_UBYTE4 allowed: Yes.
Init: D3D Driver: VertexShaderVersion=1.1
Init: D3D Driver: PixelShaderVersion=1.4
Init: D3D Driver: MaxUserClipPlanes=6
Init: D3D Driver: AGP support detected
Init: D3D Driver: D3DDEVCAPS_NPATCHES=0
Init: D3D Driver: Supports trilinear
Init: D3D Driver: Supports BLENDDIFFUSEALPHA
Init: D3D Driver: Supports LOD biasing
Init: D3D Driver: Supports Z biasing
Init: D3D Driver: Supports D3DTOP_ADDSIGNED2X
Init: D3D Driver: Supports D3DTOP_BUMPENVMAP
Init: D3D Driver: Supports D3DTOP_BUMPENVMAPLUMINANCE
Init: D3D Driver: Supports D3DTOP_DOTPRODUCT3
Init: D3D Driver: Supports D3DTOP_MODULATEALPHA_ADDCOLOR
Init: D3D Driver: Supports D3DTOP_MODULATECOLOR_ADDALPHA
Init: D3D Driver: Textures (4096x4096), Max aspect 4096
Init: Raven Shield Engine Direct3D support
Init: D3D Device: szDriver=nv4_disp.dll
Init: D3D Device: szDescription=NVIDIA GeForce 6800 GT
Init: D3D Device: wProduct=6
Init: D3D Device: wVersion=14
Init: D3D Device: wSubVersion=10
Init: D3D Device: wBuild=6693
Init: D3D Device: dwVendorId=4318
Init: D3D Device: dwDeviceId=69
Init: D3D Device: dwSubSysId=0
Init: D3D Device: dwRevision=161
Init: D3D Detected: NVidia video card
Init: D3D Device: using cubemaps [with mipmaps]
Log: (Karma): Beginning Karma for game.
Log: (Karma): Creating MeAssetDB.
Log: (Karma): Loading: ragdoll.ka
Log: (Karma): Finished Creating MeAssetDB (2 Assets).
Log: LoadMap: Entry
Log: LoadMap: Entry
Log: Initializing PhysicsVolumes list
Log: Game class is 'GameInfo'
Log: Starting portals/doors association...
Log: Finnished.
Log: Level is Level Entry.MyLevel
Log: Bringing Level Entry.MyLevel up for play (0)...
ScriptLog: InitGame:
Log: Removed 0 non-realtime actors.
Log: Browse: Entry.rsm?Name=JOHNDOE?team=255?CLASS=(null)?Skin= ?Face=
Log: LoadMap: Entry.rsm?Name=JOHNDOE?team=255?CLASS=(null)?Skin= ?Face=
Log: LoadMap: Entry.rsm?Name=JOHNDOE?team=255?CLASS=(null)?Skin= ?Face=
Log: Starting portals/doors association...
Log: Finnished.
Log: Removed 0 non-realtime actors.
Log: Raven Shield Engine
Log: Copyright 2002 Ubi Soft
Log:
Log:
ScriptLog: Team 255
ScriptLog: Login: JOHNDOE
Warning: Failed to load 'NULL': Can't resolve package name
Warning: Failed to load 'Class None.(null)': Can't resolve package name
Log: Possessed PlayerPawn: PlayerController Entry.PlayerController0
Log: PlayerController0 got player WindowsViewport0
Init: Input system initialized for WindowsViewport0
Init: Input system initialized for WindowsViewport0
Log: Opened viewport
Log: Enter SetRes: 640x480 Fullscreen 1
Init: Best-match display mode: 640x480x32@85 (Error=0)
Log: Using back-buffer format 22(32-bit)
Log: Using depth-buffer format 75(32-bit)
Log: Creating device
Init: D3D Driver: CreateDevice: will use hardware transform and lighting.
Init: D3D Driver: CreateDevice: will use hardware vertex processing
Log: Bound to DareAudio.dll
Init: Game engine initialized
Log: Startup time: 8.984314 seconds
Log: Allocating 16384 byte dynamic index buffer.
Log: Allocating 65536 byte dynamic vertex buffer.
Log: Enter SetRes: 640x480 Fullscreen 1
Init: Best-match display mode: 640x480x32@85 (Error=0)
Log: Using back-buffer format 22(32-bit)
Log: Using depth-buffer format 75(32-bit)
Log: Creating device
Init: D3D Driver: CreateDevice: will use hardware transform and lighting.
Init: D3D Driver: CreateDevice: will use hardware vertex processing
Log: Allocating 16384 byte dynamic index buffer.
Log: Allocating 65536 byte dynamic vertex buffer.
Log: URL: Adding default option Name=JOHNDOE
Log: URL: Adding default option team=255
Log: URL: Adding default option CLASS=(null)
Log: URL: Adding default option Skin=
Log: URL: Adding default option Face=
Log: Browse: Training_shooting?SpawnNum=0?Name=JOHNDOE?team=255 ?CLASS=(null)?Skin=?Face=
Log: LoadMap: Training_shooting?SpawnNum=0?Name=JOHNDOE?team=255 ?CLASS=(null)?Skin=?Face=
Log: LoadMap: Training_shooting?SpawnNum=0?Name=JOHNDOE?team=255 ?CLASS=(null)?Skin=?Face=
Log: (Karma): Initialising Karma for Level.
Log: (Karma): Autodetecting CPU for SSE
Log: (Karma): Using SSE Optimizations
Log: Initializing PhysicsVolumes list
Log: Allocating 65536 byte dynamic vertex buffer.
Log: Collecting garbage
Log: Purging garbage
Log: Garbage: objects: 42455->42376; refs: 541893
Log: Game class is 'R6TrainingMgr'
Log: Starting portals/doors association...
Log: Finnished.
Log: Level is Level Training_shooting.MyLevel
Log: Bringing Level Training_shooting.MyLevel up for play (0)...
ScriptLog: InitGame:
Log: Removed 16 non-realtime actors.
Log: Spawning new actor for Viewport WindowsViewport0
ScriptLog: R6Game.R6PlanningCtrl R6Game.R6PlanningCtrl
Log: Possessed PlayerPawn: R6PlanningCtrl Training_shooting.R6PlanningCtrl0
Log: R6PlanningCtrl0 got player WindowsViewport0
ScriptLog: R6Console CreateInGameMenus bLaunchMultiPlayer False
Log: Collecting garbage
Log: Purging garbage
Log: Garbage: objects: 44725->42640; refs: 541721
Log: Allocating 65536 byte dynamic vertex buffer.
Log: Deleting destroyed actor
Log: Allocating 16384 byte dynamic index buffer.
Log: Allocating 23688 byte dynamic index buffer.
Log: Allocating 162624 byte dynamic index buffer.
Log: Enter SetRes: 1280x1024 Fullscreen 1
Init: Best-match display mode: 1280x1024x32@85 (Error=0)
Log: Using back-buffer format 22(32-bit)
Log: Using depth-buffer format 75(32-bit)
Log: Creating device
Init: D3D Driver: CreateDevice: will use hardware transform and lighting.
Init: D3D Driver: CreateDevice: will use hardware vertex processing
Log: Allocating 65536 byte dynamic vertex buffer.
Log: Allocating 16384 byte dynamic index buffer.
Log: Allocating 23688 byte dynamic index buffer.
Log: Allocating 162624 byte dynamic index buffer.
Log: Deleting destroyed actor
Log: Enter SetRes: 640x480 Fullscreen 1
Init: Best-match display mode: 640x480x32@85 (Error=0)
Log: Using back-buffer format 22(32-bit)
Log: Using depth-buffer format 75(32-bit)
Log: Creating device
Init: D3D Driver: CreateDevice: will use hardware transform and lighting.
Init: D3D Driver: CreateDevice: will use hardware vertex processing
Log: URL: Adding default option Name=JOHNDOE
Log: URL: Adding default option team=255
Log: URL: Adding default option CLASS=(null)
Log: URL: Adding default option Skin=
Log: URL: Adding default option Face=
Log: Browse: Entry?SpawnNum=0?Name=JOHNDOE?team=255?CLASS=(null )?Skin=?Face=
Log: LoadMap: Entry?SpawnNum=0?Name=JOHNDOE?team=255?CLASS=(null )?Skin=?Face=
Log: LoadMap: Entry?SpawnNum=0?Name=JOHNDOE?team=255?CLASS=(null )?Skin=?Face=
Log: Initializing PhysicsVolumes list
Log: Game c

LiquidX
12-03-04, 11:09 PM
Are you using the latest drivers from Nvidia site? I dont know if it's because of that or the latest 1.60 patch but exiting the game has also rebooted my system. Going to check around to see if it's common with the latest patch or drivers.

Head_slinger
12-04-04, 06:03 AM
Im having the same problem with Splinter Cell (same engine) If ive been playing for a while and i exit my computer immediatly restarts. Ive been attributing it down to the low 12v rails on my card causing a power spike when the game exits.

But now that you have problem with 6800GT wondering if its something else.

What are your computer specs?

EDIT: I get no BSODs or any error messages so maybe not same problem.

Freq
12-04-04, 06:44 AM
What are your computer specs?

Athlon 64 3000+ (Socket 754)
MSI K8T Neo motherboard
Audigy 2
1 GB DDR PC3200
TV Master TV Tuner
Lite-on DVD Rom
Lite-on DVDRW
120 GB Maxtor drive
480 Watt Antec PS


And yes, I'm using the 66.93 drivers right off nVidia's site..

I also installed the latest bios for my motherboard late last night and it still continues..

It's the damnedest thing!

I wonder if I posted on the Ubi.com forums if anyone has figured out a fix there...

Warden13
12-04-04, 08:32 AM
Not sure if these games use the UT engine but UT2004 forces a BSOD/Reboot when exiting if you have DEP enabled. I would do a search for UT2004 crashes or something like that in these forums. There have been a number of threads there and several describe how you go about completely disabling DEP on an A64 system.

Warden

Head_slinger
12-04-04, 09:29 AM
hmm, that sounds promising.

I also found this

http://hardware.mcse.ms/message101136.html


Finally, a word of warning: if you install WinXP SP2, either as an SP2
update or streamlined in, on a VIA K8 mbrd, do *NOT* use the VIA AGP driver
- IOW from the VIA 4-in-1 install, refuse the AGP selection. In SP2, M$
has new "unified AGP drivers" for AGP 3.0 and 3.5 compliant chipsets and
you *must* use them to avoid trouble. In particular they have two drivers:
for AGP 3.0 and 3.5, the first specific to K8 systems; funny thing is that
for me, it did not install automatically with the WinXP SP2 install and I
had to go to "Update Driver" for the VIA CPU to AGP Bridge and manually
tell it to use the "VIA AGP driver (Microsoft)" version. This caused it to
install a driver called GAGP30KX.SYS and it seems to work fine - without it
the SBA and Fast Writes don't get enabled; with a AGP 3.5 chipset the
corresponding driver is UAGP35.SYS.

Freq
12-04-04, 02:06 PM
http://forums.ubi.com/eve/ubb.x?a=tpc&s=400102&f=327106611&m=7431029742 has instructions on how to do this.

Head_slinger
12-04-04, 02:20 PM
It seems this has fixed my problem :)

It happened on HL2 for me aswell.

Freq
12-04-04, 09:57 PM
I'll be damned - none of the other suggestions worked for me - but if I switch but to the 61.77 drivers, problem solved!!

Freq
12-05-04, 07:20 AM
Anyone know of any beta drivers that may be out there that are newer than the 61.77 or the newest on the nVidia site that don't have this conflict?

LiquidX
12-05-04, 10:38 PM
Dang it. This problem is still affecting me.

Freq
12-06-04, 05:05 AM
The fix in this thread took care of the problem for me : http://www.nvnews.net/vbulletin/showthread.php?t=36541