PDA

View Full Version : Trouble Downloading Drivers


nod
12-09-04, 03:16 PM
I've recently developed a problem whereby I cannot download drivers from Nvidia's site. I can't get the betas from their NZone page either. This is a very recent development and I've been downloading drivers from the respective pages for months with no problem.

What happens is I click on the download link, the pop-up license agreement comes up, I hit "agree" and then... waiting... waiting... and I get the error page. (says page cannot be displayed - the standard ie one.)

My computer is up to date. XP w/ SP2, etc. I don't have any problems dl'ing from other sites, drivers or otherwise.

So odd... anybody ever heard of anything like this? Any hints on what to check or how to solve this mystery? This started happening about 2 weeks ago or so.

So far I've tried deleting all my offline content, including cookies, but I still can't download drivers from Nvidia. :(

Toss3
12-09-04, 03:51 PM
maybe u've somehow set your firewall so that it blocks all downloads :-S just go to ur firewall settings and check "allow downloads"(or something similar :D)

nod
12-09-04, 04:49 PM
Other downloads work fine... that's the really really strange part. For instance, I can dl those drivers from the Alienware page, but nada from the Nvidia pages.

Gurra101
12-10-04, 04:50 AM
I have the same problem when I try to download from Guru3D and then I have to shut down my firewall so try that! Just as the other in this post said!