PDA

View Full Version : Xpand Rally Looks Good, but runs like crap?


MustangSVT
01-16-05, 07:22 PM
I got Xpand Rally recently, and I really like the game, but performance is rather awful in this game. The first thing I've noticed is resolution and AA/AF don't really make a difference in this game. If I turn up the detail to highest, and put resolution to 800x600, with trilinear filtering and noAA, frame rate dips below 30 in several cases. If I put to 1152x864, with aniso filtering, 4xAA, average frame rate is around the same..

So what I did was I put all details to medium and 1024x768 noAA and trilinear filtering, and now the game is finally fully playable, with the car turning smoothly in the corners.

However, I notice that most of the performance difference comes from messing with the draw distance slider. If you put it to minimu, the objects close to the track render when you're close to them (which is very ugly..), and if you put it to maximum, you can still see the draw-in (which kind of sucks sometimes), but the difference in fps b/t lowest draw distance and highest is rather big (game playable -> unplayable).

So does anyone else with this game and a computer similar to mine have performance this low. Here's my specs.

athlon xp-m 2.4ghz
1gb ddr400
geforce 6800gt 425/1150
forceware 67.02, nvidia chipset 5.13, etc.
all stock cooler, stock voltage on video card

Shamrock
01-16-05, 10:20 PM
if I remember correctly, that game is written ENTIRELY in Java, hence why your resources are being taken up...even in a browser, Java eats the ram bad.

Nitz Walsh
01-17-05, 12:00 PM
if I remember correctly, that game is written ENTIRELY in Java, hence why your resources are being taken up...even in a browser, Java eats the ram bad.
Uh, no. The scripting language in the game is in Java, that's it.

saturnotaku
01-17-05, 01:49 PM
I've tried Xpand on both a 6800 GT and X800 Pro - both cards ran the game fine. You may want to drop to an older revision, or perhaps one of the 7x.xx sets (71.20 seems to work well for most folks).

SH64
01-17-05, 02:45 PM
Does it run as the demo ran ?
because i got a crappy performance with the demo ... it wasent that bad though .. i played @1280x1024,4xAA,8xAF with a fine framerate .
i dont have the game yet . just played the demo .

BioHazZarD
01-17-05, 03:35 PM
demo ran good for me so thats odd.

OWA
01-17-05, 03:56 PM
The demo ran pretty well for me on one track but the performance was somewhat lacking on the more detailed tracks. I haven't tried the full game.

MustangSVT
01-17-05, 05:38 PM
I'm talking about tracks like Poland on the SP demo. Did any of you try the Poland track (the one that's more detailed). When you have lower framerate than 40 in this game, car handling feels chuggy.

And yes, performance in full game is just like demo. I'm talking about the tarmac track in demo, not the big canyon one, because most good looking tracks in the full game run like the tarmac track in demo.

OWA
01-17-05, 08:29 PM
Poland is the one that didn't seem to run well on my system. Here is a thread where we discussed the demo (a guy was having low framerates with the Poland track also). You'll notice I start out saying it seemed fine for me but then I tried the Poland track and had to take that back. :)

http://www.nvnews.net/vbulletin/showthread.php?t=34885&page=1&pp=15&highlight=Xpand+Rally

Shamrock
01-17-05, 08:53 PM
Uh, no. The scripting language in the game is in Java, that's it.

yeah, that's it!!!

photophreak314
01-17-05, 10:32 PM
I can run it at 8XS/16XAF 1280X1024, Highest Details, and It runs fine. BUt that was with the 66.81 drivers, and the demo.

BTW, the HDR in that game is cool. and the mud spash bumpmaps that change, and the awesome physics, but it is SO hard to steer in Realistic mode.

MustangSVT
01-17-05, 11:22 PM
I don't need info on which resolution and AA you can run. The AA and resolution seem to make no performance difference in this game. If you think there's something wrong with my drivers, go back and try the Poland track from the demo, the one with tarmac and water, not the one with the canyon, because MOST tracks from the full game are similar to that Poland track (or run same performance). :(

What I eventually did was 1024x768 noAA w/ Trilinear Filtering and medium details and this works around 45fps on tracks in full game, but I wanted to know if this is same case with others.

OWA
01-18-05, 07:55 AM
Also, I don't think it's a driver issue since I had basically the same performance on my X800 system on that particular track.

SH64
01-18-05, 01:29 PM
Hmmm my performance in the Ponland track (demo) is slower that the others indeed , but not as low as you mentioned .
its running at avarage of 35fps @1280x1024,4xAA,8xAF all settings maxed in my 6800GT .
& 35fps avarage on the X800XT @1600x1200,2xAA,8xAF .

lowering the res & reducing the AA samples did improve my framerate .