PDA

View Full Version : demo test


mrrolf
01-21-05, 09:09 PM
Hey guys. I've been working on a game demo for a couple months. It's getting close to being finished and I haven't tested it on different hardware. I'm developing on a 6800gt, but it should work on earlier nvidia and ati cards. It uses pbuffers and simple vertex/fragment programs. I was hoping a few people could download it and try it out to see if it works or crashes on different hardware. It's a simple 2D-space shooter game. The art work or sounds aren't fancy, but the graphics aren't too bad for a little demo.

Here is a link to the setup file (debug version): Setup_debug (http://www.cc.gatech.edu/~rolf/game/Setup_debug.exe)

If you want to look at screen shots before, I have some here (http://www.cc.gatech.edu/~rolf/game)
There is a link to the release version on the page also.. but if something goes wrong, the debug version gives a little more output which helps me more.

Anyways, I appreciate you guys helping out. Let me know what you think and what system you have.

Robbie

mrrolf
01-21-05, 09:21 PM
You can move it if you want. I didn't know which one would be best since the game forums is about commercial games.

OWA
01-21-05, 11:46 PM
Pretty cool but it took quite a bit to blow up the ships. It looked like I was hitting them but I only blew up one after several hits. Anyway, on exit I got an error. So, basically it ran fine but didn't exit gracefully. I'm using the 71.50s on a 6800U.

Banko
01-21-05, 11:53 PM
Works fine on my system!

mrrolf
01-21-05, 11:54 PM
The first level is a little slow like that. But once you start upgrading it gets fast paced. It's almost best to level up a little bit in the first level.

I'll look into the exit thing. Thanks for the input.

OWA
01-23-05, 01:18 PM
Here is the error. Maybe the more detail one (2nd pic) will help.

http://img174.exs.cx/img174/7307/error.th.jpg (http://img174.exs.cx/my.php?loc=img174&image=error.jpg)

http://img174.exs.cx/img174/9187/errormoredetail6py.th.jpg (http://img174.exs.cx/my.php?loc=img174&image=errormoredetail6py.jpg)

Toss3
01-23-05, 03:12 PM
omg I love these kind of games :D have to say good work :D sadly, it ran too fast :( but it still was very fun to play :) keep up the good work and keep me updated on new maps an' stuff ..

mrrolf
01-23-05, 04:47 PM
Here is the error. Maybe the more detail one (2nd pic) will help.

Thanks for the help. It looks like the error is in rvoglnt.dll. Is the the driver? I'll go through and try to clean up the exit process some more.

omg I love these kind of games have to say good work sadly, it ran too fast but it still was very fun to play keep up the good work and keep me updated on new maps an' stuff ..

I used to love these games also. Right now I'm trying to polish what I have up. But when I get around to making more content, I'll let you guys know.