PDA

View Full Version : Problem with Far Cry


msxyz
02-08-05, 02:45 AM
Look at the LOG and you'll understand:
****** D3D9 CryRender Stats ******
Driver description: NVIDIA GeForce 6600 GT
Full stats: HAL (pure hw vp): NVIDIA GeForce 6600 GT
Hardware acceleration: Yes
Full scene AA: Enabled: 2x Samples (0 Quality)
Projective EMBM: Enabled
Detail textures: Enabled
Z Buffer Locking: Enabled
Multitexturing: Supported (8 textures)
Use bumpmapping : Enabled (DOT3)
Use paletted textures : Disabled
Current Resolution: 1024x768x32 Full Screen
Maximum Resolution: 1024x768
Maximum Texture size: 4096x4096 (Max Aspect: 4096)
Texture filtering type: TRILINEAR
HDR Rendering: Disabled
MRT Rendering: Enabled
Occlusion queries: Supported
Geometry instancing: Supported
NormalMaps compression: V8U8
Gamma control: Hardware
Vertex Shaders version 3.0
Pixel Shaders version 3.0
Use Hardware Shaders for NV4x GPU
Pixel shaders usage: PS1.1 only
Vertex shaders usage: VS1.1 only
Shadow maps type: Depth maps
Stencil shadows type: Two sided
Lighting quality: High :eek: :eek:

I've tried everything. From forcing the r_sm30path while in developer mode, to manually editing the system.cfg

Far Cry simply refuses to use in the game any other shader than SM 1.1

I was under the impression that on NV4x or Rxxx cards the SM 2.0 path was used by default. As the log suggests, I'm using the 1.3 build. Detonators drivers are 66.93

|MaguS|
02-08-05, 03:57 AM
This is the Full Game patched to 1.3 correct?

msxyz
02-08-05, 06:50 AM
Yep, somehow I resolved the problem deleting re-installing Far Cry.

But HDR rendering doesn't work correctly. I get all sort of clipping errors (water everywhere, brights spots that are seen through wall, etc...)

s-flow
02-08-05, 02:44 PM
Yep, somehow I resolved the problem deleting re-installing Far Cry.

But HDR rendering doesn't work correctly. I get all sort of clipping errors (water everywhere, brights spots that are seen through wall, etc...)

Try to set AA to "off" in game AND nV control panel.

msxyz
02-08-05, 05:06 PM
Thanks. Once I disabled AA the problems disappeared. This means that the HDR rendering is still borked, right ? On top of that, I had to reduce the strenght of the effect because many surfaces looked too birght, almost overexposed.

Overall, it's a nice addition: the scene looked more crisp and vivid.

macatak
02-09-05, 01:35 AM
To enable SM 3.0 all you need is a supported video card (which you have), patch 1.3, DirextX 9.0c drivers and the Lighting Quality setting in Advanced Video Options set to 'very high'. HDR in Far Cry is not compatible with AA, AF is ok, also HDR can be set to any value from 1 to 11 with HDR2 having the least performance impact.You can check what shader path you are running by typing \r_displayinfo 1 into the console