PDA

View Full Version : Crackling sound on OCZ Powerstream PSU


SH64
03-10-05, 08:47 PM
My OCZ 520W Powerstream is working fine since i got from 2 days .. but i'm hearing this little crackling noise coming from within the PSU .. it sounds like some fan is hitting something but it could be not because the sound stays even when the PC is switched off ! .. it wont go unless i turn off the PSU itself (or switch power off from main) .

is that normal ?? should i return it back ?? any advice ?

Rytr
03-10-05, 08:58 PM
Could be the fan hitting something...is the fan always running when the psu is on? Anyway, the fan is the likely culprit as nothing else in the psu should be making a noise. I think I would just rma it as those psu's are not cheap.

TierMann
03-10-05, 09:12 PM
If it's making noise when it's turned off then I'd RMA it.

Saibot
03-10-05, 10:34 PM
I just got one from Newegg yesterday to replace an Aspire. Anyways I just turned off my PC and put my ear right up to it and nothing but blissful silence. I'd say RMA it too.

SH64
03-10-05, 10:44 PM
Thanks for the info guys .. i think Saibot comment made it clear .
i'm going to RMA it .. hope the store has enough supplies or i'm going to wait for weeks until a new one comes .

SH64
03-11-05, 06:22 PM
Hmm i got another one & the little sound is still there .. WTF! i guess its from my end then ??

john19055
03-13-05, 07:00 AM
Are You sure there is'nt a wire or something getting in the way of the back fan of the power supply inside of your case because it should not make hardly any noise ,I can't even hear mine unless I put my ear right next to it.

SH64
03-13-05, 11:28 AM
Are You sure there is'nt a wire or something getting in the way of the back fan of the power supply inside of your case because it should not make hardly any noise ,I can't even hear mine unless I put my ear right next to it.

If that sound is coming only when the PSU is running then i'd suspect that .. but the problem is that the sound is coming even when the PC is off !
now it comes & go .. could it be the power source ?

Nutty
03-13-05, 12:23 PM
How the hell can it make noise if the PC is switched off?
Only thing I can think of, is you got some seriously noisy power feeding into it. Try getting a power smoother.

SH64
03-13-05, 01:26 PM
How the hell can it make noise if the PC is switched off?


Beat me i dont know . its not "noise" its just a little stuttering sound that can only be heard when everything in the room is switched off .

i too believe the problem is from the power feeding .. maybe its best to try it in a different place & see what happens .

BTW a little off-topic question .. the PSU has 3 LEDs for different voltages , if one of the LEDs is not as bright as the others .. does that mean anything or its just from the LED light & nothing to worry about ?

Saibot
03-13-05, 02:02 PM
Do you have your system plugged into a UPS or just right into the wall socket? I don't know what to say about the LED's. Mine are all the same brightness, perhaps there's a problem with the mobo or something plugged into it drawing too much power even when it's off. I can't believe that you'd actually get two defective PSU's in a row - especially OCZ.

SH64
03-13-05, 02:29 PM
Do you have your system plugged into a UPS or just right into the wall socket? I don't know what to say about the LED's. Mine are all the same brightness, perhaps there's a problem with the mobo or something plugged into it drawing too much power even when it's off. I can't believe that you'd actually get two defective PSU's in a row - especially OCZ.

EDIT : the 3 LEDs are 3.3v & 5v & 12v .. the 3.3v has lower brightness than the others but in the mobo BIOS i see its getting exaclty 2.28v which is suppose is sufficent .. could this has an effect taking into account that system is stable so far ?
my system is plugged to a UPS & this one is also plugged to another one which is powering my other PC .
i dont believe the PSU is defective .. or not even the first one . something must be wrong from my end .