PDA

View Full Version : NV's OGL High Quality setting is in the toilet.


rellingsen
03-22-05, 11:59 PM
When I bought my Ultra in early June of last year I was really impressed with the image quality of the card. As time has passed image quality has degraded considerably. Now there are even optimizations in the high quality mode that effect image quality. One of the key features that made me buy the card was its ability to turn off the optimizations by using the High Quality mode. Below are some shots so that you can see what has happened over time comparing the 61.77 drivers to the newly released 71.84's.
The biggest change I have seen in OGL was when the first 65 series driver came out. NWN looked like it was only receiving bilinear filtering from then on using AF. What appear to be mipmap lines where terrible (and still are), especially when you are moving.
I thought for the longest time it might be just some bilinear bug but I also noticed in other games that textures in the far distance appear to not be filtered as well as the used to. They went from fairly sharp to blurry. It almost appears that filtering is lowered or dropped xx feet from your point of view. It is really noticable in OGL games that have a camera POV like NWN.
I am all for optimizations but can't they be kept in the quality or lower settings and left out of HQ. I would be real nice if they left the image quality pristine for the purests in the HQ mode.

The pictures below were taken at 1600X1200 with 4XAA/8XAF using the High Quality mode. You will need to turn off picture resizing in your browser to see any real differences in the full size pictures. Also opening them each in a seperate window will help so you can switch between the 2.

First is Neverwinter Nights. I compressed these as much as I could without losing too much image quality but they are still 300+K. All you have to do is tip your camera to about 45 degrees then zoom in and out with your mouse wheel to see it which is about where I always play at. It is actually easier to see over larger solid textures like the rug in the picture.
61.77 Full
http://pages.prodigy.net/ellingsen1/6177lg.jpg
71.84 Full
http://pages.prodigy.net/ellingsen1/7184lg.jpg

A small area in a mouseover comparison.
http://pages.prodigy.net/ellingsen1/NWNmouseover.html

If you have trouble seeing that on your monitor, here are the same pics as above enlarged 175%
http://pages.prodigy.net/ellingsen1/6177zoom.jpg
http://pages.prodigy.net/ellingsen1/7184zoom.jpg

Believe me, it is much worse when you are moving.

Next is another OGL game, KOTOR 2.
61.77 Drivers
http://pages.prodigy.net/ellingsen1/KOTOR2-6177full.jpg
71.84 Drivers
http://pages.prodigy.net/ellingsen1/KOTOR2_7184full.jpg

Notice the wall on the left does not look as good. Also notice the lights that look like this ....... .... in the far distance are nowhere near as sharp. The joints in the wall above the lights are not visable anymore either. Both shots used the same program and the exact same compression level to post them. On screen in the actual game, the 71.84 driver pretty much made the lights look like a solid line instead of individual lights. They did show up seperate in the screen shot though.

Does anybody have a e-mail addy for NV that I could send this to or could forward this, so it can possibly be fixed?

tertsi
03-23-05, 01:19 AM
Yeah, High Quality image setting + OpenGL seems to be broken but dont worry... just put Quality and then disable optimizations... This is how you will get "High Quality" without using image settings slider :)

fivefeet8
03-23-05, 01:34 AM
Your NWN screenshots shows what looks to be the "Anisotropic Mip Filter Optimization". Disable it directly by setting IQ to "quality".

rellingsen
03-23-05, 08:25 AM
Good job guy's! You have fixed one of the two problems. NWN's mipmap line is now gone. The other with distant textures is still there but it is not as severe as the mipmap one. That one does not seeem to be affected by the quality or high quality settings with optimizations on or off.
I thought the purpose of optimizations was to speed things up with little or no IQ loss. Boy do those pictures tell a different tale.

Acid Rain
03-23-05, 01:10 PM
If you want NV's finest image quality, look no further than the wonderful 67.66 betas.

Better image quality I have NEVER seen, on any card. There is a noticable and sometimes remarkable improvement in the crispness of textures and the fullness of specular highlights.

No other driver touches these. Plus, they are stable (very), and usually as fast as the very fastest set available in most applications.

If you haven't tried them, are an IQ fiend like me, and want stability, no temp bug and high performance all in one package, get these.

By the way, I noticed you are using the 61.77s to compare with. The 67.66s eat the 61.77s for breakfast in both the performance AND IQ departments.

Set them to high quality, adjust your games and profiles, then enjoy.
You can thank me later.

TeaEtchSee
03-23-05, 09:34 PM
If you want NV's finest image quality, look no further than the wonderful 67.66 betas.


amen to dat! :D

XG has a B.version @ www.tweakersrus.com

im using stock LEADTEK 67.66...

Skinner
03-24-05, 05:30 PM
Yeah, High Quality image setting + OpenGL seems to be broken but dont worry... just put Quality and then disable optimizations... This is how you will get "High Quality" without using image settings slider :)


Yes, this is the wat I play too, I only disable mipmap opt. and the iq is great. In most games the other two opt's. aren't visible and sometimes they save performance.