PDA

View Full Version : Silent Hunter 3 particle system bug


aceflier
03-23-05, 09:43 PM
Fist off this is my first post been lurking for a few years been an ATI owner since my 9700pro and 9800pro and now I'm back to the light side.

Here is the problem and its well known in SH3

FPS drop to about 0-1 when looking through the binoculars dead ahead of the uboat. Another thing is that my 9800pro gets about 60fps avg in this game and my 6800gt/oc only gets in the 40's. And the 9800 is on a 1.6ghz machine? The developer says this is an NVIDIA problem in the way it renders the particle system in the game and that NVIDIA will fix it in a future patch. Can we expect a hotfix driver from nvidia much like ATI has done with call of duty and doom 3? Or, should I have stuck with ATI?

I've been back to nvidia long enough to know that it took 6 months to release a whql driver this run. Have to say I'm a bit spoiled by ATI's monthly driver updates it seems.

supremeboy
03-24-05, 05:52 AM
And what fw u use? Im using 76.10XG and have no problems with my 6600gt.

aceflier
03-24-05, 11:00 AM
It's a problem on all FW drivers and all nvidia cards frorm 5200 up. Goto binoculars looks straight ahead and its a white out resulting very low performance. Doesnt happen with the Ti/4 line of cards though go figure.

EverGreen
03-24-05, 11:15 AM
NOT! any problem with, just checked Silent Hunter III for it...

aceflier
03-24-05, 11:23 AM
Well thats funny how bout you try moving your U-boat so the water actually splashes then look out the binocs. Also see this thread from the Dev team of silent hunter 3. There is indeed a problem. I also advise you to search the ubi forum as there are countless posts on the issue.

Link to Dev Team NVIDIA bug (http://forums.ubi.com/eve/ubb.x?a=tpc&s=400102&f=857101043&m=2341042492)

EverGreen
03-24-05, 01:00 PM
Well i did look up to those topic and try out to figure your problem, but it works fine here, fun part is some different U-boats and different senario's because a bug should happen with one of them or maybe all ?!?

aceflier
03-24-05, 01:28 PM
May i ask what driver you are using? I'm using 71.84 I would try the 76.10 but the nasty CSS shadows I cant stand w/that driver. Tx.

Blah
03-24-05, 06:16 PM
CRTL P will disable the particle system while in-game. This is a fix until NVIDIA addresses the problem. You'll need the SH3 1.1 patch though. I do this when using the peri or bino's. Also SHIFT PGUP or PGDWN adjusts the in-game AA modes.

EverGreen
03-25-05, 08:11 AM
May i ask what driver you are using? I'm using 71.84 I would try the 76.10 but the nasty CSS shadows I cant stand w/that driver. Tx.

I used the 76.10 XG modded driver version...

H-street
03-25-05, 04:10 PM
a little OT but how is Silent Hunter 3..

i was serious considering picking it up..

any good?

Blah
03-25-05, 04:53 PM
If you're a serious grognard sub-simmer I'd say buy it now. There are some bugs, mainly the NVIDIA graphics issue (which now has a work around described in my post), flaky save game system and wonky crew fatigue routines. There are other issues but nothing game stopping, IMO.

Neal Stevens from www.subsim.com has hinted on the next patch being special and there will no doubt be a ton of mods for this game released by the community.