View Full Version : Halflife 2 hicups really bad during game play.

03-24-05, 09:11 AM
Halflife 2 stutters/hicups more then anything. During play while Im running around it will have these hicups all the time. A few months back I beat halflife 2 on a 9600XT and it never hicuped like this. Now I have a 6600 OC'd to 500/600 which would wipe the floor with the XT. The only difference between when I beat it and now is that I had a raptor HD but that alone couldn't be the problem could it? I have 512mb ram and I have nothing running in the backround while Im playing. I disable and shut down everything until only my sound icon and steam are loaded in the tray. Any ideas? What more info do you need? Im running the 75.90's which I just installed last night. Is this a common problem? I don't really see it being an issue of ram I mean I've seen friends computers with 512 running it perfect. I have a Celeron D (the 256k cache and 533mhz bus version so don't flame me) and its running at 3.30-GHz so Im ok in that department as well. What the heck is causing these hicups and stutters??? It drives me nuts while I play.

Also I play Brothers in Arms alot on MAX settings and it runs smooth as silk. Oh and Im running a Seagate 80GB 2mb cache 7200rpm drive right now.

03-24-05, 09:13 AM
have you tried different drivers?

03-24-05, 09:15 AM
HL2 needs 1 GB of RAM to run optimally. Also, the game is extremely sensitive to system overclocking. When I've pushed my system too far, the game has stuttered and outright crashed.

03-24-05, 09:45 AM
Stuttering could be caused by overclocking?

03-24-05, 09:48 AM

03-24-05, 01:06 PM
HL likes ATI. Doom3 likes nVidia. OC doesn't haven anything with this. You can try with some other driver for GPU.

03-24-05, 01:14 PM
i play hl2 just fine with aa and af on my 6800 gt thanks. 1 gig of ram is a godsend. Ocing also does make hl2 stutter. Oc'ed by default cards even stutter by default.

03-24-05, 01:19 PM
OC doesn't haven anything with this.

Then perhaps you can explain how the game plays perfectly on my 6600 GT, but when I overclock my system beyond its means, the game stutters and/or crashes.

03-25-05, 09:24 AM
**I love typing this a few dozen times a week....**

The amount of system ram you have determines the Texture Detail setting in Half-Life 2.

If you have less than 768 meg of system ram, Half-Life 2 will recommend Texture Detail:Medium.

If you have 768 meg or more of system ram, Half-Life 2 will recommend Texture Detail:High.

Choosing to ignore these recommendations may seriously impact your gaming experience in Half-Life 2. The Texture Detail setting dramatically increases ram requirements as you increase the setting. If you run High with 512 meg of ram, textures may be loaded off the hard drive, and then immediately swapped out to the paging file. This results in pretty severe performance degredation. (Hard drive access is miliseconds, ram access is nanoseconds.)

Example: I had an Athlon XP 2100+, 1gig system ram and a Geforce4 Ti 4200 128meg. It recommended Texture Detail:High. Performance in Half-Life 2 was decent and I attribute that to the amount of system ram in this case. More ram meant less swap file use.


03-25-05, 09:33 AM
when I overclock my system beyond its means, the game stutters and/or crashes.

I think thats your problem right there. Try a modest overclock. Some games just happen to stress gpu/cpu's more than others, and will expose stability problems in overclocking.

Its got nothing to do with the speed you push your gpu at, its got everything todo with how many mistakes the gpu is making when you push it too far.