PDA

View Full Version : High pitched noise in some 3D stuff [and a fix]


Sow Bug
04-27-05, 08:02 PM
Card: eVGA 6800GT 256MB
Motherboard: Soltek K8T-Pro
No overclocking. Latest drivers.

I recently started playing the Windows port of Duke 3D, JFDuke, and I began to notice a high-pitched squealing noise coming from my computer. It sounded like it might be coming from the internal speaker, so I disabled it but that didn't fix the problem. Doing a bit of searching around in Google, I discovered that - as many of you already know on here - that it may have something to do with a resonance circuit being created in a power regulation coil. (Don't I sound smart! No, don't ask me to explain it!) Apparently it just happens with some combinations of motherboards, PSUs and graphics cards.

Anyway, the strange thing is, I never hear it in other 3D games or apps. But then I decided to try the Direct3D tests in dxdiag and the noise only turns up in the DX8 and DX9 tests, being much louder in the latter. The cubes are spinning at an incredible rate because I have vsync off, so I decided to turn vsync back on and ran the tests again and the cubes didn't spin like crazy any more and there was no longer a high-pitched noise. I tried the same with Duke3D (which was running at a frame rate of up to 300fps with vsync off) and that fixed the problem too.

So, just a little fix if you are coming across this problem. I don't seem to get the noise with modern 3D games because my frame rates are not running in the 100s. (Hmm... but now I just tried a Quake port and even though I have a crazy frame rate there is no noise.) :eek:

PS: Fraps says my D3D tests are running at 999fps (obviously the limit of the counter). :D

Sow Bug
04-27-05, 11:52 PM
WELL... I've finally discovered the real problem. Not content with the fix above, I kept playing around witih different settings. In display settings I have it set for my TV as well. I set it back to single (monitor) display and now there is no buzzing whatsoever. I hardly use TV out so I'll just keep it that way when not using it. Must be something in the TV out circuitry and having vsync off. (I'm not an electronics guy so I'm just guessing here.)

EDIT: Oops. Problem still there with just JFDuke and vsync off. :rolleyes: