PDA

View Full Version : Pariah : 6800 bug?


Pages : [1] 2

lapino
05-06-05, 03:03 PM
Just tried this game, and it seems (whatever setting I use) I get very sluggish response when there's some pixel shader effect active (like the green explosions). The framerate is great (even playable at 1920x1200) but the slowdown is very noticeable (like when viewing pixel shadered glass, movement is about twice as slow)

Any1 else noticed this?
__________________
Dell 9300 (Pentium M 750 1.86ghz | 17" WUXGA+ TrueLife | 2x512mb 533mhz DDR2 | 60gb 5.400rpm *replaced by 60gb 7.200rpm | Sony 8xDVD+/-RW | 80watt/hour 9 CELL battery | 256mb GeForce 6800GO | Intel ProWireless 2200 | 1yr NBD)
ordered: 4/8 - arrived: 4/22

SLippe
05-06-05, 04:16 PM
What driver set are you using?

lapino
05-06-05, 04:58 PM
latest official drivers from nvidia site with a modded .inf file so I can use it on my 6800go videocard (but I'm 1000% sure the modded .inf is NOT the reason for this problem)

EverGreen
05-06-05, 06:08 PM
Mmmm i noticed that the game been low in the default.ini file
[Engine.GameEngine]
CacheSizeMegs=32

I updated CacheSizeMegs to 128 or higher and noticed faster speeds.
Upwards the default.ini script there been some settings out in False mode and i changed it for True for more improvements.

Working with the 76.45 WHQL drivers.

saturnotaku
05-06-05, 07:54 PM
Only bugs I noticed in Pariah were the overall crappiness of the game that had nothing at all to do with performance.

OWA
05-06-05, 08:08 PM
If you have the retail game, there is apparently a patch out. Maybe it'll help.

http://www.gamershell.com/news/21908.html

$n][pErMan
05-06-05, 08:29 PM
Only bugs I noticed in Pariah were the overall crappiness of the game that had nothing at all to do with performance.
hehe... ya .. i was not impressed at all with the demo. It was just UT2004 with DX9.0 effects.

EverGreen
05-06-05, 09:17 PM
[pErMan']hehe... ya .. i was not impressed at all with the demo. It was just UT2004 with DX9.0 effects.

Well in these time that we may playing with DX126.37G effects, seems DX9.0 a bit old....

lapino
05-07-05, 02:03 AM
apart from how you feel about the game, what about the sluggy movement when pixel shaders on screen? (or particles)

lapino
05-09-05, 05:45 AM
little bump, any1 got a solution to this??

EverGreen
05-09-05, 09:11 AM
little bump, any1 got a solution to this??

Tweak manually the script files for this game Lapino, that is the solve...

lapino
05-09-05, 09:12 AM
a little more explanation would be nice. thx in advance.

SH64
05-09-05, 09:35 AM
What image settings are you playing Pariah with ?
i recommend Quality for good performance with LOD set to Clamp.

the demo was so slow for me on the HQ settings (a.k.a all opt off)

TeaEtchSee
05-09-05, 11:06 AM
Only bugs I noticed in Pariah were the overall crappiness of the game that had nothing at all to do with performance.

AHAHHAAHAH

Demigod
05-09-05, 12:19 PM
Its the unreal2.5 (iirc) engine with some pixel and vertex shader effects.
Personaly I like it. It has a decent story and plays well.

It is very short and does nothing that hasnt been done before. It has a few very good areas but the rest is average. not great but not bad.

The only thing I dont like it the huge crosshair brough over from the consoles


Oh and it works fine on winxp64 btw

Optimummind
05-09-05, 12:36 PM
The game runs fine on my 6800GT flashed to Ultra at 12x10 with all in-game settings maxed out with 4xAA and 16xAF.

$n][pErMan
05-09-05, 06:01 PM
It is very short and does nothing that hasnt been done before.
I hate short games... count me out on getting it :( Doom RoE was short too... but I love the multiplayer CTF on it. CTF on doom3 engine is soo nice if your computer is good enough not to lag on it or you find a good server :)

EverGreen
05-09-05, 06:13 PM
Tweak manually the script files for this game Lapino, that is the solve...

Just look up in your Pariah.ini file for the [Engine.GameEngine] and change the CacheSizeMegs=32 to 128 or 256, the speed will improve...
I noticed also that some settings be False when they cab handle a lot with True option settings for all the 6 Family cards.
:D

Renzo
05-09-05, 08:37 PM
Just look up in your Pariah.ini file for the [Engine.GameEngine] and change the CacheSizeMegs=32 to 128 or 256, the speed will improve...
I noticed also that some settings be False when they cab handle a lot with True option settings for all the 6 Family cards.
:D
Actually no, it doesn't. Well, it will speed up the game by using more memory cache for level transitions etc but the framerate will not increase.

I play the game at 1600*1200 all ingame settings maxed out (+few tricks done via "preferences" (people who know unreal engine know what I'm talking about)) and it runs at least 35fps during heavy firefights. I even set the "min desired framerate" from 30 to 0 just to disable dynamic lod/effects scaling.

Pixel shader effects (green explosions etc) don't cause fps hit on my machine. The system is A64/s939 running at 2400MHz on A8V Deluxe with 1GB OCZ plat rev2 running at 240MHz 2-3-3-7-1T and the gfxcard is non-overclocked 6800GT with "high quality" in control panel options.

EverGreen
05-10-05, 11:36 AM
Actually no, it doesn't. Well, it will speed up the game by using more memory cache for level transitions etc but the framerate will not increase.

I play the game at 1600*1200 all ingame settings maxed out (+few tricks done via "preferences" (people who know unreal engine know what I'm talking about)) and it runs at least 35fps during heavy firefights. I even set the "min desired framerate" from 30 to 0 just to disable dynamic lod/effects scaling.

Pixel shader effects (green explosions etc) don't cause fps hit on my machine. The system is A64/s939 running at 2400MHz on A8V Deluxe with 1GB OCZ plat rev2 running at 240MHz 2-3-3-7-1T and the gfxcard is non-overclocked 6800GT with "high quality" in control panel options.

Well it works here my friend, the green explosions doesn't slow down after changing it to an higher stake, with 32 CacheSizeMegs it does.
If u been talking about memory cache transitions its upon the broadwidth of calculating the ammount of textures and shaders, with less the game stutters and with more its becomes smooth over your screen.
Some other features in those scripts been down, strange for a usement with an 6800 GT or ultra card... the whole IQ of the game is more flawless then it actually must do his job.
The question was intend about: what about the sluggy movement when pixel shaders on screen? (or particles)"
The solution for this is the CacheSizeMen....
:D

lapino
05-10-05, 03:33 PM
put cachesizemegs to 128, still slowdowns :(

H-street
05-10-05, 04:21 PM
latest official drivers from nvidia site with a modded .inf file so I can use it on my 6800go videocard (but I'm 1000% sure the modded .inf is NOT the reason for this problem)


have you tried the latest drivers that you don't have the mod the inf for your 6800go?

if you had to mod the inf, the 6800go may have not been included for some or other such reason in that driver set.. i would start by just trying the latest official drivers that support the 6800go just to eliminate that as being a the problem

Inglo
05-11-05, 09:05 AM
Just tried this game, and it seems (whatever setting I use) I get very sluggish response when there's some pixel shader effect active (like the green explosions). The framerate is great (even playable at 1920x1200) but the slowdown is very noticeable (like when viewing pixel shadered glass, movement is about twice as slow)

Any1 else noticed this?
__________________


I've noticed it. With a regular 6800 128 Mb and the 71.89 drivers. I'm running at 1280x1024, maybe I'll try lowering the resolution and see if that helps. I don't think the game is that bad, it's a lot like Unreal 2, which I half liked. I think the Pixel shader stuff they're using are obtrusive though. Some of it just seems a bit much.
There are a couple of settings I remember reading about from UT2K* that may help...
CheckForOverflow=True
AvoidHitches=True
That's just me guessing though.

lapino
05-23-05, 08:10 AM
still haven't been able to fix this, even with updated drivers. framerate is GREAT (make no mistake about what the problem is). but when an explosion is there, wham, instant slowdown, even in walking speed (which is hardly framerate related). guess it's one for the bin then... :(

Inglo
05-23-05, 08:44 AM
Did you try adding these two settings to the pariah.ini:
CheckForOverflow=True
AvoidHitches=True
I played through the whole game twice without ever getting those slowdowns again.