PDA

View Full Version : Forceware version confusion...help?


johnnyig
06-15-05, 09:18 PM
Ok I see that vers 71.89 is out on nvidia site for download..what is all this 77.xx stuff? are they non supported versions of nvidia drivers? Just wondering cause BF2 wont even launch on my pc and the install program can install 77.30 drivers for me but I said no because I dont know what the heck they are, and everything else i have works great. Any info would be great. Thanks for the help! :D

Zerocool
06-15-05, 09:21 PM
71.89 r the officials. the 77.xxs r betas. u need the 77.30, maybe the newer ones too to run BF2.

johnnyig
06-15-05, 09:57 PM
Ok, Thanks Zerocool.

Electronic Punk
06-16-05, 04:55 AM
I was told new drivers would be coming in a couple of weeks, but that is fantastically vague.