PDA

View Full Version : Problems with drivers compatible with BF2


pooface
06-23-05, 01:00 PM
The 77.30 drivers caused bsods occasionally when I closed UT2k4 (just fyi i rarely ever get those) 71.89 never gave me bsods but obviously had the shadow problems. The new official 77.72 drivers gave me one random bsod when opening UT, but I decided to give it time to see if it happened again. But a few hours later when I tried to play videos I realized those were messed up.

So then I tried 77.62, and same problem with the videos. I heard 77.50's have AA problems so dont even want to bother, are there any others that I could try?

SLippe
06-23-05, 01:27 PM
I believe there is a fix for the video contrast problem in the 77.72 thread. Also, it would help if you left some info about what kind of system you are running.

pooface
06-23-05, 02:41 PM
put rig in sig, bump :P

pooface
06-23-05, 11:41 PM
77.30, 77.50, 77.72- all of these bsod when I close Ut2k4 sometimes.

atomicrc11
06-24-05, 06:58 AM
I am also getting the UT2k4 bsod with the 77.30 and 77.72. However, battlefield won't run on either the 77.30 or the 77.72. I get a bsod saying the nvidia driver crashed.

SLippe
06-24-05, 01:31 PM
Might have something to do with turning off DEP for UT2K4. I believe. atomicrc11, what rig do you have?

pooface
06-24-05, 03:47 PM
What is DEP?

The error says something like page fault in non paged area. It seems more likely to happen the longer I play UT. If I go into ut and join a game and get out right away it usually does not happen.

The exact thing that happens is as soon as I click exit game from the menu, the screen will go blank for a 1/2 second, then I'll see my desktop immediately after for about another 1/2 second, then the bsod.

pooface
06-24-05, 03:50 PM
Is there no where to report bugs on nvidia's site? I can't find it.

Zips
07-09-05, 07:57 PM
What is DEP?

The error says something like page fault in non paged area. It seems more likely to happen the longer I play UT. If I go into ut and join a game and get out right away it usually does not happen.

The exact thing that happens is as soon as I click exit game from the menu, the screen will go blank for a 1/2 second, then I'll see my desktop immediately after for about another 1/2 second, then the bsod.
I get that constantly upon exiting Guild Wars as well. I would reinstall UT2K4 to see if it's happening there as well, but I can't find my CD's at the moment.

I never had this issue with 71.89 and earlier.

pooface
07-09-05, 11:20 PM
Yes this really sucks and its keeping me from playing bf2 since the shadow bug is so irritating.

SLippe
07-09-05, 11:51 PM
What is DEP?

Right-click on My Computer > Properties > Advanced > Performance/Settings > Data Execution Prevention and add UT2K4 to the list and see if that works.

H-street
07-10-05, 12:26 AM
yea i just play with the shadow bugs in bf2 (its not that bad)..

i am sticking with the 71.89 for a bit..

Zips
07-10-05, 12:34 PM
yea i just play with the shadow bugs in bf2 (its not that bad)..

i am sticking with the 71.89 for a bit..
I might as well rollback to those as well until EA gets a patch for their patch out (memory leak).

But I'd still like an answer to this. I don't want to have to be stuck with 71.89 drivers in the future. I trust that nVidia knows about this?

D3v0ur3r
07-10-05, 01:48 PM
UT04-A64-crash-fix

Step 1. Either do a file search for Boot.ini Then skip to step 2. Or if a file search doesn't work then Open Drive C or whatver drive the UT engine game is installed on. Go to tools, folder options, view tab. Uncheck "Hide Protected Operating system files"

Step 2. Right click the boot.ini file. Click properties & Uncheck "Read-only" Then edit the boot.ini setting /NoExecute=OptIn to read /NoExecute=AlwaysOff Then save & reboot.

Use whatever driver you like after that.

Zips
07-10-05, 04:55 PM
UT04-A64-crash-fix

Step 1. Either do a file search for Boot.ini Then skip to step 2. Or if a file search doesn't work then Open Drive C or whatver drive the UT engine game is installed on. Go to tools, folder options, view tab. Uncheck "Hide Protected Operating system files"

Step 2. Right click the boot.ini file. Click properties & Uncheck "Read-only" Then edit the boot.ini setting /NoExecute=OptIn to read /NoExecute=AlwaysOff Then save & reboot.

Use whatever driver you like after that.
And for those not on a 64bit CPU?