PDA

View Full Version : Pci Express vid card removal question


nippyjun
07-01-05, 01:55 PM
Hi, I'm on my first PCI express card (7800) and i'm going to need to take it out of the system. There is a litle white clamp on the mobo that seems to lock it in place. THe clamp has a lever on it. Do you just pull a little on the lever to release the card or do you have to do something else.

Thanks.

Kickus_assius
07-01-05, 02:03 PM
You kind of bend it down and it makes it so the part holding the card's tab opens up and you can remove the card. It's really quite simple. You just bend it down and pull out the card. You can tell when you are pushing it the right way because you can see the plastic bend and open up where the card is secured. I personally think it's quicker and more painless compared to the old AGP securing implements.

nippyjun
07-01-05, 02:57 PM
You kind of bend it down and it makes it so the part holding the card's tab opens up and you can remove the card. It's really quite simple. You just bend it down and pull out the card. You can tell when you are pushing it the right way because you can see the plastic bend and open up where the card is secured. I personally think it's quicker and more painless compared to the old AGP securing implements.


When you bend it down does it unhook so that you have to rehook it when you put in a new card? Or does it just stay "open" while you put pressure on it, then is goes back to "closed" when you release pressure?

Anyone have photos or know of a link to visual directions.

Thanks again.


EDIT: here is a photo. Which way (X) or (Y) do i move the clip
http://img.photobucket.com/albums/v354/nippyjun/PCIPhoto.jpg

anthonyl
07-01-05, 04:58 PM
I took my cards out and the first time I did the stupid white clamps broke off... No biggie though my system dosnt travel.

ChrisRay
07-01-05, 06:08 PM
You push lever to the left. You can do it from either side of the card, You dont need to push hard. And thats how you remove it. :)

OWA
07-01-05, 06:12 PM
I took my cards out and the first time I did the stupid white clamps broke off... No biggie though my system dosnt travel.
I almost broke mine on purpose b/c I was pushing/pulling/tugging all sorts of ways and nothing seemed to be helping. Of course, it's compounded by not being able to see it when the card is installed.

ChrisRay
07-01-05, 06:19 PM
I almost broke mine on purpose b/c I was pushing/pulling/tugging all sorts of ways and nothing seemed to be helping. Of course, it's compounded by not being able to see it when the card is installed.


Have you tried pushing at it from the other side? I like the clip because you can either push or pull it.

OWA
07-01-05, 06:24 PM
The main problem was, I couldn't see it and the picture in the manual wasn't clear enough to see what I should be doing with it. So, I was just feeling around trying to make something happen and nothing seemed to free it. Then, all of sudden I did whatever was right and it came loose. I think what I should have done was look at the bracket to see how it works before installing the motherboard and cards in my case.

ricercar
07-02-05, 01:44 PM
i push mine y direction

nippyjun
07-02-05, 04:21 PM
Thanks, Guys, "Y" it was.