PDA

View Full Version : -Win32- and -Win64- AMD nForce4 System Drivers 6.66


Pages : [1] 2 3

d2thez
07-15-05, 01:19 PM
Well Nvidia has new Official 6.66 WHQL drivers up on their homepage for AMD Nforce4 systems.

There are WHQL XP and XP64 packages...

http://www.nvidia.com/content/drivers/drivers.asp

rewt
07-15-05, 01:23 PM
Hmm 6.66 the drivers of satan!! lol

vmsein
07-15-05, 01:25 PM
Installing now. Thanks for the heads up :)

killahsin
07-15-05, 02:43 PM
any word if these fix the ide drivers from hell for nforce 4 chipsets that cause random blue screens on startup?

newls1
07-15-05, 02:56 PM
any word if these fix the ide drivers from hell for nforce 4 chipsets that cause random blue screens on startup?
It would be nice if they fixed that...

PeterJensen
07-15-05, 03:02 PM
uhhh :)

Huigie
07-15-05, 04:25 PM
any word if these fix the ide drivers from hell for nforce 4 chipsets that cause random blue screens on startup?

Seems you're deinstalling the old drivers, there's no need for that and doing so will give nothing but problems on some systems. You can without any problem install the new over the old drivers.

GlowStick
07-15-05, 04:31 PM
Installed the 6.66's no problmes so far.
Uninstall was painless, and install was too heh!

DJB
07-15-05, 05:01 PM
NF3 is just left behind as a bastard child, even though NF3 based boards are still selling.

Now, people will say, just install the NF4 drivers...but thought that works installing over previous drivers, they are not totally designed for the NF3 as they lack the GART driver.

Would be nice to see something beyond the 5.10 set for the NF3 especially since newer Nvidia IDE drivers solve some of the old problems.

DJB

SLippe
07-15-05, 05:03 PM
I installed these and no problems here. I'm not sure exactly what drivers are being used though, since my system is an NForce2.

DJB
07-15-05, 05:40 PM
As long as you install over an old driver it should be fine on NF2,3, or 4. NF2 and 3 need the GART driver, but that should already been on your system from previous drivers unless you have done a complete uninstall.

DJB

OWA
07-15-05, 05:53 PM
any word if these fix the ide drivers from hell for nforce 4 chipsets that cause random blue screens on startup?
I haven't experienced that but I did have major issues after installing the IDE driver, I guess, b/c I'm using only SATA drives. It took me a while to figure out how to get around that but once I got it booting again :), it has been fine ever since. That was with the 6.53s, I think it was. Makes me a little leery to try these though since I don't want to go through that again.

7800GTX
07-15-05, 06:08 PM
do you guys install everything in those drivers or just the PCI, I installed only the PCI and Ethernet, but I'm running the other lan on my mobo, not the NV lan.

EDIT: And my mobo is AN8-SLI Premium.

mad_man
07-15-05, 06:23 PM
As long as you install over an old driver it should be fine on NF2,3, or 4. NF2 and 3 need the GART driver, but that should already been on your system from previous drivers unless you have done a complete uninstall.

DJB

It's not that easy, as at least IDE and Ethernet drivers wont work for NForce1/2. Possibly there could be problems with NForce3 as well, but I haven't tested. Nvidia should start working on NF3 drivers right away now...

OWA
07-15-05, 07:15 PM
do you guys install everything in those drivers or just the PCI, I installed only the PCI and Ethernet, but I'm running the other lan on my mobo, not the NV lan.

EDIT: And my mobo is AN8-SLI Premium.
I installed everything (SMbus, Ethernet, and IDE) but the audio. Oh, and I skipped the firewall and forceware NAM installation.

SLippe
07-16-05, 02:38 AM
I knew all that DJB, thanks anyways. I usually install the latest beta set and I was using the Intel 7.13 set before this one. It only comes up with 4 things for me to install on my NF2 and I think they are IDE, Audio, Ethernet and ATA or something like that. Anyways, no problems here and yes, I had to tell it OK to override the newer 7.13's.

j0j081
07-16-05, 05:53 AM
I posted these drivers leaked from Asus about two weeks ago now. Too bad nobody payed any attention to my post...

lowdog
07-16-05, 09:25 AM
The 6.66 on Nvidias site are only 32 bit!!!

There are no 64bit drivers there. :confused:

OWA
07-16-05, 09:39 AM
These are working fine for me but I don't really notice any difference from the 6.53s I was using earlier.

Demigod
07-16-05, 09:50 AM
The 6.66 on Nvidias site are only 32 bit!!!

There are no 64bit drivers there. :confused:


They are there but nvidia has the link wrong, load the 32 bit download page and swap the 32 for 64 in the address bar.

Shion Uzuki
07-16-05, 10:44 AM
LOL!!!!

This is one evil set of drivers :D

but umm. Install away!! LOL. I wonder if NAM got better or not....

littlegreenguy
07-16-05, 11:31 AM
Wellllllll, are there any noticeable performance improvements? (particularly for nf4 sata raid 0 users :p )

wheeljack12
07-16-05, 01:47 PM
your bsod are now becoming rsod's (red screen o death)! And they ask to sign and deliver soulwise or no pc for you,not!

wollyka
07-16-05, 04:23 PM
I posted these drivers leaked from Asus about two weeks ago now. Too bad nobody payed any attention to my post...
As j0j081 said, these drivers are old news for Asus mobo, i had them more than a 2 weeks now and they are working ok

Sk8erian
07-17-05, 05:19 PM
I've never downloaded the NForce chipset drivers before...so whatever came with my mobo, its still there.

Is it really necessary to install these?

In order to install these...or can I just install it?

Thanks.