PDA

View Full Version : Tt water or air???


PaiN
07-25-05, 05:58 PM
I bought a Tt BigWater liquid cool used, it leaked and didn't pump. I got my $$ back and replaced it with a Tt BigTyphoon. I got smart somewhere along the line and applied for an RMA from Tt for busted BigWater, with nothing to lose, I sent it back. Today, a replacement BigWater arrived.....
I'm all :confused: discombobulated :confused: with what to do, keep the Typhoon or try the Water??? I know its stupid but after all I been through, I'm afraid to touch things...... :o
The CPU mounting is the same on both systems, so it should be a fairly simple(as going form air to liquid can be) change over...
What do you think?

Riptide
07-25-05, 06:01 PM
If it's not broke... well you know the rest dude. ;)

SH64
07-25-05, 06:19 PM
From slef-experiance i found the BigTyphoon not efficent for cooling .. it maybe quiet but temps wise heck no! i was getting about 10c degrees extra over my Zalman CNPS7700-AlCu when i tried it for a short period.
actually i didnt like Tt's CPU air cooling solutions at all after trying some of them.
i say try the water-cooling but dont do it yourself .. try any nearby store or people with enough experiance ot install it.

last week one of my friends had a similar problem like yours when the liquid leaked over his 6800U & some other hardware but thankfully nothing got damaged & that was on the local store's responsbility because they didnt fix it well. moral of the story : better safe than sorry!

GlowStick
07-25-05, 07:08 PM
Yeah ive seen reviews of their water kits and they were craptacular at best.

extreme4377
07-25-05, 08:18 PM
lol! PaiN is pretty darn experienced if I do say so myself. Hes had a h20 kit or two in the past.

Anyways, Id have to agree, if it aint broke, dont fix it. But, its pretty tempting I assume. So, CHARGE IT! :)

PaiN
07-25-05, 09:17 PM
Ha...thanks SH64, I been doing the wa-wa for a long time, which is half the reason I want it back. The other half is, after some investigation, I found like you said, the temps I'm getting from the BigTyphoon(air) are not that good for a SD core CPU...

Anyway, I did go over to the BigWater, its on and leak testing atm, so no temps. yet.. I found that the org. used kit, I bought, was missing "quick connect" barbs that came off the pump which caused the leaking, not to mention it didn't pump ;)