PDA

View Full Version : Can someone please tell me how to enable HDR in Far Cry with my 7800 GTX?


ozziegn
07-31-05, 12:25 AM
I remember people talking about the whole HDR thing but of course that was a long time ago and I cant seem to find any info on that now.

I heard that Far Cry is one of the games that can take advantage of HDR so I am hoping that someone will point me in the right direction as to how do I do this with my 7800 GTX?

Thanks for any info...

gram_vaz
07-31-05, 12:43 AM
\r_hdrrendering 7 in the in-game console.

where 7 is the value of hdr. 7 is what people generally use. and i think i heard once anything lower than 7 turns off certain hdr features.

Roadhog
07-31-05, 12:59 AM
11 is the highest

macatak
07-31-05, 01:16 AM
Some people have been expierencing graphic bugs with the 7800GTX in Far Cry when HDR is enabled, like this (http://forums.ubi.com/groupee/forums/a/tpc/f/170106891/m/2001014533), also here's a good article (http://www.elitebastards.com/page.php?pageid=7594&head=1&comments=1) which covers HDR in Far Cry.

Acid Rain
07-31-05, 05:00 AM
My favorite method by far is to simply edit the config file. Just change "Hdr Rendering" from 0 (disabled) to 7 (mode 7, the most favored by many, though 1-11 are modes as well). Done. Then it will always run with it enabled as you see fit, without needing the console command every time. Just remember to disable AA in the game, and of course in the display properties control panel as well.

Zurble
07-31-05, 08:00 AM
Some people have been expierencing graphic bugs with the 7800GTX in Far Cry when HDR is enabled, like this (http://forums.ubi.com/groupee/forums/a/tpc/f/170106891/m/2001014533), also here's a good article (http://www.elitebastards.com/page.php?pageid=7594&head=1&comments=1) which covers HDR in Far Cry.

that's wierd, i had the same bug in resolution above 1152x864, but not below in single card mode
in SLI i can set 1600 without this bug.

i use HDR 11, and it was with same drivers same settings (except resolution), and transparency AA is still set to supersampling, so it might be related to the amount of power in reserve for your GPU

PeterJensen
07-31-05, 08:05 AM
HDR is fubar on my 7800GTX, must bed the drivers. Even at HDR level 7 its way to bright and there are weird colors in the side of the screen.

OWA
07-31-05, 08:30 AM
Are you using patch 1.32? I went back to using 1.3 and things seem fine.

PeterJensen
07-31-05, 10:10 AM
Yea patch 1.32. Can u uninstall a patch ?

PNY7800GTX
07-31-05, 11:22 AM
I get this (http://forums.ubi.com/groupee/forums/a/tpc/f/170106891/m/2001014533) too when I enable HDR with my 7800 GTX. Seems the older drivers fix it, so we have to wait for a fix in the new drivers to use it again.

OWA
07-31-05, 02:17 PM
Yea patch 1.32. Can u uninstall a patch ?
I tried just getting rid of the patch but it kept saying it was still installed. So, I had to remove Far Cry and after reinstalling, just installed the 1.3 patch.

anzak
07-31-05, 02:26 PM
I use 2. It turns off the annoying light rays and gives a nice boost in performance.

OWA
07-31-05, 04:28 PM
My favorite method by far is to simply edit the config file. Just change "Hdr Rendering" from 0 (disabled) to 7 (mode 7, the most favored by many, though 1-11 are modes as well). Done. Then it will always run with it enabled as you see fit, without needing the console command every time.
That's definitely convenient. Thanks for the tip.

Acid Rain
07-31-05, 04:37 PM
You are very welcome. :)

macatak
07-31-05, 04:46 PM
Those weird graphic also happens with my 6800u when i enable HDR 7.

ps, you can also set the HDR level by adding "r_hdrrendering 7" to the Target line in your shortcut to Far Cry, it will look like this..Far Cry\Bin32\FarCry.exe" "r_hdrrendering 7"

faithlesspreach
07-31-05, 07:37 PM
do u have to got any patch instaled in order to hdr to work i tryied that and i have used till 1.32 patch i think , and it doesnt make a difference no hdr :thumbdwn:

OWA
07-31-05, 07:42 PM
I think it was added with patch 1.3.

Are you sure you're issuing the command correctly?

\r_hdrrendering 7

It should be a fairly obvious difference with any scenes that have lights. You should have a noticeable framerate difference as well.

Gentle
08-01-05, 12:12 AM
You should also notice it when you are going from an area that is dark to an area that is bright.

The screen will over-brighten a moment and then even out.

Gentle