PDA

View Full Version : WOW stuttering on a 7800gtx


Pages : [1] 2

grimreefer
08-11-05, 07:08 PM
yea, its stuttering really bad, using 77.77 drivers. i have a dual core cpu, and im thinking it might have something to do with that or the grafix card. this is the only game i have that stutters. also played cs source, and fear demo, both play fine.

retsam
08-11-05, 08:48 PM
using 77.77 drivers.


have you tried other drivers?

cambrian
08-11-05, 08:53 PM
from your sig, seems that u overclocked your card. Sometimes oc'ed graphics card stutter during games. My 6800gt did until i backed down on the core and memory a little. Try it. 525 core is insane dude

BTW, I have 77.77 drivers and WoW is super smooth. My 7800gtx runs at stock.

Kojiro
08-12-05, 09:59 AM
Duh! :rolleyes:

Why do you even need to OC a 7800GTX? The only game that runs slow on my 6800GT is F.E.A.R. . But I beleive that this games 3d engine needs to be
seriously reworked, thats my opinion. But SLI, OC however you want. nothing will ever be fast enough for you. :p

OWA
08-12-05, 05:25 PM
yea, its stuttering really bad, using 77.77 drivers. i have a dual core cpu, and im thinking it might have something to do with that or the grafix card. this is the only game i have that stutters. also played cs source, and fear demo, both play fine.

Make sure you install the AMD X2 drivers if you haven't already. Not sure if it will help but it helped solve a lot of little (and big :)) problems I was having.

bigjohns97
08-12-05, 06:12 PM
alt+escape out of the game open task manager and find your exe running under services. it will probably be the one using the most memory.

right click the exe and select "set affinity" and try forcing it to use only one cpu instead of both.

I have to do this with madden and sc:ct.

grimreefer
08-12-05, 06:30 PM
alt+escape out of the game open task manager and find your exe running under services. it will probably be the one using the most memory.

right click the exe and select "set affinity" and try forcing it to use only one cpu instead of both.

I have to do this with madden and sc:ct.
yea, that would solve my problem! but, for WOW, it says "acess is denied".anyway to get around this....im sure this will solve my problem.

-=DVS=-
08-12-05, 08:00 PM
If you have dual core games will sutter unless you run them with Affinity either 0 or 1 , there is plent small programs on google , you add it in game shortcut and game starts with preset affinity and or with tool THG made its not perfect no minimize or system try button but it works Linky (http://www6.tomshardware.com/cpu/20040528/images/taskassign.zip)

Rivatuner could add this feature or Nvidia drivers should.

grimreefer
08-12-05, 09:05 PM
If you have dual core games will sutter unless you run them with Affinity either 0 or 1 , there is plent small programs on google , you add it in game shortcut and game starts with preset affinity and or with tool THG made its not perfect no minimize or system try button but it works Linky (http://www6.tomshardware.com/cpu/20040528/images/taskassign.zip)

Rivatuner could add this feature or Nvidia drivers should.
ok, thanx...do games stutter for u? at least i know im not alone now
damit, its not working with WOW...works with everything else though....."acess is denied" to change WOW.exe's afinity.....anyone know a mod i can do to the exe file?

OWA
08-12-05, 10:17 PM
Below is a utility floydenheimer mentioned to me when I was having issues with my X2 CPU. The thread is here if you want to see the context:

http://www.nvnews.net/vbulletin/showthread.php?t=53954

http://www.activeplus.com/us/freeware/runfirst/

grimreefer
08-12-05, 10:32 PM
thx for the help!
what do i add to "C:\Program Files\World of Warcraft\WoW.exe" to get it to start with runfirst?

Viral
08-12-05, 10:33 PM
Make sure you install the AMD X2 drivers if you haven't already. Not sure if it will help but it helped solve a lot of little (and big :)) problems I was having.

Somehow I think that would severely screw things up for him.

*Points to grimreefer's sig.

OWA
08-12-05, 10:38 PM
Heh, you're right. He said dual-core and I just assumed that meant an AMD X2. I guess when I see someone say dual-core I think AMD and when they say hyper-threading, I think Intel.

grimreefer
08-12-05, 11:05 PM
lol, dual core intel is a rare find among gamers... i just installed chipset driver's from asus's website and everything is going perfect....but im not sure if the problem is gone for good, iv reinstalled chipsets drivers b4, and yhe problem keeps coming back.....
anyway, what do i add to "C:\Program Files\World of Warcraft\WoW.exe" to get it to start with runfirst? i cant figure out what i have to add!

OWA
08-12-05, 11:31 PM
Heh, I didn't think I had ever heard dual-core mentioned when talking about Intel. :)

Anyway, after someone told me to check the X2 drivers (i.e. to make sure they were installed) and I found I didn't have them installed, I installed them and most of my issues were solved. When playing around with the runfirst utility, I just used it like this. I copied runfirst (although maybe I should have copied it to Program Files) and then changed the shortcut as follows (for example):

C:\WINDOWS\RunFirst.exe E:\Games\Painkiller\Bin\Painkiller.exe

That seemed to work but I wasn't really sure how to verify if it was working correctly (although it did seem to fix a weird issue I had with Painkiller where I'd have to hit keys several times before they'd be accepted).

Edit: That also seemed to solve a "surging" type problem in Painkiller so I do think that is how you use it. The README mentions running it like this:

runfirst program.exe program options

OWA
08-13-05, 05:57 PM
A day after saying I hadn't seen dual-core mentioned in regards to Intel, I see an ad in Tiger Direct for a dual-core Intel system (Pentium D). I thought you were joking. :)

grimreefer
08-13-05, 07:21 PM
damit, stuttering is back....and i cant assign WOW to a single cpu, it always says access is denied. dam u blizzard, why would u deny such access! i contacted tech support, but i dont think ill get a good responce.

-=DVS=-
08-13-05, 11:52 PM
Did you try to use any of the tools posted above ?

grimreefer
08-14-05, 12:30 AM
Did you try to use any of the tools posted above ?
yep, none work with wow, work with all other stuff though....i reinstalled wow and i think the stuttering is gone now though.....there is stuttering in source too occasionally, but i can assign it to a single cpu, so its not big deal

bigjohns97
08-14-05, 03:29 PM
my source works fine with my dual cpu, maybe you have some tsr's running in the background? autoupdate anything like that that might trigger some nic hd cpu mem activity, could do it also. Depending on what the bottneck in your system is.

I see you have 2 gigs of ram have you tried disabling swapfile (virtual memory)

grimreefer
08-14-05, 04:38 PM
my source works fine with my dual cpu, maybe you have some tsr's running in the background? autoupdate anything like that that might trigger some nic hd cpu mem activity, could do it also. Depending on what the bottneck in your system is.

I see you have 2 gigs of ram have you tried disabling swapfile (virtual memory)
do u ever notice that with source, it runs much smoother when u set the affinity for only one cpu? set it to one cpu and see if u see a difference. i wanna know if im alone here.

bigjohns97
08-14-05, 04:51 PM
It is impossible for source to be more smooth i score 180 fps is the vst with 1280x960 4xaa and 16xaf HQ.

The graphics and fps could not be any better. I don't see what HD you have so i would try and disable swap file since you have so much memory, anything that is loaded into memory must be replicated on swap file, when you start loading large games the overhead can be seen if the hd i/o is not effecient. Give it a shot.

-=DVS=-
08-15-05, 01:59 AM
High FPS not equals smooth. With dual core several games start skipping frames/micro stuttering hard to explain doesn't affect FPS counter at all , its a problem with games or windows maybe drivers since all of them were designed for single CPU operation. For example NFSU game runs to fast with dual core cpu , in some games i noticed it works fine the first hour or so after windows bootup but acts weird later , anyways assigning affinity to one cpu you can do whatever on second and get virtually no fps drop and smooth game play , i use one tool i found online , sets all tasks to affinity 0 and game to 1 , works awesome. I think there might be a flaw in windows internal task scheduler how it assigns cpus to specific tasks and such.

Absolution
08-15-05, 04:41 AM
i get extreme stuttering on the computer im using now (until my mobo gets in) and i believe it is because of windows pagefile. it could bve that your pagefile is set too high/low (try setting it to let windows manage it for you if it isnt already) my computer->properties->advanced->performance->settings->advanced->change
also set memory usage to programs instead of system cache (i believe...)

the stuttering isnt so bad for me anymore (i still run out of ram though... only 512 and wow uses a hella lot)

JamieS
08-15-05, 10:46 AM
Stuttering? Would you mind describing a bit further? My config, below, doesn't seem to show this behavior in WoW.

js