PDA

View Full Version : DXVA/MPEG2 acceleration BROKEN since 71.89


Darkfalz
09-04-05, 01:23 AM
Just went back in driver versions to see when MPEG2 went from with my FX 5700 card and MPEG2 playback with hardware acceleration turned on.

Basically, in versions 71.89 or newer I have the following problems with MPEG2 support.

Adaptive/blended clip options disappeared from NVDVD Decoder (ie. hardware support was removed, at least for FX cards!).
Occasional black screen/hangs when trying to play back MPEG2 files with hardware acceleration turned on.
Jerky playback with DTV card and hardware acceleration (different codec).

When I went back to 61.77 (old faithful), I got my extra deinterlacing options back, and playback went back to perfect in both DTV (Cyberlink codec) and Media Player files (NVDVD codec).

The only reason I want to use a 77.72+ driver is because I desperately want triple buffering in OpenGL, but I don't want to put up with sub standard MPEG2 support (ie. forced to use software mode) in order to have it.

Of course, no way to contact NVIDIA to report these problems or ask them what's up.

Darkfalz
09-04-05, 01:33 AM
Oh yeah, CS/HL2 is no good with these old drivers :(

DAMN YOU NVIDIA! STOP INTENTIONALLY BREAKING SUPPORT FOR OLDER CARDS TO FORCE USERS TO UPGRADE!

Darkfalz
09-04-05, 03:13 AM
Can anyone with an FX card (even a 6x00 card) go into the options for NVIDIA DVD/PureVideo decoder and tell me what interlacing options they have?

In 61.77 I have
Display fields seperately
Combine fields
Blended clip
Adaptive

In 71.89 and later I only have
Display fields seperately
Combine fields

(Plus as I said, playback is buggy).