PDA

View Full Version : drivers for decent dvd playback on a 6600


RanCorX2
09-22-05, 04:56 PM
can someone recommend a few sets that offer good playback for dvds on a 6600?
do i really need dthe latest drivers, i've been getting the following problems with dvd playback;

small playback pauses, like a stutter.

small to big areas of tearing (only seems to occur in vmr mode)

interlacing is dodgy in places, jagged lines & flashing lines when movement happens.

a bsod from win32k.sys

I watch more videos on my pc than play games, I'm looking for that special driver that has good fps and good playback.

Peoples-Agent
09-22-05, 05:52 PM
Try the 77.77 HDs from www.tweaksrus.com , never had a problem with them.

RanCorX2
09-23-05, 03:14 PM
they seemed pretty good for vmr dvd playback but still had some micro pauses, i hate micro pauses, you get them when a sudden movement happens or when the video is slowly panning across to something.
I asked earlier how use the post processor filter from the nvidia decoder (nvvpp)
I think its supposed to switch to software mode and show up in the decoder properties, but havn't been able to activate it yet, I tried enable for nstant but the program crashed on launching. Is the nvvpp.ax filter anygood really?

better still whats the best option to use? software, overlay or vmr7,9, nvvpp
hope someone can help me. :)

sharangad
09-23-05, 04:09 PM
better still whats the best option to use? software, overlay or vmr7,9, nvvpp
hope someone can help me. :)

The overlay, VMR7 and VMR 9 options relate to the Enhanced nView display mode ( which relates to playing back DVDs on multiple monitors. If you don't believe me look up the option on the PureVideo decoder ). Most people have got it into their heads that this relates to whether the Purevideo DVD decoder uses Overlay or VMR, but this setting is controlled by Windows Media Player 9/10, under Tools/Options/Performance/Advanced, and there're two VMR settings, one for regular videos ( VMR overlay, VMR Highquality, VMR turned off ( hardware overlay) ) and undeneath there's another section for DVD playback ( overlay and VMR settings ).

I too have been experiencing the micro pauses. I don't really know what causes it except that it didn't happen before the latest PureVideo version 1.02.150. It didn't use to happen with the older versions and possibly earlier drivers.

I haven't really played around with older driver/decoder/options. Also with various driver and decoder versions, there are different options for deinterlacing.

RanCorX2
09-23-05, 04:20 PM
i'm using zoom player inconjuction with the purevideo decoder, I never had a problem with using vmr rendering before forceware 61.76 after that they went down hill for dvd playback.

micropausing & a small area in fullscreen vmr mode that shows tearing, (said about it before) its a small rectangle top right of screen when watching a video thats running in vmr mode and is fit to the whole screen, and sometimes theres full tearing like in games.

thought it might just be my 5600 which i had untill recently, but i was annoyed to find it still occurs on a totally different card.

RanCorX2
09-24-05, 01:27 PM
I set the de interlace setting to auto instead of smart and it remove the pausing for me. (only tested 1 movie sofar) "sahara" when the logo comes together when you first start playback the stars that fly in apear to jerk. set deinterlace to auto from smart and no jerky stars.

sharangad
09-24-05, 04:11 PM
I set the de interlace setting to auto instead of smart and it remove the pausing for me. (only tested 1 movie sofar) "sahara" when the logo comes together when you first start playback the stars that fly in apear to jerk. set deinterlace to auto from smart and no jerky stars.


Actually now that you mention it, the release notes for the PureVideo 1.02.150 did say that they'd changed the default deinterlace mode from auto to smart, so that's proly it.

RanCorX2
09-24-05, 04:40 PM
yea I seem to now remember them mentioning that, personally i see no difference between auto & smart.

CainSyris
09-27-05, 04:05 AM
I set the de interlace setting to auto instead of smart and it remove the pausing for me. (only tested 1 movie sofar) "sahara" when the logo comes together when you first start playback the stars that fly in apear to jerk. set deinterlace to auto from smart and no jerky stars.


If you read the Purevideo file that describes the various settings, you'll figure out the cause of this. Your jerky framerate issue is actually tied to your refresh rate. I have an InFocus 4805 projector that has a resolution of 852x480, which I have to put to 848x480 for it to work with a PC. The natural refresh rate is 48hz (24 for movie fps per second x 2) and the natural for most PCs is 60 (or the 30 of TV fps x 2).

Part of what the decoder does is take programming that is 24 fps and make it 60 fps for monitors that support that resolution. So if you find that movies are jerky on a 60hz refresh rate, then you're suffering from a bad conversion of smooth quality on film videos. If you're like me and you suffer from jerky playback on TV-based material, it's because the 30 fps to 24 fps (x2=48) is poor.

Keeping all this in mind, when you switch from Smart to Automatic on the settings of the nVidia Purevideo option, you are changing it from scanning the video to set the best setting to instead accepting whatever the disc says it is. Most of the time, this will work fine. This removes some special tricks that nVidia has developed to make their playback look the sharpest, but that still can help you in content where the nVidia decoder makes a mistake in trying to fix the refresh rate issues.

All that said, there are instances where a 30 fps video will mistakenly be flagged 24fps. In circumstances such as this, the video will suffer degradation in quality. Smart setting was made to overcome this by letting the video card detect for itself what settings it needed and changing on the fly.

The problems with jerking that we both have (and which cannot be fixed by setting automatic on my card) is a problem nVidia is having with the VMR subsystem built into their video cards. It is well-documented, long-standing, and will likely be fixed as part of the new drivers. (80 series)

For now, nVidia's obsessed with fixing SLI because all of 1 percent of their marketbase have it. ;)

RanCorX2
09-27-05, 07:31 AM
If you read the Purevideo file that describes the various settings, you'll figure out the cause of this. Your jerky framerate issue is actually tied to your refresh rate. I have an InFocus 4805 projector that has a resolution of 852x480, which I have to put to 848x480 for it to work with a PC. The natural refresh rate is 48hz (24 for movie fps per second x 2) and the natural for most PCs is 60 (or the 30 of TV fps x 2).

Part of what the decoder does is take programming that is 24 fps and make it 60 fps for monitors that support that resolution. So if you find that movies are jerky on a 60hz refresh rate, then you're suffering from a bad conversion of smooth quality on film videos. If you're like me and you suffer from jerky playback on TV-based material, it's because the 30 fps to 24 fps (x2=48) is poor.

Keeping all this in mind, when you switch from Smart to Automatic on the settings of the nVidia Purevideo option, you are changing it from scanning the video to set the best setting to instead accepting whatever the disc says it is. Most of the time, this will work fine. This removes some special tricks that nVidia has developed to make their playback look the sharpest, but that still can help you in content where the nVidia decoder makes a mistake in trying to fix the refresh rate issues.

All that said, there are instances where a 30 fps video will mistakenly be flagged 24fps. In circumstances such as this, the video will suffer degradation in quality. Smart setting was made to overcome this by letting the video card detect for itself what settings it needed and changing on the fly.

The problems with jerking that we both have (and which cannot be fixed by setting automatic on my card) is a problem nVidia is having with the VMR subsystem built into their video cards. It is well-documented, long-standing, and will likely be fixed as part of the new drivers. (80 series)

For now, nVidia's obsessed with fixing SLI because all of 1 percent of their marketbase have it. ;)

--

awsome post man, auto fixes it mostly on my card but i still see a few small jerks in movement intensive scenes in parts. It only pi*ses me off because its basicly still the same dvd performance, image, stutters as on my last card 5600xt, which was pretty rubbish compared to a 6600. I was expecting flawless dvd playback :( I do hope nvidia sorts it out, I remember it was flawless back in the days of forceware 61.76 or below, but as you know they are reealllly old, and just to have perfect dvd playback it would be a bit of a downgrade to goback to them!

heres my overlay & vmr comparision;

overlay:

-smooth image
-small frame stutters on fast movement

vmr:

-parts of image are pixelated
-tearing top right of screen
-smother image than overlay but makes lights looks pixelated
-much more stutters
-fullscreen tearing in nstand when in windowed mode (does that make sense?)

misc:

-nstant sucks

sharangad
09-27-05, 08:43 AM
If you read the Purevideo file that describes the various settings, you'll figure out the cause of this. Your jerky framerate issue is actually tied to your refresh rate. I have an InFocus 4805 projector that has a resolution of 852x480, which I have to put to 848x480 for it to work with a PC. The natural refresh rate is 48hz (24 for movie fps per second x 2) and the natural for most PCs is 60 (or the 30 of TV fps x 2).


I watch my stuff on a PC monitor and I've never had jerking like this before with any other PowerDVD or WinDVD and much lesser graphics cards. Oddly enough it only happens on DVDs and not on MPEG-2 files taped by my PVR.

rdhw
09-27-05, 12:09 PM
The natural refresh rate is 48hz (24 for movie fps per second x 2) and the natural for most PCs is 60 (or the 30 of TV fps x 2).

Part of what the decoder does is take programming that is 24 fps and make it 60 fps for monitors that support that resolution.You are quoting data that is only valid for North America/Japan etc. In Europe, the fps rate for PAL DVDs is 25, not 30, and film-sourced material on PAL DVD is also speeded up to be 25 fps rather than 24 fps. So European users need to be looking at matchig a multiple of 25 for their vertical sync rate, not a multiple of 30.

RanCorX2
09-27-05, 01:27 PM
are you saying v-sync effects dvd playback? as i always have it off.

RanCorX2
09-28-05, 06:18 PM
i'm trying out reclock, seems to work well with some videos, still testing on dvds.

RanCorX2
10-02-05, 10:04 AM
I think I may of found a good settings mix for dvd playback on my 6600.

using purevideo .150 & fw 78.05

following settings for purevideo;

smart or auto
vmr9
vertical stretch
dxva

following settings for zplayer;

video decoder - nvidia nvdvd v3+
audio decoder - cyberlink powerdvd 6+
audio renderer - reclock audio renderer
video renderer - vmr9 windowed

everything else default.

sofar so good.

sharangad
10-04-05, 07:18 AM
Someone on usenet (alt.comp.periphs.nvidia) claims that changing the priority of the player app to high eliminates the mico-pauses.

RanCorX2
10-05-05, 12:15 PM
they've basicly gone with the 81.82 drivers :)

admiral1313
10-30-05, 05:26 PM
have this problem while using a TV for playback,try the following:

Set your TV's resolution to 720x576.Then select the 50Hz refresh rate (if you're using a PAL tv of course).The stuttering should be gone.