PDA

View Full Version : SLI locking up games while loading


cyberbloke
09-25-05, 02:27 PM
I'm having trouble running certain games with SLI enabled.

Both Sims 2 and GTA San Andreas frequently lock up on loading with SLI enabled, but run fine without it.

Half Life 2, however, runs like a dream in SLR.

Am I doing something wrong or is this just something I have to live with?


Processor: FX-57
Operating System: XP
Mobo: ASUS A8N-SLI DELUXE
RAM: 2 GIG DDR
Video: 2X 7800GTX
Audio: X-FI FATAL1TY

OWA
09-25-05, 02:32 PM
Are you using stock settings for everything? If not, try running at stock speeds first just to eliminate any chance overclocking might be causing it. If you're not overclocking anything, try relaxing your RAM timing. What kind of power supply do you have?

cyberbloke
09-25-05, 03:14 PM
Thanks for the reply.
I haven't overclocked the cards, but thay came pre-clocked to 491Mhz which I understand is faster than stock. Could the factory overclock be a problem?

I've tried all sorts of RAM timings as I thought my RAM was the problem at first, so I don't think that's a factor.

My power is provided by a Jeantech 600w Arcitic PSU. I doubt this is the cause of my problems as I can happily play HL2 in SLI for hours without a hitch.

It just doesn't seem to like certain games.

keith33
09-25-05, 03:52 PM
What brand is your video card(s)?

ascully
09-25-05, 04:18 PM
Sims 2 & SA actually lock up for me in SLI as well, maybe its a driver issue as I have no problems in any other games. Or maybe the games dont like the widescreen resolution I use, do you have a widescreen monitor by any chance?

PSYCHODAD
09-25-05, 04:58 PM
Don't know if it's the same thing that was happening to me, but I was having lock-ups with certain games(while loading) and come to find out that anytime my system went on standby it would cause the lock-up after waking from standby. As long as the system wasn't allowed to go to standby, it would be fine.

78.01 drivers btw.

cyberbloke
09-26-05, 06:23 AM
Thanks to everyone who is trying to help.

The cards are made by XFX.

I am using a widescreen monitor, resolution 1680x1050. Although Sims 2 does not give this resolution as an option, STA San Andreas does apparently offer widscreen support. Both run fine in widescreen without SLI, but you could be onto something.

I doubt it's a standby problem, as during testing I normally try to load up the games straight after booting up.

JaxMacFL
09-26-05, 03:06 PM
Thanks to everyone who is trying to help.

The cards are made by XFX.

I am using a widescreen monitor, resolution 1680x1050. Although Sims 2 does not give this resolution as an option, STA San Andreas does apparently offer widscreen support. Both run fine in widescreen without SLI, but you could be onto something.

I doubt it's a standby problem, as during testing I normally try to load up the games straight after booting up.


I play GTA: SA in widescreen at 1920 x 1200 resolution with SLI just fine. Here is the settings I use:

AA......App Control
AF......16X
IS.......HQ
VS......Off
FMM....None
TO......Off
AMFO..Off
ASO....Off
GCA....On
TA......Supersampling
TB......Off
SLI RM.AFR
NLODB.Clamp

Good luck!

OH, Drivers 78.03

cyberbloke
09-27-05, 02:21 PM
I play GTA: SA in widescreen at 1920 x 1200 resolution with SLI just fine. Here is the settings I use:

AA......App Control
AF......16X
IS.......HQ
VS......Off
FMM....None
TO......Off
AMFO..Off
ASO....Off
GCA....On
TA......Supersampling
TB......Off
SLI RM.AFR
NLODB.Clamp

Good luck!

OH, Drivers 78.03

Thanks for the advice. How can I change the settings to AFR? I've got nHancer but it tells me the SLI settings are locked by the driver.
It seems that it is only non-AFR games that cause problems for me.

JaxMacFL
09-27-05, 03:04 PM
This link will show you everything you need to do:


http://www.nvidia.com/object/slizone_sliAA_howto2

cyberbloke
09-28-05, 07:33 AM
Thanks for the link. GTA loaded up fine first time with your settings and played well.
Second thime I tried it, the screen blanked while loading, came back, then the computer crashed!

odin20
09-28-05, 02:24 PM
I have similar problems with planetseide etc.
With sli on and verticle sync enabled it will lock up while loading new maps (continents) as soon as you get in game. If i shut off vsync i can use all the sli modes and never lock up. Try setting vsync to off.
Something in the drivers(all of them so far) has a problem with vsync enabled on lcd's. Hell its not even available in afr modes yet. Cmon nvidia.

JaxMacFL
09-29-05, 10:31 AM
Thanks for the link. GTA loaded up fine first time with your settings and played well.
Second thime I tried it, the screen blanked while loading, came back, then the computer crashed!

Maybe an in-game setting is causing that. Here is what mine are:

Draw Distance......Max
Frame Limiter.......Off
Widescreen..........Off (cause I have a widescreen)
Visual FX Quality...Very High
Mip Mapping.........On
Anti Aliasing..........2

Hope that helps.

JaxMacFL
10-07-05, 03:01 PM
Thanks for the link. GTA loaded up fine first time with your settings and played well.
Second thime I tried it, the screen blanked while loading, came back, then the computer crashed!


cyberbloke:

When I upgraded to the 81.84 drivers, I got the same game response as you have been describing. Turns out you can not set the AA by the in-game option without having to delete the gta_sa.set file everytime you want to start the game. Seems like the only AA setting it likes is the 2x via the nvidia control panel. Tried and tested just fine on this end. Must be a driver issue cause I didn't have that annoyance with the 78.05 drivers. Anyway, after playing around with the settings, both in-game and nvidia control panel, I have found this works. First, go into My Documents\GTA San Andreas User Files and delete the gta_sa.set file. Then set the 2x AA via the nvidia control panel along with the other control panel settings you were using. Now start the game and use all the other in-game settings as before except leave the in-game AA option off.

Good Gamin'

JaxMacFL

cyberbloke
10-08-05, 09:06 AM
The 81.84 drivers actually see to have solved all my problems. GTA and Sims 2 work fine in SLI at last.
I'm assuming the factory-clocking of my 7800GTXs was causing some problems, and the more forgiving new drivers are allowing me to use them properly at last.
Thanks for all the help.

JaxMacFL
10-08-05, 07:16 PM
The 81.84 drivers actually see to have solved all my problems. GTA and Sims 2 work fine in SLI at last.
I'm assuming the factory-clocking of my 7800GTXs was causing some problems, and the more forgiving new drivers are allowing me to use them properly at last.
Thanks for all the help.


LOL, great to hear. What is someone's problem is someone elses' solution. Awesome game, GTA: San Andreas. So much to do in it. Don't know about Sims, but what I've read, they cover the whole realm of life.

Later,

JaxMacFL

Muppet
10-09-05, 03:06 AM
Well i finally managed to download the 81.84s and now no more crashes to the desktop. :)

cyberbloke
10-10-05, 08:09 AM
Well i finally managed to download the 81.84s and now no more crashes to the desktop. :)


Good to hear Muppet, enjoy