PDA

View Full Version : A7N8X Deluxe-Beware of Slots 2&3 if using AC7!


Mike89
12-29-02, 10:26 PM
Man what an experience I have had with this motherboard and trying to get the onboard sound to work.

This is what I have found out through a lot of time consuming checking.

I have a PCI modem and a Winfast TV2000XP tuner card.

The onboard sound will not work when either of these cards are plugged into PCI slots 2 or 3.

I can use slot 4 and both the PCI device (either one) and the onboard sound will work. I haven't tried slot 5 yet.

This is what this hassle has cost me. I RMAed the board because I had not figured this out at that time. I just could not get the onboard sound to work. At that time I did have the modem into slot 2.

When I got the second board, it did exactly the same thing! I started messing around and first removed the TV Tuner. Still no sound. I then removed the modem from slot 2. Now I finally had onboard sound. At that time I had the TV tuner in slot 4.

Well then my tv tuner starts messing up. The sound would cut out after the tuner was on for a minute or so.

So I said hell with this and disabled the onboard sound and put my Santa Cruz sound card back in. Well the TV tuner sound did the same thing. I emailed Leadtek and found out that the sound cut out problem with the TV tuner was related to Norton Antivirus 2003 monitoring MSN Messinger. I unchecked the monitor for that in the antivirus and it solved the tuner sound cut out problem.

OK by this time I had re-arranged my sound card, TV Tuner, and modem in different slots and all were working fine.

Now I start thinking about my original problem again. So I go and buy a US Robotics External modem for $100 thinking my PCI winmodem just was not compatible with the onboard sound.

Now I figured I will go back to the onboard sound. So I take out my Santa Cruz sound card, and PCI modem, hook up the external modem, boot up, and guess what? No sound!

&%$@)*^&%#!@(&%&^*

Now I'm REALLY tripping. The only device left in (besides the vid card) was the tv tuner card. I take the tv tuner card out, boot up and guess what? I have sound!

Jeez jeez jeez!

The TV Tuner had been in slot 2, the same slot the modem had been in what I experienced my first onboard sound problems. So now I have isolated that slot 2 is the issue.

I then put the TV Tuner card in slot 3, boot up, and guess what? No sound!

*^#$@!)&*()^%$#@*&^

So now I figure that for some reason, slot 2 and 3 have an issue with the onboard sound.

Then I drop the TV Tuner in slot 4, boot up, and guess what? I have sound.

Now I have onboard sound, TV Tuner working right, and external modem (through serial port) working right.

I sure don't know what the deal is here with slots 2 and 3.

I would be interested to know just what slots you A7N8X Deluxe owners, who are using the onboard sound, are using.

This is really screwed up. I don't use slot 1 because it's just too close to the vid card (and upcoming NV30 is supposed to take up that slot anyway). Now I can't use slot 2 and 3. That leaves slots 4 (which I've tried) and 5 (that I haven't tried yet) to use.

That's pretty flaky if you ask me. Now with using a sound card, then all slots can be used (I know this because I had tried them all with the sound card, tuner and pci modem trying to get the best IRQ spread).

I would love to hear comments on this.

Cotita
12-30-02, 10:21 AM
probably the MCP doesn't like irq sharing.

BTW a good rule of thumb says to install your pci cards on the farther pci slot, specially soundcards and video capture cards.

styles-T
12-30-02, 11:14 AM
What Revision Bios do you have ??

I hear the 1001c is having tons of problems..

Gator
12-31-02, 06:21 AM
Originally posted by Mike89
Man what an experience I have had with this motherboard and trying to get the onboard sound to work...

This is VERY interesting info because myself and others have considered this board. You should report your finding to Asus, maybe they could make a BIOS workaround. It isn't fair for anyone to be forced to spend an extra 100bucks on an external modem, or go thru the extra hassel that you did. :(

Do you have the latest bios installed?

Mike89
12-31-02, 10:20 AM
I didn't really have to get the external modem. I got that before I figured out the issue with slots 2 & 3 with onboard sound enabled. The original PCI modem would have worked if I would have put in Slot 4 (with nothing else in slot 2 & 3). I was just too dumb to figure it out BEFORE I bought the external modem. I decided to keep the external modem anyway cause it's just a better modem than the winmodem I had.

Like I said earlier, if you disable onboard sound and use a sound card, then all slots will work.

It's that old saying, you don't get anything for nothing. Use sound card, have to use the slots. Use onboard sound, lose 2 slots anyway.

DaveW
12-31-02, 10:39 AM
Ahhhh good old IRQ conflicts... Despite all the improvements to PC architecture over the years we still have to deal with this (fun) from time to time. I prefered the old days when you had to assign a card an IRQ by setting jumpers on it. Atleast then you knew for sure if your sound card and NIC were sharing an IRQ.

Its like those questions on GCSE maths tests, when you have 5 people and 5 chairs and you had to sit them according to their preferences. the question goes something like "Jane wants to sit next to John, John doesn't like sitting next to Jill, Jill and Jane both want to sit next to Joseph, Josh wants to sit next to Jill". It seemed pointless at the time, but all along you were really learning how to troubleshoot IRQ conflicts! :)

saturnotaku
12-31-02, 10:49 AM
Originally posted by DaveW
Its like those questions on GCSE maths tests, when you have 5 people and 5 chairs and you had to sit them according to their preferences. the question goes something like "Jane wants to sit next to John, John doesn't like sitting next to Jill, Jill and Jane both want to sit next to Joseph, Josh wants to sit next to Jill". It seemed pointless at the time, but all along you were really learning how to troubleshoot IRQ conflicts!

From left to right:

John, Jane, Joseph, Jill, Josh

Sorry, couldn't resist. :D