PDA

View Full Version : "Popping" sound in FEAR


Lazaredz
10-19-05, 06:03 PM
I'm getting a weird "popping" constantly when playing FEAR. Seams to come from all speakers. I have never had this problem before with any other game (HL2, D3, Q4, etc). I tried turning the hardware acceleration on/off as well as EAX 2.0 and all combinations of the two, doesn't seem to change anything. I'm using a SB Live that I have had for years (without problem) and a Cambridge Soundworks 2000 4.1 set (again, for years no other problems). I have the latest drivers that Creative provides for them. Any ideas?

I would not be adverse to using "modified" drivers if anyone could suggest some. I have had good luck with the XG versions of NV's drivers, so I feel okay with doing the same with my audio.

Thx in advance

DJMONDY
10-20-05, 05:20 AM
I'm getting a weird "popping" constantly when playing FEAR. Seams to come from all speakers. I have never had this problem before with any other game (HL2, D3, Q4, etc). I tried turning the hardware acceleration on/off as well as EAX 2.0 and all combinations of the two, doesn't seem to change anything. I'm using a SB Live that I have had for years (without problem) and a Cambridge Soundworks 2000 4.1 set (again, for years no other problems). I have the latest drivers that Creative provides for them. Any ideas?

I would not be adverse to using "modified" drivers if anyone could suggest some. I have had good luck with the XG versions of NV's drivers, so I feel okay with doing the same with my audio.

Thx in advance

Im getting the same problem:confused:Ive got the same sound card as you too.

If you find a fix let me know and i'll do the same if i do.

Cheers :)

BioHazZarD
10-20-05, 05:49 AM
Im sure its your soundcard, better ask this in the fear forums if more then you have this problem.

agentkay
10-20-05, 10:00 AM
I have sound issues as well, minor popping but thats not a big issue. However, I canīt hear the radio messages when I enable the HW mixing setting. EAX2, and EAXHD make no difference, but I doubt they work without enabled HW mixing anyway.

I donīt really want to disable these settings because they do improve sound a lot, especially if you are using 5.1 AND addionally when I disable them, my framerates drop as well.

Iīm using a Soundblaster Audigy 2 ZS, with 2.05.0000 drivers but I just checked the Creative site and they have a new version out, 2.08.0002. Iīll check if they do a better job.

Lazaredz
10-20-05, 10:13 AM
Well, did a bit of work last night and came up with an improvement at least. I had CThelper running in the background (didn't realize it as I had just updated my drivers manually from Creative). Anywho, on vugames FAQ site for FEAR they mention turning this off. Did so and rebooted and at the very least it seemed that I only got the repeating popping AFTER a distorted "unknown source" radio message came in. I again did the HW/EAX on/off bit and noticed no differance in the popping, so I have left them on for now.

Not a fix, but it at least helped for me.

EDIT: vugames forums are still down, but a search did reveal about 3-4 different threads stating a simular problem with the LIVE cards. It is also in their "tech issues we are aware of" thread. I'll update more when the forums come back online.

SLippe
10-20-05, 10:17 AM
I have the same card and had the same issue, at first. I unchecked EAX 2.0 and Hardware Mixing. Whala! Gone. And I couldn't tell any difference in the sound quality either. I guess I could disable CTHelper, but I haven't had too so far. Also, I have the Music off in the game. It's creepy enough without it. LOL

zoomy942
10-20-05, 08:40 PM
I have the same card and had the same issue, at first. I unchecked EAX 2.0 and Hardware Mixing. Whala! Gone. And I couldn't tell any difference in the sound quality either. I guess I could disable CTHelper, but I haven't had too so far. Also, I have the Music off in the game. It's creepy enough without it. LOL


okay, i love you guys and everything, but this goes on my dry-erase board as just aonther reason i love my nvidia sound:)

Slybri
10-20-05, 08:47 PM
I have the same problem. Driving me nuts. I almost turned around and shot at it once.
I think Creative put that in there so it would push gamers to go buy their new X-Fi cards. I hate Creative. Buggiest drivers ever.
Still, I think I'm gonna get me one of those X-fi cards...

zoomy942
10-20-05, 08:50 PM
I have the same problem. Driving me nuts. I almost turned around and shot at it once.
I think Creative put that in there so it would push gamers to go buy their new X-Fi cards. I hate Creative. Buggiest drivers ever.
Still, I think I'm gonna get me one of those X-fi cards...


nooo!! the dark side has you young skywalker!!

:):)

Lazaredz
10-21-05, 10:07 AM
Okay,so after some digging it would seem that the driver set 5.12.1.226 (or the misnamed 5.12.2.226) is the last set out from creative, labeled Feb 2003. I then come upon the kxproject.com and their drivers. While still almost a year old, its the newest, most referanced unofficial drivers I could find for SB Live. Went ahead and replaced my old drivers the the kx ones and seem to be very happy. Popping sound in FEAR is gone with minor problems.

1: For some reason the front/back speakers are mixed up. They explain this in the kx project and have a default correction in their mixer. I however don't want anything more than necessary running in the background of my games, so I turned the mixer off and just changed the F/R plugs in my soundcard.

2. While testing for FEAR I noted that if you turn on HW accelleration for sound, you will loose sounds originating from the character (ie: gunfire, grunts, etc). EAX 2 seems to have no effect.

3. I noticed no change in my ingame performance tests (with EAX on or off).

Anywho, it took the popping away, so I'm happy.

Also, I did confirm the problem on the vugames boards and mentioned that there were a few others with this issue over here, so hopefully vu will address it in a patch or find a true fix.