PDA

View Full Version : Cannot disable SLI!


gzunk
10-23-05, 11:39 AM
Has anyone else got this problem? I run a dual monitor setup, with each monitor plugged into separate cards. Upgrading to 81.85 was good - no longer having to reboot when switching to SLI, but now I can't get back!

Whenever I uncheck the SLI checkbox and click apply, it just puts the tick straight back in. The only way I've found to get round it is to boot into safe mode, remove the drivers and then re-install them.

Does anyone know of an easier way to turn off SLI?

SignorSalad
10-24-05, 09:43 PM
I have a similar setup and sometimes have the same problem.

My 2 monitors are plugged into the same card though: card #1

I will switch into and out of SLI frequently with no problems.. however every now and then when I switch into SLI, it requires a reboot for whatever reason. It says to enable SLI, I must reboot. So I do. But I find that when that happens, when I go to try and switch out of SLI, it will not let me out. I uncheck, hit apply or ok, and it acts as if its happening, but then comes back with SLI checked.

When this happens, I just reload 81.85 on top of the old one, and then reboot and its fixed. Very annoying, but I figure this functionality is so new that a few bugs remain.

Peoples-Agent
10-25-05, 12:51 AM
Does leaving SLi enabled all the time cause any problems if dual displays aren't your bag? ....just wondering.

gzunk
10-25-05, 05:02 AM
If I didn't have the dual displays then I would leave SLI enabled all the time.

I'll try and and re-install 81.85 over the top and see if that gives me the same behaviour as with SignorSalad... (Here's hoping)

superklye
10-25-05, 07:25 AM
I reinstalled with the WHQL 81.85 drivers and will test tonight to see if it happens again. If it does, I'm dropping these drivers FAST.

Did anyone have this problem with the 81.84? And apparently THOSE don't require you to restart for SLI even though the 81.85s say you don't, they still make me.

Strahd
10-25-05, 11:39 AM
I enabled SLI using non-WHQL 81.85 without a reboot. I leave SLI enabled so I haven't tried to turn it off to see what happens. I can try it and post back tonight when I get home from work

gzunk
10-25-05, 12:36 PM
I re-installed the 81.85's over the top and successfully got out of SLI mode!

Since it doesn't happen (too) often, I can live with this work-around until the next driver fixes it (hopefully)

SignorSalad
10-25-05, 07:30 PM
I reinstalled with the WHQL 81.85 drivers and will test tonight to see if it happens again. If it does, I'm dropping these drivers FAST.

Did anyone have this problem with the 81.84? And apparently THOSE don't require you to restart for SLI even though the 81.85s say you don't, they still make me.

the 81.85's only sporadically make me reboot. Usually I can switch in and out with no problem. However when they do, I know that I'm probably going to have a problem getting it out of SLI mode.

superklye
10-25-05, 08:26 PM
Damn it. I'll see what happens tonight and if the .85s keep doing this, I'll try the .84s and see if those fare any better.

ricercar
10-25-05, 11:45 PM
Does leaving SLi enabled all the time cause any problems?Not for me. My SLI rig is in SLI mode and powered on 24/7 with no problems. YMMV.

Blacklash
10-26-05, 12:12 AM
Leaving SLi on causes no problems.

If you are having trouble switching off SLi flip the paddle card on your motherboard between your two video cards. One side is specifically for non SLi operation.

SignorSalad
10-26-05, 07:42 AM
Leaving SLi on causes no problems.

If you are having trouble switching off SLi flip the paddle card on your motherboard between your two video cards. One side is specifically for non SLi operation.

That is not the issue. My DFI does not have a paddle card, it uses jumpers only. And the jumpers are definitely set to enable SLI. But even if you have it set to enable SLI, you are supposed to be able to turn SLI on or off, regardless.

Blacklash
10-26-05, 09:20 AM
I have the 81.85s in my system. I can disable SLi or enable it without a reboot. The only time I was made to reboot was the first time I installed the driver. I have a single LCD connected to the top video card and am using the DVI connector closest to the motherboard. I tried unticking then ticking SLi in the driver CP and running 3dmark05. It was definitely off then on.

The hardware adjustment was meant to be a last resort suggestion.

Goodluck resolving the issue.

EDIT: To the OP, Something that may be worth trying.

Before you disable SLi in your driver CP under nView display settings set it to single display and select your number 1 display as primary|default.

Under Performance and Quality load your global driver settings. Select advanced and then go to SLi rendering mode and set that to single-GPU rendering.

Now go to the SLi multi GPU and tick for off. See if it sticks.

SignorSalad
10-26-05, 10:32 AM
The hardware adjustment was meant to be a last resort suggestion.




I meant to say that disabling SLI via the paddle or jumper or whatever is an extremely unviable solution. Having to reboot your machine just to switch into and out of SLI was already bad enough, but having to open your case to swap jumpers (not very easy on the DFI board) to go back and forth between SLI is not really something I think any normal user would be willing to do. Especially since we are now spoiled because the driver works part of the time and allows a switch without a reboot.

Since switching into and out of SLI works for you 100% of the time, it leads me to believe that this problem only impacts Dual Display users. The other suggestions might be a workaround.. I'll definitely try it when I am able later this evening. But I believe that when in SLI, the nview display settings is already on Single Display mode. If thats the case there'd be nothing to change there. In my situation though I'd have to test out the other part repeatedly in different gaming situations, as the sticking behavior only happens sporadically.

Hrrmm, Perhaps the bug is reproducible depending on whether you play an OpenGL game or a DX game.

SignorSalad
10-26-05, 05:08 PM
looks like some of our problem is now addressed in the 81.87 beta:

# GeForce 7800 GT/GTX, GeForce 6800 Ultra, SLI: The NVIDIA panel intermittently prompts for a reboot after enabling dynamic SLI coming out of Dualview.
# [SLI]: It is not possible to reliably switch the output to a specific display after enabling SLI.
# [SLI]: The screen goes blank after switching to the flat panel display on the second GPU once after rebooting the system.

superklye
10-26-05, 05:25 PM
Hmm...sweet. Maybe I'll install those (81.87) tonight and give them a try. After 81.85 nearly ruined my monitor last night, I went to .84 which worked like a dream. SLI enabled without a reboot and disabled without, well, not disabling.

SignorSalad
10-26-05, 09:40 PM
So far so good. Switching into and out of SLI has been fine so far with 81.87

Blacklash
10-27-05, 12:02 PM
Glad it is now working.

In hindsight, the best hardware approach would have been disconnecting the alternate panel from the secondary video card at the card connector|output, that way you circumvent having to open the case. If that failed to defeat the problem then proceed to jumpers|paddle cards.

I am with you on believing perhaps the driver was detecting the second monitor on the second card and refusing to switch off SLi because of the dual display set up in that manner.

Personally, I do not know why one would be that desperate to defeat SLi and I tend to put ideas out there to let the end-user think for themselves. They will decide if something is worth their time and trouble.

Jimi
10-27-05, 02:55 PM
Has anyone else got this problem? I run a dual monitor setup, with each monitor plugged into separate cards. Upgrading to 81.85 was good - no longer having to reboot when switching to SLI, but now I can't get back!

Whenever I uncheck the SLI checkbox and click apply, it just puts the tick straight back in. The only way I've found to get round it is to boot into safe mode, remove the drivers and then re-install them.

Does anyone know of an easier way to turn off SLI?

So is your issue fixed with 81.87?

SignorSalad
10-27-05, 05:31 PM
I am with you on believing perhaps the driver was detecting the second monitor on the second card and refusing to switch off SLi because of the dual display set up in that manner.



Don't know about the others, but I have both displays hooked up to the same card.. card #1. Either way, hopefully its not an issue anymore (although I still haven't gone into and out of SLI quite enough yet to be totally convinced its fixed yet.)

Jimi
10-27-05, 06:16 PM
Don't know about the others, but I have both displays hooked up to the same card.. card #1. Either way, hopefully its not an issue anymore (although I still haven't gone into and out of SLI quite enough yet to be totally convinced its fixed yet.)


Why dont you try 81.87 and let us all know. I don't have 2 displays to try this on.

SignorSalad
10-27-05, 06:52 PM
Why dont you try 81.87 and let us all know. I don't have 2 displays to try this on.

Read about 5 posts up bro.

Jimi
10-27-05, 07:03 PM
Read about 5 posts up bro.

Hehe ok I wasn't sure if you had any more extensive testing done yet.

SignorSalad
10-29-05, 08:17 AM
Although I still haven't tested it quite that much, so far I have yet to have any problems switching into and out of SLI with 81.87. Although I did get some hard locks and even a hard reboot with Lost Coast, but thats for another thread.