PDA

View Full Version : X-Fi 64-bit beta drivers!


facade
11-12-05, 08:37 PM
Link to the drivers in this thread - http://forums.creative.com/creativelabs/board/message?board.id=soundblaster&message.id=37793

And confirmation posts in this one - http://forums.creative.com/creativelabs/board/message?board.id=soundblaster&message.id=37654&view=by_date_ascending&page=1

I haven't tried them yet; my X-Fi is still on its way. Good luck! ;)

jolle
11-13-05, 07:22 AM
So its really a Vista driver.. but the people on that forum seems to say that it should work on XP x64, even tho it doesnt list a beta driver on Creatives site..
So my question is, Why the hell release a beta driver for Vista, and NOTHING for XP x64 which is acctually a released fully operational OS... even if this Vista 64bit driver will work on x64..

EDIT
Sofar so good, they DID install and I got atleast basic sound output now, which is a step forward if anything..
gonna try to find my driver CD and se if I cant install some of the apps like the CP and that..

EDIT II
The creative stuff off the CD (minus the driver and some crap which I chose not to install) installed just fine, CP works fine.
Ran Theif 3 and it worked perfectly (the 1 min i tried it) with all the EAX stuff enabled.. HD advanced, Multiple enviroments etc..
Seems to work fine.

EDIT III
Prolly the "mother of tests" hehe.. it ran BF2 fine on X-Fi soundsetting.
only tried 3mins SP, ill play more online later.. seems to work atleast, good news.

jAkUp
11-13-05, 01:34 PM
Dammit right WHEN MY ****ING OPTICAL DRIVE IS DEAD! **** :(

I guess I will just go get a cheapy DVD Rom :(

jolle
11-13-05, 04:57 PM
headphones on BF2 sound a bit like the sound was behind me.. something was bit off atleast..
but it was stable atleast and ran great.

jAkUp
11-13-05, 05:29 PM
Link is dead :( Damn.

jolle
11-14-05, 01:39 PM
link seems to work again..
Think its creatives standard "download driver" site... entire US site was fubar this morning it seemed..