PDA

View Full Version : Bug received by PM (DONT DO THIS PLS)


Superfly
12-09-05, 04:48 AM
Text copied from PM:
Hi.

I read a post you wrote saying that you can submit bugs so I think it would be cool if you could submit this bug report to nvidia.

Bug: Halo Active Camoflauge rendering.

Problem: Active camoflauge does not render properly. Light does not bend, but simply passes through.

GPU/Hardware specifications: I don't own a geforce FX, 6, or 7 series so I can't give you any detailed reports except it occurs on all these video cards and has nothing to do with any hardware problems.

Screenshots: The link below has screenshots. Though the article is old the bug still exists.

http://www.digit-life.com/articles2/digest3d/0904/itogi-video-gallery-bugs.html

Ok: Here's everything I know about the bug.

1. It occurs on all FX, 6 series, 7 series cards. From reading several forum posts, it occurs only on these cards. The fact nobody has mentioned this problem on the geforce 4 or 3 tells me that it this bug does not occur on these cards.

2. It works under 3danalyzer if some pixel shader 2 is forced. However, chat text disappears in halo. Not an acceptable solution.

3. It also works with a "far cry fix." It supposedly replaces a key file, something like "direct3d9.dll" in the program files\ms games\halo. It fixes the bug, but like 3danalyzer, the in-game text disappears.

4. The problem is that the camo looks like if the fixed function path is being used. To activate fixed function add in -useff to the command line for the halo shortcut. You can also see in screenshots at the digit life link above.

Here's a link in which a bungie programmer says that there are no plans to make any changes to Halo other than security fixes since the development team has gone off to work on other projects. The post is in yellow text under the name sawnose.http://bungie.net/Forums/posts.aspx?postID=3408405&postRepeater1-p=3

Because bungie has given up fixing bugs, I think nvidia should step up and give the image quality their customers expect.

Here's a complaint from just 3 days ago regarding this bug. http://gbxforums.gearboxsoftware.com/showthread.php?t=49365

I forgot, the problem also occurs in halo custom edition.

I hope I can buy an nvidia card once this bug is fixed. Please send this bug report to nvidia.


If other users can confirm this as a genuine bug im sure either myself or Jimi would log it for you, please dont send me PM's with bug reports though - this is the place to post them and get then investigated/confirmed.

Many thanks - please help me to help you by posting your bugs were all others can see them!!!!!! (cheers)

Merry xmas all.

Superfly.(xmassign)

Gentle
12-09-05, 02:51 PM
Yes, this is a still a problem.

I have owned a Geforce 6600GT since December 2004 and never experienced the active camouflage in Halo or Halo CE because it is broken for whatever reason.

Gentle

GOZ
12-09-05, 08:17 PM
Same here its broke on a 6800NU

adpr 02
12-12-05, 11:02 PM
I have a 7800gt. I played halo on my brother's 9700pro, and I was BLOWN AWAY by the IQ. I cannot believe that his measly card plays a game better than I can. LOL (mikec) .... anyway. Tell me if U see a fix.

Dr@Home
12-13-05, 08:49 PM
This subject has come up time and time again over at Gearbox forums... still no fix, but every once in a while I read that a Nvidia card user has it working right (and no pics to prove it.) :(

Tried the farcry fix on my gf4ti4600 and 6800GT. Works fine on the 6800GT, but the GF4 DOES have the watery effect too (and a big color problem, like its magnifying what should really be there.)

Hope it can actually be fixed sometime.. :)

Superfly
12-14-05, 04:36 AM
I doubt it, Halo is long forgotten.

Electronic Punk
12-14-05, 08:15 AM
I know they fixed a bug, just before thanksgiving (whenever that was? :s) that I flagged up as critical.

That damn SLI capable thing popping up everytime and also the tastbar icon not remembering that I turned it off.

Fortuanately the fix will be included in the next release, whenever that might be ;D