PDA

View Full Version : Problems with games that use UT2004 engine


bonchez
02-11-06, 03:55 PM
I'm putting this in the games section and hardware section since this would be approate for both.

Ever since I upgraded my computer from an

Asus A7N8X Deluxe to a Gigabyte GA-K8U-939 ULi motherboard

Amd Athlon Xp 2800+ to a Amd Athlon 64 3500+

and added a 1GBPC3200 stick of ram to my computer

Any game that uses the UT2004 engine restarts the computer a random times. Games that do this include UT2004 (of course), Red Orchestra, America's Army, and Brothers in Arms Earned in Blood. There isn't much else to say but that. Can anyone help me?

Acid Rain
02-11-06, 04:08 PM
What kind of ram is it? Is it the same as the stuff you already had? Exactly the same?

Maybe take the ram voltage up a tad. Some ram, for instance, does much better on 2.8 volts when two 1gb sticks are used. Also, most ram manufacturers warrant their ram to run at up to 2.8 anyway.

Also, what PSU are you using? The system should be using less power than before if anything, but you never know.

Q
02-12-06, 02:28 PM
This sounds like the Windows DEP issue that was occuring for a while with Nvidia drivers. It only affected the Unreal engine, so it sounds a lot like the problem you were describing. I would upgrade the drivers first and foremost. Followed by disabling DEP if you feel like it.

bonchez
02-12-06, 03:08 PM
What does DEP mean?

I do have the 81.98 nVidia drivers, I could try the latest beta drivers if that may help.

Q
02-12-06, 04:06 PM
What does DEP mean?

I do have the 81.98 nVidia drivers, I could try the latest beta drivers if that may help.

DEP was some sort of virus protection thing introduced in SP2. However, your drivers are way too new to be effected by that.

Are you sure that its only in Unreal Engine games?

saturnotaku
02-12-06, 06:48 PM
Also, DEP is only available on Athlon 64 processors. He has an Athlon XP.

Q
02-12-06, 08:40 PM
Also, DEP is only available on Athlon 64 processors. He has an Athlon XP.

::slaps forehead for not paying attention::

Ah...but what about the 64-bit Intel processors??? You did say ONLY on Athlon 64 processors, didn't you Saturnotaku? :D

(Yeah, yeah, I know what you meant...)


Edit: ACTUALLY, if you read his post carefully, he upgraded FROM an XP TO a 64. :p

Greg
02-12-06, 09:04 PM
As the above posters say, you are quite possibly getting the old UT / Athlon64 / nVidia driver / WinXP SP2 bug. (No one owns up to who's fault this is.)
This issue usually occurs only on game exit however.

1) Stop your machine from repooting and display a proper blue screen error.
Right click MyComputer -> Properties -> Advanced -> Startup And Recovery Settings -> Uncheck Automatic Restart.

2) Disable DEP (Data Execution Prevention) follow instructions here: http://www.nvnews.net/vbulletin/showthread.php?t=36541&highlight=UT2004

Also, make sure your system is stable to begin with. Certain apps are more sensetive to hardware failures that others and most unstable systems relate to incorrect CPU/MB/RAM configuration. So download the latest MemTest and run that for a few full cycles with zero errors to be confident. Find out what your CPU and RAM speeds should be and make sure those numbers appear when the PC boots, or are visible in some system spec utility.