PDA

View Full Version : Toshiba M3 (GeForce GO 6600TE/6200 TE) drv problem.


bjg
02-19-06, 05:36 AM
Hello,

Happy owner of a thoshiba M3 laptop I need to be able to hot/key switch between
internal/external screen under Solaris. This is not an implemented feature currently,
so I would like to do twinhead display at least, switching manually between xorg
confs ...

I tried nvidia drivers, but could not have theim work.
I tried several driver release, ranging from 7667 to 8178.
I tried it on several Solaris / OpenSolaris releases.
I always had the same problem :
xorg logs complains about being unable to allocate DMA push buffer and aborts.
Full details are attached to the nvidia-SunOS-bug-report.sh generated bug report.

This bug report was ran on a std. default xorg config, but from the README,
I tried quite all device options tweeks I could thought of.

To conclude by extension to this problem, having hot-key switching
for laptop displays is (IMHO) a critical point for any laptop owner.
It should be added on the "wish list" for NVidia drivers.

Any thoughts, hints or help would be greatly appreciated.
Cheers,

bjg.

bjg
02-20-06, 04:13 PM
Hi,

I have had some progress, but things are not perfect yet.
I had put a mess by juggling with some wrong gfx_private stuff for my release.
This have been solved and I can use nvidia drivers for twin display now.

My problem now, is that on the flat panel I only see part of the full display whatever
is the resolution I choose (no more than 1280x1024 anyway), as it goes fine on the
external CRT. I can not pan as well, so it is somewhat unusable in standalone mode.
I suppose this is linked to the specific physical resolution of that TFT (1400x1050,
1280x960,etc... not multiple of standard resolutions.)

I will stop post for now to avoid poluting that forum, but still watch the thread.

If someone can help, thanks in advance.
If I find an acceptable solution I will post again to let you know.
If NVidia have some on its way hot-key switching updates for the M3, that would
be wonderfull... ;)

Cheers,

bjg.

netllama
02-20-06, 04:17 PM
This is a known bug in 1.0-8178, and will be resolved in the next driver release.

Thanks,
Lonni

bjg
02-20-06, 04:32 PM
So cool...
Thanks to you, lonni.

Bjg

wxbal
02-22-06, 10:25 AM
This is a known bug in 1.0-8178, and will be resolved in the next driver release.

Thanks,
Lonni

I just received by new Tecra. Any idea when this new driver will be released? Thanks.

RM

wxbal
02-22-06, 10:26 AM
[QUOTE=bjg]Hi,

I have had some progress, but things are not perfect yet.
I had put a mess by juggling with some wrong gfx_private stuff for my release.
This have been solved and I can use nvidia drivers for twin display now.

My problem now, is that on the flat panel I only see part of the full display whatever
is the resolution I choose (no more than 1280x1024 anyway), as it goes fine on the
external CRT. I can not pan as well, so it is somewhat unusable in standalone mode.
I suppose this is linked to the specific physical resolution of that TFT (1400x1050,
1280x960,etc... not multiple of standard resolutions.)
\

So were you able to get 8178 to work at 1280x1024 or 1024x768? If so, would you mind posting your xorg.conf?

Thanbks,
RMI

bjg
02-23-06, 10:36 PM
So were you able to get 8178 to work at 1280x1024 or 1024x768? If so, would you mind posting your xorg.conf?

Thanbks,
RMI

wxbal,

Here are two xorg.conf, for both single head and dual head mode.

I could achieve 1400x1050 and 1280x1024 in single head mode (fxorg.conf.single)
Then, other resolutions are rejected as invalid modes by Xorg (from Xorg.0.log).
I presume I have badly declared some things, as I am not a Xorg expert.

I could achieve 1280x1024 and 1024x768 in dual head mode (xorg.conf.dual)
Curious I could get 1024x768 on that mode, as my freqs. are coherent with
previous confs... Definately, I'm not a Xorg expert :-).

In dual head I used a 21" Sun monitor, and tested on a Sharp video projector.
Even with the attached screen directive, if I do not boot with the external device
attached, I go out of sync as I plug it.

I have stop testing for now, and wait for the new driver.
Hope it'll solve the issues and come quickly...

HTH,

bjg.

wxbal
02-28-06, 10:32 PM
Thanks very much for the xorg.confs

GLA
03-03-06, 12:09 PM
Any update on the new driver??

Thanks