PDA

View Full Version : No 5.1 speaker usage in games


Tuork
03-02-06, 07:18 PM
Haven't played from some time due to beeing busy, but I just noticed that when I'm in games only 2.1 sound is emitted.

I have a set of creative 5400 5.1 speakers on a 24bit SoundBlaster Live.


Any suggestions?

Zelda_fan
03-02-06, 07:21 PM
you probably dont' have the sound settings configured properly. I know that was a problem with mine but I fixed it

Tuork
03-03-06, 06:25 PM
3x 3.5mm

I'm not on my computer right now, but if I'm not mistaken I've enabled CMS 3D or whatever it's called... and my control panel settings enable 5.1 audio... I think.

Hey Zelda, mind telling me what settings should I look for?

j0j081
03-03-06, 07:41 PM
make sure both windows cp and creative cp is set to 5.1. then of course the game settings have to support surround and be on it.

CaptNKILL
03-04-06, 12:33 AM
You should disable the CMS 3d stuff I think. Im pretty sure it "simulates" 5.1, so it may be just doing that instead of using real 5.1.

Peoples-Agent
03-04-06, 12:36 AM
Disable that CMS rubbish.... that's used for MP3s and audio that don't support 5.1 generally, and then your find ingame it should take advantage of 5.1.

Tuork
03-05-06, 05:39 PM
Oops, my bad... what I meant with the CMS crap is that I have it set on real 5.1 sound, not that "smart" crap.

Zelda_fan
03-05-06, 11:46 PM
Oops, my bad... what I meant with the CMS crap is that I have it set on real 5.1 sound, not that "smart" crap.

first of all read your sound card manual and double check to make sure the cables are plugged in perfectly.

Second go to windows sound control panal, the volume tab, then click advanced and make sure it is set to 5.1 surround. Also since you are useing 3 analog outputs, make sure in the creative control panal it is NOT set to digital output.

SLippe
03-06-06, 12:17 AM
make sure both windows cp and creative cp is set to 5.1. then of course the game settings have to support surround and be on it.
Yeah, it's only used for stereo audio files and shouldn't effect real surround sound files. If you can't find the setting in the game, then the game probably doesn't support it. Hell, some only have Stereo or Mono settings, which I think is lame at this day and age. I have the same card, but I don't see what you are talking about "Smart" setting. Do you have the Synchronize with Control Panel" checked? Not sure why that would matter. I think it's just game dependent whether that setting is there or not. I use that CMS, it makes MP3's sound a hell of a lot better, IMO. I'm on a 4.1 system, JFYI.

j0j081
03-06-06, 11:21 PM
yeah as far as I know cmss only works if needed when your in surround mode therefore any true surround sources will be untouched.

Tuork
03-09-06, 09:24 AM
All things done... and I think 5.1 is working now.

I "think" beacause I forgot to pay attention last night when I was playing. Will look into it when I get home.

Thanks a bunch everyone. :D

TheManko
03-10-06, 04:35 AM
In older creative cards (pre X-fi) the application "cthelper.exe" might change the speaker count to stereo when launching certain games and it can be removed from startup without any consequenses.
What "cthelper" actually does is fixing a bug with older versions of windvd and is thus completely worthless today. Just remove it from startup and you'll be sure that no application screws up the speaker count.

j0j081
03-10-06, 04:46 AM
In older creative cards (pre X-fi) the application "cthelper.exe" might change the speaker count to stereo when launching certain games and it can be removed from startup without any consequenses.
What "cthelper" actually does is fixing a bug with older versions of windvd and is thus completely worthless today. Just remove it from startup and you'll be sure that no application screws up the speaker count.
cthelper was giving me headaches when I first got my card. disabled it and never looked back. the only downside is it stops the creative speaker settings from syncing with the windows ones but that is an upside for me because sometimes I've found things sound better with the windows cp set to 5.1 when I'm using headphones with the Creative setting on 2.1