PDA

View Full Version : Oblivion AFR rendering option question (potentially nHancer related)


Garulfo
03-22-06, 02:38 AM
I have seen a couple people saying that they use AFR for Oblivion to get the best frame rate. I have no idea what AFR is, and would really appreciate some insight.

My Machines config is as follow:

Asus A8n Deluxe SLI
AMD 4800+
4GB Kingston (3-2-3) (Actually I took 2GB out since I am running winXP 32bits, so make that 2GB total).
Two Geforce 7800 GTX with 512MB each (XFX)
Audigy 2 ZS
Using Drivers 84.21

I downloaded nHancer and noticed that the Elder Scrolls Oblivion Profile has AFR selected by default with no possibility to change it.

I have seen several posts witnessing that enabling SLI helps their frame rate. I have the very bad feeling that I am not actually using my SLI configuration. I am not sure how to enable and disable it.

I treid to uncheck the "enable SLI" box in the original nVidia software that comes with the drivers (under SLI-Multi GPU).

But wether I check it or not does not change performence one bit. I saved the game, quit and reloaded it at the same spot, and I am getting 43 FPS no matter what. Which is not bad, but I have AF turned off =/ And it goes as low as 17 FPS when I start running aroun in crowded areas... It's jsut not right with these video cards.

Is there a way for me to disable the SLI make SURE it is disabled? I got a hang of nHancer I think so if I have to use that, I shouldn't be too clueless.

I know that a lot of games, maybe including Oblivion, do not support SLI. But I have read enough people witnessing a framerate gain (usually not huge, around 20-40%) that I would like to be sure that OB is using both of my cards...

Thanks for any input :)

billos
03-22-06, 05:39 AM
Under the "Enable SLI" checkbutton, u must have another checkbutton called
"Show GPU load balance" or something like that.

Check the 2 options and start your game : if you see a vertical (or horizontal according to the SLI mode used by the game, SFR / AFR) bar, it confirms that the 2 cards are beeing used , otherwise they aren't.

Try this and tell us

SH64
03-22-06, 06:40 AM
Oblivion uses SLI AFAIK. look for the SLI green bars as billos said to check if its working or not.

OWA
03-22-06, 10:06 AM
Yeah, SLI helps and Oblivion seems to be SLI-aware since it's mentioned in the renderer file. Although if you try to use auto-detect, for me anyway, it picks SFR and SFR doesn't work well at all. The nvidia predefined profile uses AFR and it almost doubles the framerate a lot of the time (still some areas where it doesn't help though). That said, it doesn't mean the framerate is all that great even though it is helping (at least at 1920x1200).

Garulfo
03-22-06, 02:49 PM
Actually I do not have the 2 lines showing. The first time I started oblivion they appeared (in white, not green). But they disapeared when I loaded a save game... And they don't appear at all anymore,

**EDIT**
After installing nHancer and launching it here is what I did and what happened (this is all with the SLI enable in NV control center and multi GPU load on too)

If I set the Oblivion profile to Split-frame rendering I see one green horizontal bar that goes up and down on my screen. So I guess only one GPU is being used there?

I then alt-tabbed while playing and set it to Alternate Frame Rendering and the bar disapeared completely. No bar showing at all. But I gained an average of 10 FPS (I am sure abotu the gain I tested for over 5 minutes in each configuration, twice).

I really think only one GPU is being used and I don't know why. My computer detects the SLI after installing the drivers (you get the bubble in the bottom right saying "click here to activate SLI" you know...). There are 2 cards installed. But I only get 1 green bar showing in SFR and none at all in AFR...

Any help troubleshooting would be very welcome.

I also have two more questions if you don't mind:


1)Anyone could explain how to make sure that AFR is being used?

2)Are profiles used automatically? There is an Oblivion profile with the Oblivion.exe executable listed in int in the Nvidia control center software thing. Do I have to somoehow activate it or will it be used when the Oblivion.exe is launched, no matter what?

Thanks :)

Superfly
03-22-06, 03:14 PM
In answer to question 2 its automaticaly set when the .exe is run, no need to activate it.

pibrahim
03-22-06, 03:15 PM
Actually I do not have the 2 lines showing. The first time I started oblivion they appeared (in white, not green). But they disapeared when I loaded a save game... And they don't appear at all anymore,

**EDIT**
After installing nHancer and launching it here is what I did and what happened (this is all with the SLI enable in NV control center and multi GPU load on too)

If I set the Oblivion profile to Split-frame rendering I see one green horizontal bar that goes up and down on my screen. So I guess only one GPU is being used there?

I then alt-tabbed while playing and set it to Alternate Frame Rendering and the bar disapeared completely. No bar showing at all. But I gained an average of 10 FPS (I am sure abotu the gain I tested for over 5 minutes in each configuration, twice).

I really think only one GPU is being used and I don't know why. My computer detects the SLI after installing the drivers (you get the bubble in the bottom right saying "click here to activate SLI" you know...). There are 2 cards installed. But I only get 1 green bar showing in SFR and none at all in AFR...

Any help troubleshooting would be very welcome.

I also have two more questions if you don't mind:


1)Anyone could explain how to make sure that AFR is being used?

2)Are profiles used automatically? There is an Oblivion profile with the Oblivion.exe executable listed in int in the Nvidia control center software thing. Do I have to somoehow activate it or will it be used when the Oblivion.exe is launched, no matter what?

Thanks :)

If you see the horizontal green bar in SFR, then SLI is working (although my performance sucks with that method at the mo). As for AFR, apparently the two white lines don't show up if you have vsync enabled - disable it and see if they reappear.

Garulfo
03-22-06, 03:23 PM
Indeed they do when I disable Vsync.

I don't understand why I am not getting better FPS in AFR than I do in Single mode. I get an average of 40 or so in both, doing the exact same path using Fraps to benchmark

SFR is the lowest by 10FPS. Average of 30 or so.

Weird.