PDA

View Full Version : Oblivion crashing/freaz.. Many times..


Pages : [1] 2

Kdar
03-22-06, 11:32 PM
Hello.
Ok I got my Oblivion today and it crashed many times.
I dont know what can be the problem

My comp specs are:
AMD X2 4400+
2 GB of Ram
7800GT 256

OWA
03-22-06, 11:37 PM
What graphics drivers are you using? I'd start with the 84.25s and if they don't work, try the 84.21s followed by the 81.98s. I was using the 81.98s and they worked well. I just switched to the 84.25s tonight because they are supposed to help performance a little.

Also, make sure you're not overclocking anything. There is a thread here where someone found they couldn't overclock as much when playing Oblivion. So, I'd start off with stock settings also.

With motherboard and drivers also?

SH64
03-22-06, 11:41 PM
Updating your mobo BIOS might help if you didnt already .. also messing around with the RAM timings/voltage.

Kdar
03-22-06, 11:41 PM
Nothing is over clocked.
And I installed 84.25s drivers, before I installed the game... I guess I can try 84.21s.

PS. do you know is this game will have patch for Dual Core CPUs or it all thats now?

Kdar
03-22-06, 11:49 PM
Updating your mobo BIOS might help if you didnt already .. also messing around with the RAM timings/voltage.

Which one do I need?
http://www.dfi.com.tw/Support/Download/bios_download_us.jsp?PRODUCT_ID=3471&STATUS_FLAG=A&SITE=US

OWA
03-22-06, 11:51 PM
Actually, I remember reading a preview of the game and the guy said things were much better for him after he installed the AMD X2 CPU driver and MS dual-core hotfix. So, if you haven't installed those, you might want to. I already have them installed.

Kdar
03-23-06, 12:03 AM
Where can I get MS dual-core hotfix?

SH64
03-23-06, 12:05 AM
Which one do I need?
http://www.dfi.com.tw/Support/Download/bios_download_us.jsp?PRODUCT_ID=3471&STATUS_FLAG=A&SITE=US

The latest of course! (NF4LDB14) , i'm now on the 623 though.

OWA
03-23-06, 12:05 AM
Where can I get MS dual-core hotfix?
http://www.nvnews.net/vbulletin/showpost.php?p=772349&postcount=4

Edit: Ignore my runfirst comment in that post. With the X2 driver and the MS hotfix, you probably won't need to use anything like the runfirst command (or manually set the affinity option).

Kdar
03-23-06, 12:11 AM
So just install Driver and then Hotfix.. that all?
Do I need to mess with registry? To install hotfix etc...

OWA
03-23-06, 12:48 AM
Yeah, after you install the hotfix you have to edit the registry to enable it.

If you don't have the AMD X2 driver installed already. Start with that first, test to see how things are and then install the ms hotfix. It's just easier to test one thing at a time in case something doesn't work as expected.

-=DVS=-
03-23-06, 12:58 AM
Correct me if i missunderstand but after you apply HOTFIX you don't need to do anything else in registry according to MS link , you edit registry if you want to disable it.
If im correct after editing registry you will disable the hotfix and whole install would be pointless :p

Link (http://support.microsoft.com/?id=896256)

How to disable the new performance state policy behavior
After you install the hotfix that is described in this article, you may use registry settings to disable the new performance state policy behavior. To do this, follow these steps:
1. Click Start, click Run, type regedit, and then click OK.
2. Right-click HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager, point to New, and then click Key.
3. Type Throttle for the new key name.
4. Right-click Throttle, point to New, and then click DWORD Value.
5. Type PerfEnablePackageIdle for the value name.
6. Right-click PerfEnablePackageIdle, and then click Modify.
7. In the Value data box, type 0. Make sure that Hexadecimal is selected in the Edit DWORD Value dialog box, and then click OK.

Note You can type 1 in the Value data box to enable the new performance state policy behavior.
8. Quit Registry Editor.

OWA
03-23-06, 01:02 AM
I don't think that is correct. See the later part of the note:

Note You can type 1 in the Value data box to enable the new performance state policy behavior.

I think they're just telling you how you can disable it if need be. If you want to enable it, you need to follow the Note where it says to type 1 in the value data box.

-=DVS=-
03-23-06, 01:28 AM
Is it not at 1 by default ? , MS doesn't make it very clear :p anyway no matter gonna test it once i get home , only been 7 hours without Oblivion need my FIX :D

OWA
03-23-06, 03:01 AM
Is it not at 1 by default ? , MS doesn't make it very clear :p anyway no matter gonna test it once i get home , only been 7 hours without Oblivion need my FIX :D
Yeah, I wasn't sure what to do either when I first tried it. I basically tried it both ways and saw that I got a slight performance increase with it enabled. I think it defaults to 0 but it has been a while since I went through the process so I could be mistaken.

killahsin
03-23-06, 05:32 AM
yah the game already gets a huge boost from dual cores. You just have to do all the crazxy stuff listed above to see it lol.

Kdar
03-24-06, 04:24 PM
Installed all fixes and what not. But still same ****.

OWA
03-24-06, 04:26 PM
Well that sucks. Do other games do it or is it just Oblivion? Can you loop benchmarks without crashing?

swaaye
03-24-06, 05:37 PM
Actually I'm not convinced the game uses the 2nd core at all by default. All the options for threading are even disabled in the ini. The tweak thread has some info on it.

But without any tweaking, I don't see higher than 60% which usually means single threaded app with some dual core action by Windows or the video driver maybe.

-=DVS=-
03-24-06, 05:53 PM
Actually my game became unstable (alot of crashes) once i did that Registry tweak "1" for MS Hot fix :eek: but setting it at "0" all is well. Didn't see no speed gains . So .... i realy doubt the Usefulness of this patch...

Kdar
03-24-06, 07:10 PM
Actually I'm not convinced the game uses the 2nd core at all by default. All the options for threading are even disabled in the ini. The tweak thread has some info on it.

But without any tweaking, I don't see higher than 60% which usually means single threaded app with some dual core action by Windows or the video driver maybe.

So I can make game use 2core by looking in ini file?
Do you know how?

OWA
03-24-06, 10:59 PM
Actually my game became unstable (alot of crashes) once i did that Registry tweak "1" for MS Hot fix :eek: but setting it at "0" all is well. Didn't see no speed gains . So .... i realy doubt the Usefulness of this patch...
The dual-core hotfix also resolved affinity issues. Before, there were some games I had to set the affinity option for or else the game wouldn't run correctly (either super fast or super-slo or some combo of the two). Since installing the hotfix, I haven't had to set the affinity option. It also increased my performance a little. In games that required the affinity work-around before I installed the hotfix, performance was pretty much the same, they just ran correctly but in games that worked correctly already, they got a small boost in performance (a few fps). 3DMark05 got 200-300 point increase.

killahsin
03-24-06, 11:08 PM
Hello.
Ok I got my Oblivion today and it crashed many times.
I dont know what can be the problem

My comp specs are:
AMD X2 4400+
2 GB of Ram
7800GT 256


POSSIBLE FIX FOR CRASHES :

from the oblivion message boards :

Frequent Crashing possibly due to old system file

Some users may experience frequent crashing due to an older system file. These crashes may be attributed to the 'mpeg2dmx.ax' file. Simply renaming the file to "mpeg2dmx.ax.old" may correct this issue.


^ is that your crash? or is it the fdshow one?

Kdar
03-25-06, 10:51 PM
I was playing Oblivion today and set it to use only one Core.
And it run fine. In like 3 hour of game play it didnt had any crashes, lag or any thing.

But I still want to use both cores for this game, not just one.
You think I could have insteled those drivers wrong?

I used this to install MS Dual Core HotFix
http://hardware.mcse.ms/archive69-2006-1-277175.html
Go to Start, Run. Type regedit and push OK. Navigate to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro
l\Session Manager.
Right-click Session Manager and do New, Key. Type Throttle for the name.
Right-click New, DWORD Value. Type PerfEnablePackageIdle for the name.
Right-click PerfEnablePackageIdle and click Modify. In the Value data
box, enter '1' (without quotes, default is most likely '0'); make sure
Hexadecimal is selected and push OK. Close the registry editor.
user posted image


@killahsin

I searched for that file, and windows didnt finded it.

Tygerwoody
03-26-06, 02:15 AM
This game has crashed at least 10 times just today. I have tried 3 different drivers, and all the same outcome. I'm not using an X2 chip, so thats not my problem.