PDA

View Full Version : Far Cry problems with 84.21WHQL


SquireSCA
03-24-06, 03:41 PM
Specs in sig.

All games seem fine except for Far Cry with 1.33 patch. Gameplay feels like it is running at triple speed. Not in that I have 3x the FPS, but that everything moves so fast that the game is unplayable.

Like you run across a field in seconds. Turn a step and you turn all the way around.

Playing at 1680x1050x32bit, 4xAA, 16xAniso, max details.

Never had a game play too fast before, it's whack.

Any ideas?

OWA
03-24-06, 06:04 PM
See if there is a CPU driver for your dual-core and install that. Then install the MS dual-core hotfix. There is a X2 CPU driver for the X2s but I don't know about your CPU. To see if that is the issue before going through all of that, alt-tab or similiar method out of the game once it's started, bring up the task manger, find the process, right click on it, choose the set affinity option and uncheck CPU 1. Go back to the game and see if it's normal. If so, you have the affinity issue. Doing the above (installing the CPU driver and dual-core hotfix) solved all those issues for me. Before that, I was using a utility called runfirst that would do the affinity stuff I just mentioned automatically.

If it's not an affinity issue, try removing the predefined tag for the SLI mode in Far Cry profile in file c:\windows\system32\nvapps.xml. Then change the SLI mode to AFR or AFR2 or SFR just to see if that changes things.