PDA

View Full Version : Weird SLI GPU Load Balancing (GPU1's temp=106C, GPU2's temp=68C)


KoRnfR3ak
03-29-06, 04:33 PM
I'm using ForceWare 84.21
In idle, my GPU1 is 66C and my GPU2 is 65C.
In load, "Multi-GPU rendering" @ Drivers Settings, GPU1 is 96C and GPU2 is 76C.
In load, "Single-GPU rendering" @ Drivers Settings, GPU1 is 106C :( and GPU2 is only 68C.

In the in-game screenshot ("show GPU load balancing" option), GPU1 is rendering most (85%) of the frame, while GPU2 is only rendering the small area (15%) at the bottom.
Something is causing this "bad GPU Load Balancing", wich then results in GPU1 being 106C and GPU2 being only 68C. GPU1 almost :( 40C hotter than GPU2.

So far only noticed this issue with Need For Speed MW (using patch v1.3) and rthdribl.exe.
In 3dmark05/06 the GPU Load Balancing is working fine, since both cards reach similiar temps around 82C. So I don't think my GPU1 (or PSU) is faulty.

Could anyone with NFSMW confirm this issue, please?
Why is this "bad GPU Load Balancing" happening? How can I fix this ?

GuOD
03-29-06, 06:29 PM
I think NFS:MW uses AFR?? When I played NFS:MW using SLI I had the vertical green bars. You might be using the wrong SLI method?

OWA
03-29-06, 07:04 PM
Yeah, it uses AFR on mine as well so it doesn't look like the correct mode is being used.

KoRnfR3ak
03-30-06, 01:50 AM
Ok.
How do I use the correct SLI rendering mode ?
In global driver settings I have:
"Multi-GPU rendering" (SFR ?) , In load GPU1 is 96C and GPU2 is 76C, a difference of 20C, wich is not good.
"Single-GPU rendering" (AFR ?), In load GPU1 is 106C and GPU2 is only 68C, a difference of 40C, wich is not good either.

In the NFSMW profile, the SLI rendering mode says "Predefined (read only)".
What should I do ?

OWA
03-30-06, 07:29 AM
Try setting the global to auto-detect.

Single GPU is just using a single card.

Multi-GPU is using both. Actually, since you have multi-gpu showing in the global setting, I think that is the same as auto-detect. Apparently, you don't have coolbits installed so you don't get to see the actual modes.

If you install coolbits, you'll see options like Auto-Detect, Single GPU, SFR, AFR, AFR 2, etc.

http://www.slizone.com/object/slizone_appprofile_howto1.html

KoRnfR3ak
03-30-06, 02:29 PM
You are right. I don't have coolbits installed.
Thanks ;)
Gonna try it and report results Saturday. Got to study for a test Friday.

OWA
03-30-06, 02:47 PM
I guess that's worth a try but I don't think that's the issue. It should work whether or not coolbits is installed so I think something else is up. I'd normally suggest just reinstalling the drivers but since most other stuff works correctly, I don't think that would help either.

Oh, one thing you can try, edit the file c:\windows\system32\nvapps.xml (might want to copy it to a different location before editing so you can easily restore it) and remove the Need For Speed Underground profile. For a while, some of the drivers didn't work correctly b/c the exe for NFSU and NFSMW were the same thing (speed.exe). That was fixed a while back so that shouldn't be the issue but it might be worth trying if nothing else is working.

Good luck on the test. :)

KoRnfR3ak
03-31-06, 12:25 PM
Installed Coolbits, selected "auto-detect" rendering mode, and NFSMW was still using SFR. The thin horizontal GPU Balancing line. The temp issue again.
1600x1200 8xAA 16xAA 10-20 fps :(
I then selected AFR rendering mode and (nana2), vertical bar GPU Balancing,
1600x1200 8xAA 16xAA 40-60 fps, and temps are now close (GPU1's temp=93C, GPU2's temp=87C) in load.
Ok, my bad. I should always have Coolbits installed. Thanks OWA. But even so... How am I suposed to guess which games use SFR and which games use AFR ? Can u tell me where i can find this List ?

J-Mag
03-31-06, 01:21 PM
I'm using ForceWare 84.21
In idle, my GPU1 is 66C and my GPU2 is 65C.
In load, "Multi-GPU rendering" @ Drivers Settings, GPU1 is 96C and GPU2 is 76C.
In load, "Single-GPU rendering" @ Drivers Settings, GPU1 is 106C :( and GPU2 is only 68C.

In the in-game screenshot ("show GPU load balancing" option), GPU1 is rendering most (85%) of the frame, while GPU2 is only rendering the small area (15%) at the bottom.
Something is causing this "bad GPU Load Balancing", wich then results in GPU1 being 106C and GPU2 being only 68C. GPU1 almost :( 40C hotter than GPU2.


Why are you using Single-GPU rendering then? It makes sense that GPU1 will be hotter in
that mode. Does SFR still show up when you select "multi-GPU rendering" or is it AFR?

Technically your GPU1 is only 20C hotter under load when using "multi-GPU" which is what you should use if you want to run SLI. I mean that's why you bought two cards, right?

KoRnfR3ak
03-31-06, 03:57 PM
Why are you using Single-GPU rendering then? It makes sense that GPU1 will be hotter in
that mode. Does SFR still show up when you select "multi-GPU rendering" or is it AFR?

Technically your GPU1 is only 20C hotter under load when using "multi-GPU" which is what you should use if you want to run SLI. I mean that's why you bought two cards, right?

Ok, Single-GPU rendering is the same as not having SLI.

Anyway, before enabling coolbits, when I selected "multi-GPU rendering", the drivers should auto-detect NFSMW as AFR, right? But it didnt happen so. Something's wrong.
In "multi-GPU rendering", without coolbits, NFSMW automatically runs in SFR (the horizontal GPU Balancing line), and 10-20 fps @ 1600x1200 8xAA 16xAA.

Now, after enabling collbits:
1) I manually choose "auto-detect" and NFSMW still runs in SFR (the horizontal line GPU Balancing line), and 10-20 fps @ 1600x1200 8xAA 16xAA.
2) I manually choose "AFR" and NFSMW now runs in AFR (the vertical GPU Balancing bar), and 40-60 fps @ 1600x1200 8xAA 16xAA.

Resuming: The Auto-Detect is wrongly auto-detecting SFR instead of AFR.
So I must manually select SFR or AFR for each and every game.
But... How am I suposed to guess which games use SFR and which games use AFR ? Can u tell me where I can find this List ? Or I'm gonna have to benchmark every game to see wich SLI rendering mode gives me more fps, SFR or AFR ?

J-Mag
03-31-06, 04:12 PM
Resuming: The Auto-Detect is wrongly auto-detecting SFR instead of AFR.
So I must manually select SFR or AFR for each and every game.
But... How am I suposed to guess which games use SFR and which games use AFR ? Can u tell me where I can find this List ? Or I'm gonna have to benchmark every game to see wich SLI rendering mode gives me more fps, SFR or AFR ?

Nvidia normally puts the optimal SLI mode in the profile of the game so you don't have to worry about it. Anyway, sounds like your problem is a jacked up profile... Do you remove previous drivers and use driver cleaner before installing new drivers?

OWA
03-31-06, 04:22 PM
Yeah, most of them should be set to the proper setting already. So, normally the only time you have to deal with it is when there is a new game or demo released that they don't already have a profile for. The auto-detect sometimes works, sometimes doesn't so I never use it. I basically leave the Global setting at auto-detect and if a game doesn't have a profile already, I create one for it and try AFR first, AFR2 2nd and SFR last.

KoRnfR3ak
03-31-06, 04:23 PM
Nope. This WindowsXP installation is only 1 week old. First installed Forceware 84.21, using it until now. U try disabling coolbits and see what happens there in NFSMW when selecting "auto-detect" SLI rendering mode.

OWA
03-31-06, 04:25 PM
Which one is being set to auto-detect? Are you setting the global SLI option to auto-detect or are you overriding the game specific profile SLI option and choosing auto-detect?

KoRnfR3ak
03-31-06, 04:43 PM
Global=auto, NFSMW profile=auto, the game runs in SFR
Global=auto, NFSMW profile=AFR, the game runs in SFR
Global=SFR, NFSMW profile=AFR, the game runs in SFR
Global=AFR, NFSMW profile=SFR, the game runs in AFR

OWA
03-31-06, 04:54 PM
Hmm, I don't know. I just keep my global on auto and the game specific profile is set to its predefined value (read only -- AFR mode). Not sure why the global is overriding the game one unless not having the predefined tag (read only) mode set in the game specific profile allows the global to change it. Maybe you should try that. Restore the original NFSMW profile which has the SLI predefined/read only value and put global at auto to see what happens (unless that is how you started and you have already tested that).

KoRnfR3ak
03-31-06, 05:02 PM
hmmm, yah, that's how it started. Tested it already. And once again:
Global=auto, Custom profile using Coolbits=removed, restored NFSMW profile=read-only, the game runs in SFR