PDA

View Full Version : solaris 11 build 39


peteruta
05-11-06, 02:47 PM
Has anyone gotten the Nvidia driver to work with opensolaris build 38 or 39?

It seems some x.org modules needed by Nvidia driver are now missing.

(EE) Failed to load module "Xst" (module does not exist, 0)
(EE) Failed to load module "xtsol" (module does not exist, 0)


Thanks

Peter

zander
05-13-06, 03:46 AM
The NVIDIA X driver doesn't rely on these modules; please generate and attach a bug report log file if you have problems specific to the NVIDIA X driver.

gnutux
05-13-06, 11:39 AM
have you double checked your /etc/X11/xorg.conf that you're using the nvidia driver and not the nv driver?

gnutux

jpeg
05-14-06, 08:19 AM
Has anyone gotten the Nvidia driver to work with opensolaris build 38 or 39?


No problem with snv_38, but encountered a "hard" problem using snv_39. I will
try to go further tonight and let you see the result, if any.

Update #1: Commenting the line which load the GLX module (in the xorg.conf file)
do the trick here. FYI, here are the correponding error lines in the Xorg.0.log
file:
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.

Update #2: Following the X Window mailing list about this problem, it seems that
this is a known problem already tracked. Here is the corresponding link with
a workaround in order to be able to use OpenGL (be careful not to break anything):
http://www.opensolaris.org/jive/thread.jspa?threadID=8955

--
-jpeg.

johnmartin
06-02-06, 02:39 PM
A temporary fix has been integrated into build 41 under 6429418.
Until b41 is available, you will need to use the b38 /lib/ld.so.1 binary
as a workaround (or disable GLX in xorg.conf).