PDA

View Full Version : Windows Virtual Memory to low message. How do I fix it?


Digital_Trans
08-12-06, 10:13 PM
I'm getting a Windows Virtual Memory to low popup on the bottom right hand of my screen. How do I fix this issue? I've got 1GB of ram so I'm not sure as to why I'm being told Windows Virtual Memory to low. Please advise? Thank you! :D

rflair
08-12-06, 10:29 PM
When this happens have you brought up task manager to see if it may be a specific program that is leaking memory?

Digital_Trans
08-13-06, 12:14 AM
When this happens have you brought up task manager to see if it may be a specific program that is leaking memory?


iat just does it off and on.

Bearclaw
08-13-06, 12:27 AM
I had that recently happen to me when I was playing Flight Simulator X. It happened twice and shut down the program. I don't know why, I have 2 gigs. :thumbdwn:

MUYA
08-13-06, 03:28 AM
Have you guys tried nabuakky specifying the size of the swap file and possibly location? To have mem low with 1 GB and 2 GB, probably means there's a lot of background apps and other mem hog stuff being loaded. Checkup services, msconfig and or services.msc. And follow http://www.youtube.com/watch?v=-aiHJgvlTu4&mode=related&search=

as a guidline...as to what services should be there and what you can not have start etc.

LycosV
08-13-06, 03:35 AM
Just jack up your virtual memory. Hold down the start key on your keyboard and press the pause/break key (or goto system properties in control panel, same thing). Then goto the advanced tab and click the settings button in the performance box. Onto advanced then click the change button. Increase the maximum size, let the system manage it, whatever you want it's all in there.

lduguay
08-13-06, 09:06 AM
Bring up the Task Manager, and check the Limit value in the Commit Charge (K) section. If it is set to > 4000000 then your page file is not the problem. Should be process that is leaking mem. Select Mem Usage and Vm Size in the View/Columns page. The sort the process list by Mem Usage or VM Size in the processes tab. You will easily find the offending service/process.

Digital_Trans
08-13-06, 11:18 PM
Okay, thanks for the information gang!

Bearclaw
08-14-06, 01:48 AM
Bring up the Task Manager, and check the Limit value in the Commit Charge (K) section. If it is set to > 4000000 then your page file is not the problem. Should be process that is leaking mem. Select Mem Usage and Vm Size in the View/Columns page. The sort the process list by Mem Usage or VM Size in the processes tab. You will easily find the offending service/process.
My limit is 8186388 and I still have problems with FSX. I don't really mind sincce it's not essential and this is the only thing it happens with. My pagefile/swapfile is it's own seperate partition and is 6Gb. I shouldn't be having problems but like I said, FSX is the only thing it has ever happened to.

Xion X2
08-14-06, 10:22 AM
Fixing this is simple:

Go to control panel.
Go to system.
Go to advanced tab.
Go to Performance>Settings.
Go to Advanced tab.
Go to virtual memory>change.

Depending on the amount of RAM you have and free disk space, you can set it accordingly. I usually set it somewhere close to the amount of physical ram I have in my computer. (For instance, if you have 2GB of physical RAM then set it somewhere close to that in virtual memory.)

Where it says custom size, change both initial size and maximum size to that #. After you're done, click set, then OK, then apply (if it gives you the option) and voila, you're done.

There is another way to do it so that you won't fragment your pagefile, but I won't confuse you with that unless you want me to. I hardly think you can tell a difference, anyway.