PDA

View Full Version : Disabling PnP In Bios


The Bigman
08-15-06, 11:11 AM
With alot of conflicts with asus motherboards with xfi or sbAudigy 2's sharing the resources with 2nd pci-ex slot, is it best to leave Plug & Play off in bios?

I hear it actually helps with highend cards because windows likes to share them all on same slots or tie in the resources with each other loke both pci slots and pci-e slots.

ViN86
08-15-06, 11:29 AM
good question. all mobo manuals i have read say that it should be on with PnP operating systems though (e.g. win xp).

Ancient
08-15-06, 12:40 PM
I'm not sure it will make much difference. You're merely switching the burden of resolving IRQ conflicts from Windows to your BIOS and there's no guarantee that your BIOS is going to handle the problem any better than Windows does. You can give it a shot to see if it works any better. If it doesn't solve your problems then your best bet might be to manually assign resources, assuming your BIOS permits that.

LycosV
08-15-06, 12:51 PM
Turn PnP off!? That's crazy talk! In all honesty I have no idea what will happen. I haven't gone without PnP since the days of 95 where only half of devices supported it.

Ancient
08-15-06, 01:04 PM
Turn PnP off!? That's crazy talk! In all honesty I have no idea what will happen. I haven't gone without PnP since the days of 95 where only half of devices supported it.
I don't think you can actually turn it off. The setting he is talking about, I think, is PnP OS. That doesn't disable PnP but merely allows you to determine whether the BIOS or the OS will handle any conflicts that arise in resource assignments.

mullet
08-15-06, 01:48 PM
PnP OS = pure evil bottom line.

The Bigman
08-15-06, 02:00 PM
Thats what i mean pnp os. I have the ASUS p5n32 which doesn't have pci irq asignments like gigabyte or msi.

Problems is sli uses 2 IRQ's 16 and 18, i have 2 pci cards a NVTV TV Tuner which shares with the first GPU and the soundcard which shares with the second GPU. Thats a big problem with creative cards and 7800's.

I need to brake the souncard away from the 2nd GPU to aliminate sound scrathing. I don't get the scratcing with sli off because their is no use of the 2nd GPU but with SLI on the 2nd GPU interferes with soundcard.

ViN86
08-15-06, 02:14 PM
you can try disabling PnP in bios, that should stop the automatic IRQ assigning.

then read this:
IRQ Conflicts (http://kadaitcha.cx/irq_conflicts.html)

see the section about assigning IRQ's in win xp, and you need to change some things so you can manually assign the IRQs. make sure you make a note of the IRQs when they are assigned automatically. this will give you a guideline to go by.

hope that works :o

The Bigman
08-15-06, 02:51 PM
I talked to asus and they said leave it off so windows could creative virtual IRQ's. I rad you should set the acpi to standard pc to manually asign irq's but that takes away from system being dual core.

I don't like the soundcard sharing resources with BFG 7800 its bad for SLI.

Ancient
08-15-06, 04:44 PM
Disabling PnP OS really won't have any effect on your current problem because your problem originates in your PCI slots. PCI slots are hard coded for IRQ assignments. The IRQ will be assigned by the BIOS and passed on to Windows and won't change whether PnP OS is on or off. Windows might remap the IRQ provided by the BIOS, but in the BIOS there's really no change whatsoever. I don't think your problem will be solved without physically relocating the sound card to another slot that doesn't share an IRQ with the vid card, if that's even possible on your m/b.

The Bigman
08-15-06, 05:07 PM
I heard im going to need a bios mod to physcally change the IRQ's which sucks that ASUS doesn't include a feature to change IRQ"s like Gigabyte does.

I really love my wifes MD its and X2 64 and has 5 slots.

tweaked
08-17-06, 12:27 AM
XP isn't PNP its ACPI which is similar but different. Its the next step beyond PNP.

kinda pnp 2.0.


the setting is only for legacy pnp OS's.

Windows XP will over-ride your BIOS regardless of what pnp setting you use.

windows 95 on the other hand will have issues with it off.