PDA

View Full Version : New nHancer beta released & the infamous Prey-SLI bug


Grestorn
08-20-06, 11:22 AM
I've just uploaded a new beta for nHancer. See this posting (http://www.nvnews.net/vbulletin/showpost.php?p=969923&postcount=298) for more details and the download links.

The main purpose of this posting is another problem, which nHancer keeps being blamed for:

The game Prey sometime doesn't seem to use SLI. Some people suggested that this would be nHancer's fault. But I couldn't imagine any reason why nHancer could cause this.

So I started to investigate:

If you enable the SLI load balancing graph (which currently can only be activated with nHancer since nV has removed that option from their control panel for some reason) and then start Prey, there's a chance that Prey will startup with seemingly active SLI (the SLI graph is displayed) but for some reason, the green bar isn't there. The performance is then equivalent to a single GPU setup.

You can even deinstall nHancer, and you'll still can reproduce this effect, you just have to be presistent... since it doesn't happen all the time.

In the recent X-Bit labs article "Seven Games and One Week: Games vs. GPUs (http://www.xbitlabs.com/articles/video/display/7games-gpus.html)" they even claim that SLI wouldn't work at all using GX2 cards with Prey ... which is definitely not true (and I wrote them a letter about that as well, which was ignored so far). All because of this bug apparently.

I don't have any idea what the cause of this problem is. But I've got a work around:


Select Prey's game profile in nHancer
Remove the executable "prey.exe" from it. This will stop the driver from trying to activate it automatically. THIS IS IMPORTANT! If you don't do this, the workaround might fail still.
Activate the checkmark "can be activated manually" just below the list of profiles (the Prey profile must still be selected)
Then you'll get the option to activate Prey's profile manually, using the nHancer's menu "Tools->Activate Profile->Prey". The same menu is available in the tray icon.
Then start Prey. This way, I always got the SLI performance (and a visible green bar in the load balancing graph). I hope that this work around works for you, too.

After you've finished playing Prey, you should reset the driver to whatever setting you prefer, or you just activate the profile "Driver defaults" which is always available in the aforementioned menu.

I'd be happy to hear if that solves the problem for you.

SemperFi
08-20-06, 11:53 AM
If you rename the prey.exe to doom3.exe (the main executable, not the shortcut on your desktop) this will enable SLI mode in the game. By doing this you are forcing nvidia to use the profile for doom3 which also enables SLI for the game.

Just a quick fix for those who are having problems.

john19055
08-29-06, 04:22 AM
I don't use nhancer ,but I use 7900GT with sli enable ,I just set it to auto and the game worked perfect from start to the very end without any freeze ups or studdering or any problems what so ever ,I was useing the 91.33 drivers with the old display pannel.I ran it at 1600x1200 with 4xFSAA and 16x aniso and it never dip below it's capped 60FPS.