PDA

View Full Version : Windows doesnt want to pick up usb-mass-storage devices why?


a12ctic
09-23-06, 09:35 PM
Well today i had to transfer some files to my sis's computer that were sitting on my zip drive, it runs Windows XP pro, well, i pop in the drive and it says its detected. Unfortunatly it doesnt show in My Computer, i looked in disk managment and changed the Letter it mounts to to Z, this didnt work either. In disk managment it has the Floppy icon for some reason. Does anybody have an idea of what could be wrong?

Q
09-23-06, 09:42 PM
Are you pluggin it in to a motherboard based USB connector or to a front/rear extension USB connection? By extention, I mean the headers that run from the motherboard to the front of the case or to a PCI slot. A lot of USB Mass Storage devices have a hard time unless they are plugged directly into the motherboard USB.

Try switching ports. I've had an issue like this with my USB thumb drive where it half ass detects but it won't make it available.

a12ctic
09-23-06, 09:43 PM
its plugged directly into the motherboard, although it gives the same problem when it plugs into the front extension.

Q
09-23-06, 09:55 PM
Does it work on the other machine? Just curious.

Try toggling USB options in your bios. If you have legacy devices supported, try disabling it. If disabled, try turning it on. Have you tried a Linux Boot Disk? You could get reads using that and then just write to a FAT32 dir or if you're brave NTFS.

When you map it to Z:, can you access it through the command line? Does it just come up "device not ready"? Try accessing through safe mode or another user account? Administrator account?

The floppy icon is OK. I've seen that with Zip drives before. XP, for some reason or another, just doesn't like Zip drives. (At least with the two or three I've run into at work).

Good luck. I'll post some other non-sense if I can think of it! ;)

a12ctic
09-23-06, 10:04 PM
works perfectly on linux box, ill try messing with some bios features, thansk.

a12ctic
09-23-06, 10:30 PM
ok no luck there, its already formatted in fat32, its picking it up, its just not showing it in my computer, i can get to the drive through disk management.

nekrosoft13
09-23-06, 11:17 PM
probably is trying to use the same letter thats already being used by another drive.

change the drive letter in disk management

a12ctic
09-24-06, 12:00 AM
probably is trying to use the same letter thats already being used by another drive.

change the drive letter in disk management
already said that i changed it.