PDA

View Full Version : New drivers and old games


Laser Eyes
09-30-06, 12:00 AM
I am not impressed with the recent drivers from nVidia. I have been having difficulty getting older games to run. My favourite game System Shock 2 has been unplayable with the last few official Foreware drivers. I get the following error message:

"Direct3d device driver does not accurately report texture memory usage.
Contact your 3d accelerator vendor for updated drivers."

Updated drivers? I always use the latest drivers. Now I'm wishing I never updated my drivers. Trouble is old drivers are not compatible with my 7900GTX video card. Looks like I don't have a choice.

RejZoR
09-30-06, 01:02 AM
I hope you've updated SS2. I had different problem though. Game worked but textures looked like 8bit palettized. It was a real mess compared to just ocassional texture aliasing on R9600 Pro that was far from annoying. But here i can see every texture shade stage, so even ancient Mechwarrior 2 looked better in the end and it's not even hardware accelerated like SS2.

WimpMiester
09-30-06, 02:23 AM
I am not impressed with the recent drivers from nVidia. I have been having difficulty getting older games to run. My favourite game System Shock 2 has been unplayable with the last few official Foreware drivers. I get the following error message:

"Direct3d device driver does not accurately report texture memory usage.
Contact your 3d accelerator vendor for updated drivers."

Updated drivers? I always use the latest drivers. Now I'm wishing I never updated my drivers. Trouble is old drivers are not compatible with my 7900GTX video card. Looks like I don't have a choice.

That's an issue that’s been around for a long time and it affects all Dark Engine games (Thief 1 & 2 and System Shock 2). I don’t remember which file you needed to edit for Thief 1 & 2 but for SS2 add this line to the end of the cam.cfg file to fix this error.

safe_texture_manager

Also, a good fan site that offers support for Looking Glass games is www.ttlg.com

Delbert
09-30-06, 12:58 PM
As WimpMiester said... go here http://www.ttlg.com/forums/showthread.php?t=69958
I was just playing SS2 on the latest drivers 2hrs ago... no problems.

Serious Tom
10-02-06, 05:15 PM
All of the 9x.xx drivers so far have screwed up Medal of Honor Breakthrough for me. I read somewhere to delete all the sli profiles but that didn't help. I've have to stick with the 8x.xx drivers.... bad nVidia, first time they ever did this to me, it kinda sucks !