PDA

View Full Version : Odd problem with 1.0-9629


rmf
11-16-06, 02:46 AM
After installing 1.0-9629, my DELL 2007FPW (a 1680x1050 lcd monitor using DVI) could no longer be set into its native resolution. It always dropped back to 1280x1024. Reverting the driver back to 8776 brings back the native resolution. I tried manually setting the HorizSync/VertRefresh (not relying on EDID), but that did no good. This is with sol10u2 with current patches. This a known problem?

netllama
11-16-06, 01:00 PM
Can you generate and post a verbose X log which captures this failure?

Thanks,
Lonni

rmf
11-18-06, 02:28 PM
Xorg.0.log and output of nvidia-SunOS-bug-report.sh are attached for 8776 and 9629

netllama
11-18-06, 08:39 PM
None of what you've attached is a verbose X log.

paulgress
11-20-06, 12:53 AM
I've looked at some of what you attached. In the "/etc/X11/xorg.conf" file, the section near the end:

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
# Option "TwinView" "True"
# Option "TwinViewOrientation" "RightOf"
Option "UseEdidFreqs" "True"
# Option "MetaModes" "1280x1024, 1024x768, 1024x768"
SubSection "Display"
Depth 24
# Modes "1280x1024" "1024x768" "800x600" "640x480"
Modes "1280x1024"
EndSubSection
EndSection

Try changing:


From:

"Modes "1280x1024"


To:

"Modes "1680x1050"

Paul

rmf
11-20-06, 11:57 AM
uh, why would I do that? Screen0 *IS* a 1280x1024 flat panel.

rmf
11-20-06, 12:08 PM
Sorry about the verbosity level. What verbosity level do you want?

netllama
11-20-06, 01:04 PM
level 5 or 6 would be good, thanks.