PDA

View Full Version : Oni Performance issues with 97.02 drivers...


Githss
11-27-06, 09:15 PM
I installed the 97.02 drivers using a modified inf file so I can install the nvidia drivers on my laptop. For some reason when I'm playing oni the framerate goes all over the place. If I have vertical sync off, it goes from like 500fps to 50fps when there are any particle effects or lights flashing.
I messed around with driver settings but I can't seem to get this fixed.
Are there any work arounds for this??

My specs are:

Dell Inspiron 9400
Intel Core Duo @1.8Ghz
GeForce Go 7800 256MB
1GB Ram
100GB 7200RPM harddrive

crainger
11-27-06, 09:17 PM
Maybe try a different set of drivers? the 97.02's were designed for the 8 series after all.

I hope we can get it working. Oni is an all time favourite of mine. :D

Githss
11-27-06, 09:24 PM
Tried with 95 something and 80 something same problem.
Somebody mentioned that it was possible to drop the opengl.dll file in the main dir and oni would use that one, but I haven't found a download for it yet.

crainger
11-27-06, 11:47 PM
Tried with 95 something and 80 something same problem.
Somebody mentioned that it was possible to drop the opengl.dll file in the main dir and oni would use that one, but I haven't found a download for it yet.

From an old driver set? Not sure if that would work. Worth a try though. Why not check nvidia FTP for some old drivers.

saturnotaku
11-28-06, 05:21 AM
The 97.02 drivers aren't very good for the 7-series GeForce cards. I have the 96.89 drivers on my laptop right now. My workaround for Oni is as follows:

Download the 97.89 driver set and extract all the files to a folder. Use the command prompt and navigate to the directory where the drivers are and type the following command (without the quotes)

"expand nvapps.xm_ nvapps.xml"

Edit the newly created nvapps.xml file and copy/paste this code into it, just be sure to follow the format of the rest of the profiles there.

<PROFILE Label="Oni">
<APPLICATION Label="Oni.exe"/>
<PROPERTY Label="ogl_extension" Value="1" Itemtype="predefined"/>
</PROFILE>

Save, then install the drivers as you normally would. Upon completion, when you go into the driver control panel, you should see a profile for Oni there. Use it to also enable vsync and triple buffering, and you can also crank up the resolution and anti-aliasing. When I had my desktop system with a GeForce 7800, I could play at 1600x1200 with 8xS AA and 16x AF with vsync on and experience no performance loss.

This workaround means you don't need to install extra software to get it running. However, an easier way to accomplish the same thing is to use the program nHancer, and enable the OpenGL extension limit for the Oni profile you create.

Mike89
11-28-06, 10:39 PM
Oni? Wow dude, I thought I was the only one left that still had that game on my computer! It is a cool game.

Saturn, dunno why you're going through all that. I just created a Oni profile and turned the "Extension Limit" to "On". If set to "Off", the game would just crash when trying to start it. Running fine now though.

Githss
11-30-06, 12:01 AM
Oni? Wow dude, I thought I was the only one left that still had that game on my computer! It is a cool game.

Saturn, dunno why you're going through all that. I just created a Oni profile and turned the "Extension Limit" to "On". If set to "Off", the game would just crash when trying to start it. Running fine now though.

Yeah same here. I use Coolbits to enable all that stuff. Thanks for the tips guys but so far I tried all that.
It used to run perfectly on this laptop so maybe I need to just keep trying different drivers.

Githss
12-02-06, 03:20 PM
Okay I reinstalled the 87.08 and Oni runs great, but now Quake 3 Arena runs weird. The settings change to bilinear filtering and picmip=1 instead of my config settings.

Gaco
12-02-06, 03:25 PM
Nice to see that someone is still playing Oni :D