PDA

View Full Version : 8800 driver Scale to Fit setting is where?


Pages : [1] 2

Destroy
12-18-06, 12:54 PM
Native res of my lcd is 19x10.

If I run a game at 12x10, the game is stretch across filling the whole screen.

How do I prevent this and keep the game at 1:1?

Using 97.44 drivers btw.




.

OWA
12-18-06, 01:26 PM
Bring up the Nvidia CP, click on Display, click on Change Flat Panel Scaling and then choose the Do Not Scale option (and of course, apply). :)

Destroy
12-18-06, 03:19 PM
Bring up the Nvidia CP, click on Display, click on Change Flat Panel Scaling and then choose the Do Not Scale option (and of course, apply). :)

I don't have a Change Flat Panel Scaling section anywhere in my 97.44 CP.

I have:
Appearance section with
Run display optimization wizard
Change resolution attributes
Adjust desktop color settings
Rotate display
Manage custom timings

Multiple Displays section with
Change display configuration

That's all I have under Display.

Shocky
12-18-06, 05:34 PM
I don't have a Change Flat Panel Scaling section anywhere in my 97.44 CP.

I have:
Appearance section with
Run display optimization wizard
Change resolution attributes
Adjust desktop color settings
Rotate display
Manage custom timings

Multiple Displays section with
Change display configuration

That's all I have under Display.

The option is there, but it only works with the 96.## drivers and not with 97.## which are more like beta drivers..

OWA
12-18-06, 05:37 PM
It works fine for me with the 97.02s, 97.28s and 97.44s.

Edit:

I don't have a Change Flat Panel Scaling section anywhere in my 97.44 CP
How is your display connected (i.e. using DVI?)?

Destroy
12-18-06, 07:08 PM
Edit:


How is your display connected (i.e. using DVI?)?

Yes, using DVI on both ends of the cable.

OWA
12-18-06, 07:16 PM
Are there any options in the control panel that say something like treat my LCD TV as a flat panel monitor or something to that effect. I can't recall where that might be and it might have only been in the old control panel. See if you can find an option like that though.

epithumia
12-18-06, 07:31 PM
I can find the setting to change the FP scaling (97.44 drivers, installed onto a clean system), but unfortunately no changes I make actually take effect after I apply them. In fact, if I leave the page in the panel and return to it without closing the control panel application, I find that it's been reset to the previous value.

Crap, in fact, no changes I make in the nvidia control panel are actually saved anywhere. I can even add an entirely new game profile and it will be gone as soon as I leave the page. Nice. How I wish for boring documentation and plain text file somewhere which I could just edit.

And double crap, a quick scan of this forum doesn't turn up anyone else experiencing this problem.

OWA
12-18-06, 07:37 PM
Try nHancer epithumia to see how that goes.

Destroy, I've tried searching the forum for what I'm thinking about in regards to treating a LCD TV as a flat panel but I can't find the info. I thought I even supplied a screenshot of the option but couldn't find that either. It was definitely with the older drivers though since I haven't had my Westy 37" connected since the 9x.xx series and the new control panel were released.

Destroy
12-18-06, 10:39 PM
So it sounds like another 8800 driver issue lacking the feature?

Shocky
12-19-06, 08:58 AM
It works fine for me with the 97.02s, 97.28s and 97.44s.
(i.e. using DVI?)?

Odd, doesnt work for me with any of those drivers.

OWA
12-19-06, 11:03 AM
Odd, doesnt work for me with any of those drivers.
Yeah, you're not alone. I saw at least 3 or 4 others say the same thing (doesn't work for them). It has always worked fine here though. Maybe it depends on the LCD or something.

Destroy
12-19-06, 11:26 AM
Odd, doesnt work for me with any of those drivers.

Do you actually have the option to adjust this feature in the CP? If so, what is the title of the CP area called?

OWA
12-19-06, 11:42 AM
See the attachments for what it's called and what the section looks like.

Shocky
12-19-06, 02:47 PM
Do you actually have the option to adjust this feature in the CP? If so, what is the title of the CP area called?

Yes I got the option it just doesnt work, its actually a little buggy with 96.89 to . Some times it applys a sometimes not.. Same goes for the custom resolutions, they either worth fine or I get a black screen and have restart and boot last good working configuration. nvidia really should release better drivers, but I guess all they care about is getting our money..

Looks at OWA's post for pics..

bigjohns97
12-19-06, 08:30 PM
it doesn't work for any of the 97.xx drivers try 96.89.

OWA
12-19-06, 10:51 PM
It does work, for at least me anyway. See pic to see the no scaling option being used. Using 97.44 currently. Resolution in this pic was set to 1680x1050.

http://img399.imageshack.us/img399/5943/scaling02ue3.th.jpg (http://img399.imageshack.us/my.php?image=scaling02ue3.jpg)

Edit: Resolution set to 640x480 so it's more obvious.

http://img399.imageshack.us/img399/4218/scaling03ts9.th.jpg (http://img399.imageshack.us/my.php?image=scaling03ts9.jpg)

Destroy
12-19-06, 11:04 PM
See the attachments for what it's called and what the section looks like.

Nope. That one exact section in your pics does not exist in my 8800 97.44 or 97.02 CP. I have only 5 of the 6.

How come you have it and I don't? I've uninstalled and reinstalled both version of these drivers several times now.

My X1900XT never had this issue btw.

OWA
12-19-06, 11:15 PM
Nope. That one exact section in your pics does not exist in my 8800 97.44 or 97.02 CP. I have only 5 of the 6.

How come you have it and I don't? I've uninstalled and reinstalled both version of these drivers several times now.
I think it's because the drivers are considering yours a LCD TV while mine is considered a computer monitor (flat-panel monitor). I'm pretty sure I had the same issue when I was using my 37" Westy (but I think there was a way to change that in the 8x.xx drivers although I could wrong about that since it has been a while). You might want to try PM'ing Riptide. I think he still uses his Westy as his main monitor and he might be able to help out a little more. I currently don't have a long enough cable to reach the Westy and I have so much stuff connected to it that I don't want to move it to where my computers are.

OWA
12-19-06, 11:21 PM
OKay, I finally found what I was thinking about. See this post:

http://www.nvnews.net/vbulletin/showpost.php?p=839116&postcount=2

Edit: Here is part of the post...

Okay, I just disabled the treat digital display as HDTV option and then it let me select the same sort of scaling options on the Westy 37" HD monitor as it does on the Dell 24" LCD. Edit 3: Right click the display device in the nvidia control panel to get access to those options (or use the device adjustments option).

See if you can find something similiar to that. The above was with the 8x.xx series drivers.

Edit 2: Under manage custom timings, there is a check-box that says Treat as HDTV. See if you see that and see what happens if you turn it off (if it's on). You might need to do more than that though. I've never used the custom timings before so I'm unsure about it.

Edit 3: What does the control panel show for you under the Video and Television section. It mentions being able to specify the connector type and stuff so I'm wondering if maybe that is where the you can tell it to treat it as flat-panel monitor.

Edit 4: Searched through the help and I'm not really seeing a procedure for it so I wonder if it's not there in the 9x.xx series (new control panel). They removed some other features when the new control panel was added.

Destroy
12-20-06, 12:42 AM
Edit 2: Under manage custom timings, there is a check-box that says Treat as HDTV.


Yay! This did the trick. By unchecking the "Treat as HDTV" it unlocks the "Change flat panel scaling" selection within Display.

Much thanks for your help.

However, the setting does not stay to 'Do not scale' after Apply. If I quit out of CP then reenter CP, it reverts back to "Use nVidia scaling"

Edit: Just tried 2 different games. Still not working, Goes full screen stretched every time. Guess chalk up another driver issue. <sigh>

OWA
12-20-06, 12:46 AM
Well, I guess we're making progress. :) I think the other issue you mention is what the others have been saying. For whatever reason, the scaling options work for me but for a lot of others, the setting doesn't seem to stick.

bigjohns97
12-20-06, 10:45 AM
Yeah, destroy run 96.89 until some new drivers come out, the 97.xx don't work with the westy.

macatak
12-21-06, 09:36 PM
None of the options under "Digital Flat Panel Settings" work for me, either i get a garbled screen and then it reverts back to previous setting but if i use the settings in this window then they work....

http://img142.imageshack.us/img142/3729/scaz2.jpg

Destroy
01-13-07, 11:43 AM
Sad to say 97.92 still do not scale properly. :(

Every game res I pick gets stretched and uses the full screen.