PDA

View Full Version : X-fi internal power connector


Jon
01-25-07, 04:44 AM
Hi, I've finally decided to purchase:

Creative X-Fi Xtreme Gamer Fatal1ty Professional soundcard.

The manual says to connect a floppy power connector to the card. This apparently powers the i/o panel (which I don't have). I've googled it and seen mixed opinions on whether I need to plug in the power connector.

So, for those that already have an x-fi card without the I/O panel, have you connected the floppy connector? Has anyone had problems without it being connected?

Amuro
01-25-07, 04:57 AM
I don't use the front I/O panel so I never connected anything to the power connector, and card works fine.

Rayman1968
01-25-07, 08:05 AM
I don't use the front I/O panel so I never connected anything to the power connector, and card works fine.
^^^

john19055
01-25-07, 10:00 AM
If you are not going to use the extra front pannel ,or don't have it ,then there is no reason wht you would need to connect the power up to the card since it's only purpose is to power the front pannel .

ONER
01-25-07, 12:10 PM
If you are not going to use the extra front pannel ,or don't have it ,then there is no reason wht you would need to connect the power up to the card since it's only purpose is to power the front pannel .


Yeah, no need to use it if your not using a front panel.

Starscream
01-25-07, 12:43 PM
I've got an X-Fi Xtreme Music in one of my systems and have never plugged that in. I do not have the live drive.

Jon
01-25-07, 03:14 PM
Cheers everyone... I've put the x-fi in and am really happy I don't need the extra power cable (micro atx pc - finding any power connector makes me cry).

Just installing the drivers now.

Amuro
01-25-07, 08:55 PM
Enjoy your new x-fi! :)

Jon
01-26-07, 03:56 AM
Hehe, thanks. Played around with it for hours yesterday. Upgraded from an Audigy 2. First things I noticed are that my sub woofer suddenly started to sound like a sub and that everything sounds clearer and more defined.

There are so many options in the audio console / apps I still haven't got through them all! :D

$n][pErMan
01-28-07, 02:06 AM
Enjoy the card .. I love my X-Fi. Also.. your power connector is on the card? Maybe I never noticed that but I use a front I/O panel on my X-Fi Fatal1ty and the power connector is on the I/O panel itself. The only thing connected to my X-Fi card is the I/O communication cable.

Jon
01-28-07, 09:34 AM
Yes, the power connector is actually on the card. Even knowing it was there, it took me a while to spot it. According to the manual there are 2 revisions of the card, the first has the connector in the top right corner facing up. The 2nd has the power connector at the right end facing right.

$n][pErMan
01-28-07, 01:37 PM
Yes, the power connector is actually on the card. Even knowing it was there, it took me a while to spot it. According to the manual there are 2 revisions of the card, the first has the connector in the top right corner facing up. The 2nd has the power connector at the right end facing right.
I think I just found it on mine right next to the little red LED X-Fi logo. Interesting... clearly you don't need it if you hook the power connector to the I/O panel itself. Id be curious to try moving the power to the card instead of the I/O panel but I don't wanna risk it ATM :p

Dazz
01-28-07, 05:00 PM
I have mine powered on, although i do believe the power is for the IR sensor singanl for the remote.