View Full Version : 41.09's and PowerDVD

03-16-03, 06:18 PM
First off, I'm assuming this is a fkup on nVidia's part (from trawling around the web it doesn't look like it's the fault of PowerDVD).
I finally decided to come out of my hole and replace my 30.82 drivers with ones that were DX9 complient.
Upon installing the 41.09 drivers, I went to watch a movie. I have only one monitor installed on this system. TwinView is most certainly not enabled and I have reinstalled XP since I last had a TV connected to this system (as I am now at uni).
When I tried to play the DVD, I got:

Error Code f4d41436
Detailed. This copy protected disc cannot be played when the TV out function is enabled.

This happens with EVERY SINGLE DISK I tried to play. Clearly something is making PowerDVD think that I have got the computer connected to a recording device (I have had it outputting to a TV before now, and even to a VCR when I had it over at a mate's who doesn't have a TV with a scart socket. Yes the macrovision protection made the DVD flash dark then light, but it still played) and the only culprit I can see is those drivers, especially since 40.72 (which are WHQL Certified, unlike 41.09) don't show this problem.
I havn't had time to try any other 40's than those.

Is anyone else experiencing this problem, or is there something random going on with my machine?


03-16-03, 06:33 PM
Hmm. I've been running PowerDVD on 41.09 with no problems. I've used PowerDVD/4109 on all sorts of NVIDIA cards, dual-display and otherwise (various cards NV11, 15, 17, 18 25, 28) and never seen that message.

When you look into the driver control panel, do you see a device selection tab? Go there and see if 41.09 has erroneously got you set up in "clone mode". Changing this might let you watch DVDs again.

03-16-03, 06:49 PM
No, everything is set exactly as you'd expect for a single monitor computer.
I'm using PowerDVD 4.0 btw.


03-16-03, 11:23 PM
Yes I remember that kind of problem I had on Playstation 2 connected to VCR's SCART gave the picture flashed dark and then light and vice versa, it cos of macrovision protection. I solved it by connect Playstation 2 to TV.

So I heard all about Detonator drivers use macrovision protection, sometime leaked drivers had the protection disabled. All you need to disabled macrovision protection with the software called TVTool http://tvtool.info/index_e.htm

03-17-03, 02:34 AM
Yes they all have it - it's just that these particular ones have messed something up so that powerdvd triggers it even during normal monitor playback.

03-17-03, 05:17 AM
Have you tried patching your PowerDVD (I'm assuming you're using PowerDVD XP/4) the latest version (2417)? Patch is available at Cyberlink's website. Dunno if this will help but is worth a try.

03-17-03, 05:39 AM
Ah, I didn't realise there were any updates.
I'll give that a try then.

03-20-03, 06:58 AM
Well, according to this INQUIRER article (http://www.theinquirer.net/?article=8425).

Drivers from Nvidia starting with 41.09 will include stringent checks to comply with Macrovision. So if your video card has a TV encoder that doesn't comply then you'll have problems with DVD playback.

03-20-03, 07:32 AM
That's dumb - my card does indeed have one of those encoders mentioned in the article.
Thanks a bunch nVidia/Microsoft - not only have you fked DVD playback and restricted me to out of date drivers, I'll have to get TV Tool to disable macrovision.

The sad irony of this is that in thier never ending quest to prevent piracy, the companies involved here have actually introduced me to and forced me to use a tool which disables the very protection they're trying to enforce.

I hope it's not only me who sees the funny side here.