PDA

View Full Version : Wierd DirectX Freeze


t3hl33td4rg0n
05-08-07, 10:11 PM
Hey all,

Got a slight problem with most of my DirectX based games. Usually about 3-5 after launching and while in game, it freezes for about 10-15 seconds and HDD goes wild during that period. After its over, it starts playing normally like it never happened. As far as I can tell it happens with CSS, FEAR, Gothic3, NFSC, RSV, DM of M&M, CoD2, and Oblivion. The behavior is identical across the board. Yet, it doesn't happen with Quake4, Doom3, or Prey. Even if I have next to nothing running in the systray it happens, and its always 3-5 minutes into the game after a map is loaded.

I have no idea what could be the root of the problem, let alone where to begin fixing it. Ideas anyone?

SLippe
05-08-07, 11:02 PM
Did this just start happening out-of-the-blue? Or have you made changes to something recently?

t3hl33td4rg0n
05-09-07, 12:31 AM
Actually, I can remember this happening not too long after getting my 7800GTX, around the time when the CoD2 demo came out. Its been like that ever since. That was a while ago. But, I've been through 2 different motherboards and CPU's but it has always done it ever since i can remember.

t3hl33td4rg0n
05-09-07, 11:50 PM
So I guess I am the only one with this issue?

jballou
11-05-07, 11:45 AM
I am encountering the same issue, or close to it. I will be playing, then the entire system freezes for 10-30 seconds, sometimes with looping sound sometimes not. Testing has concluded:

Only in DirectX 9 games. DirectX 8 and lower, or OpenGL, will run for hours with 0 problems.
Temperature is not a factor. Starting from a cold boot after several hours off in my 62 degree climate controlled office, it still happens.
Full screen, windowed, resolution changes have no effect. All DirectX 9 titles run in any mode suffer the lockup.
While frozen, Windows Task Manager records no high CPU or memory usage, it all comes back as the same levels as before and after the freeze. Looks like nothing happened, but the system is completely unresponsive.
Recently, 1 out of 5 times or so it will also throw an error and crash to desktop.

Any extra information needed to help diagnose this would be greatly appreciated. Thanks!