PDA

View Full Version : How good are the current Vista 64bit drivers?


RostokMcSpoons
05-15-07, 06:03 PM
Hi,

I'm right on the brink of ordering a new graphics card. I was waiting for the R600 release, but I've already got a hair drier and an overdraft, so I don't want to pay lots of money for something that makes that much noise and hot air :rolleyes: So it's an 8800GTS 320mb .. or maybe (if I can find a cheap one) a 640mb version.

So... I'm going to upgrade to a new system, and as I can't afford to do that very often it's got to last me a while. That means it's got to play Halo2, Crysis and other DX10 and/or Vista-only games at a decent lick. And also Quake Wars and HL2 EP2 / Portal / TF2.

But the drivers have also got to be upto the job of playing my current fave games.

So that means (in order of play-time)

1. Day of Defeat: Source

err... ummm... oh yes...

2. STALKER
3. FEAR
4. CS:S
5. Call of Juarez (just the demo at the mo', but I liked it)

I've read stories of fog problems with Source engine games, and memory leak(? the one which is 'cured' by alt-tabbing) problems with FEAR and STALKER. I understand STALKER isn't really meant to Vista, but are the other bugs still applying to Vista64?

Is there anything else I should worry about before parting with my hard-earned?

Apologies if these questions have been asked before but my head is spinning from balancing xp vs vista 32 vs vista 64 vs Nv vs ATI :headexplode: and I'd really like to gather replies in one place :)



My expected system spec:

17" Hitachi LCD 1280x1024 (will prob upgrade to 16x10 widescreen)
Intel C2D E4300 - cooled with Scythe Infinity, overclocked to hell-and-back
Leadtek 8800GTS 640mb (215 at Scan)
4gb DDR2 5400
Asus P5NE-SLI / Gigabyte P965 DS3
2 x 200gb WD HD's in RAID 0
1 dvd burner
Corsair 520HX psu

Redeemed
05-15-07, 06:20 PM
Hi,

I'm right on the brink of ordering a new graphics card. I was waiting for the R600 release, but I've already got a hair drier and an overdraft, so I don't want to pay lots of money for something that makes that much noise and hot air :rolleyes: So it's an 8800GTS 320mb .. or maybe (if I can find a cheap one) a 640mb version.

So... I'm going to upgrade to a new system, and as I can't afford to do that very often it's got to last me a while. That means it's got to play Halo2, Crysis and other DX10 and/or Vista-only games at a decent lick. And also Quake Wars and HL2 EP2 / Portal / TF2.

But the drivers have also got to be upto the job of playing my current fave games.

So that means (in order of play-time)

1. Day of Defeat: Source

err... ummm... oh yes...

2. STALKER
3. FEAR
4. CS:S
5. Call of Juarez (just the demo at the mo', but I liked it)

I've read stories of fog problems with Source engine games, and memory leak(? the one which is 'cured' by alt-tabbing) problems with FEAR and STALKER. I understand STALKER isn't really meant to Vista, but are the other bugs still applying to Vista64?

Is there anything else I should worry about before parting with my hard-earned?

Apologies if these questions have been asked before but my head is spinning from balancing xp vs vista 32 vs vista 64 vs Nv vs ATI :headexplode: and I'd really like to gather replies in one place :)



My expected system spec:

17" Hitachi LCD 1280x1024 (will prob upgrade to 16x10 widescreen)
Intel C2D E4300 - cooled with Scythe Infinity, overclocked to hell-and-back
Leadtek 8800GTS 640mb (215 at Scan)
4gb DDR2 5400
Asus P5NE-SLI / Gigabyte P965 DS3
2 x 200gb WD HD's in RAID 0
1 dvd burner
Corsair 520HX psu

Well, check the sig- Vista Ultimate x64 all the way for me. :p Only thing I dislike about these Vista drivers is that SLi is borked. So I'm really only using one GTS as it averages better fps than SLi while allowing for a much cooler (temp wise) rig. Also, there are fog issues with Source games. I haven't noticed it in CS:S or HL2: DM nor GES- but in HL2, HL2: LC, and HL2: EP1 I do get the fog problem. No fix for it yet. And I have not played STALKER yet so I can't comment on its performance, nor have I installed FEAR yet.

So far though, I'm very pleased with Vista. I would say go ahead and get yourself a copy.

As to your new rig- get the 640MB GTS. With DX10 titles you are going to need that extra RAM. Also, you should go with an SLi capable board cause with DX10 titles, even the 640MB GTS will probably struggle at 16x10 with any decent amounts of AA aplied. As such, with a SLi capable mobo you have the ability to purchase a second GTS later for boosted performance. By the time you'll need a second GTS I'm sure SLi scaling will be on par if not better than that of XP. Though for SLi you would need quite a better PSU. Otherwise, the components you have selected look to be great. ;)

grey_1
05-15-07, 09:31 PM
Single card performance is at or very near XP with good to great IQ for me. I'm currently using the 158.42s, but was also very happy with the 160.03s.

64bit here also and loving it.

tweaked
05-15-07, 10:07 PM
what grey said, todays new drivers sealed the deal for me.

8800gtsfan
05-15-07, 11:48 PM
Still no 1280x1024 in some games like NHL 07, GTA VC....

Hapatingjaky
05-17-07, 09:11 AM
Still no 1280x1024 in some games like NHL 07, GTA VC....

Yeah I've run into a few games still that have issues with proper resolutions. But the drivers are nearly rock solid. The only game that has given me a real issue is UT2K4 64Bit. If I try and set a resolution higher then 640x480 it CTD's on me. But there's an easy solution. If I change .CFG file and change the following 2 options:

WindowedViewportX=
WindowedViewportY=

to 1280 and 1024 things work fine. So its not that big of a deal.

Riptide
05-17-07, 09:49 AM
They still need to get SLI support cleaned up and fix that stupid 4GB problem. Beyond that they are alright now for the most part.

Slammin
05-17-07, 10:26 AM
What is this 4gb problem I keep hearing about? I hear there is a 4gb problem when using X-Fi and Vista64, which I think I have because I get static and pops with some games, but what is the nVidia 4gb problem?

Zod
05-17-07, 12:18 PM
Aha! I've just built a Vista 64, Core Quad 6600 680i system with 8800GTX SLI, X-Fi and 4GM of PC8500 and I have sound crackles as well as memory speed problems and SLI is just not really any quicker than single card.

What is this 4GB problem, please?

Crisao23
05-17-07, 12:33 PM
I use Vista x64, 8800GTX, no problems at all

Wolfhound
05-17-07, 12:34 PM
See my sig no problems

Princess_Frosty
05-17-07, 05:43 PM
wait what...a 4gb memory problem in Vista 64 specifically for 8800 owners?

I've just upgraded to a 8800GTX after many months of problematic SLI with my 7950GX2 because of 4Gb of RAM, there's not other issues unresolved with Nvidia drivers for the 8800 cards is there?!

I thought the 4Gb+SLI thing only effected the 7xxx range users anyhow?

gizmoy2k
05-21-07, 02:55 PM
wait what...a 4gb memory problem in Vista 64 specifically for 8800 owners?



Should read

...a 4gb memory problem in Vista 64 specifically for X-FI owners ;)

Riptide
05-21-07, 03:00 PM
AFAIK the 4GB SLI problem affects the 8800 series as well. Am I wrong?

Shocky
05-21-07, 03:56 PM
There as good as the vista 32bit driver.

Goran
05-21-07, 03:56 PM
Is the Automatic Fan control working on 8800GTX in Vista 64 bit? Only thing that holds me off any Nvidia upgrade at present.

Pagusas
05-24-07, 02:48 PM
wait what...a 4gb memory problem in Vista 64 specifically for 8800 owners?

I've just upgraded to a 8800GTX after many months of problematic SLI with my 7950GX2 because of 4Gb of RAM, there's not other issues unresolved with Nvidia drivers for the 8800 cards is there?!

I thought the 4Gb+SLI thing only effected the 7xxx range users anyhow?

I have 4gigs, P5B deluxe mobo, C2D, 8800GTX and an XFi and have not had any issues (other then the lame way vista handles audio now)

hewlett
05-26-07, 10:25 AM
I have 4gigs, P5B deluxe mobo, C2D, 8800GTX Hey same here with vista ultimate 64 bit aslong as i don't use dreamscene with a game or pcpitstop i have no problems.I use 2 get my arsss handed to me in bf2 but not anymore!I'm have alittle better preformance now Nv gettting little better with the drivers now



Edit: useing 158.43