PDA

View Full Version : Should I RMA my 8600?


Jon
06-04-07, 03:24 AM
I have a BFG 8600GT OC that is 2 weeks old. But I can't figure if the card is faulty or not. I'm having the following problems:

Serious Sam 2 / Fable: Hundreds of short horizontal white lines randomly flickering across the screen. A kind of ghosting effect on textures. This is also present in the windows desktop when quitting the game. But a reboot fixes it.

NFS Carbon: After playing for a while, all the colours even in menus are messed up.

However, WOW, Spiderman 3, Dark Crusade, COH I can play for hours and they don't show any such problems.

This is a fresh install of windows xp, latest nvidia drivers. I have used ntune to underclock the card to its proper nvidia speeds instead of BFG speeds and still the same problem.

Temps are 50 idle, 65 degrees load.

I just can't figure why it only happens in some games.

john19055
06-04-07, 07:45 AM
If the the card was bad i think it would mess up in any game you played ,have you tried different drivers to see if one works better.

Jon
06-04-07, 09:48 AM
I'll try uninstalling/reinstalling the drivers and if that doesn't fix it, go back through some of the archive drivers.

The problem in serious sam 2 and fable is identical which made me think it was the card (especially as the problem continues to the windows desktop after exiting the game).

But as you say, it should do it in all games.

XFX Support
06-04-07, 03:12 PM
I would contact BFG Tech support and let them know about the situation as it is possible that the video card could be having problems. If you are using more then one stick of RAM, try using only one at a time. Would it be possible to test this video card in another system? I have seen it where a faulty video card showed artifacts in some games but worked in others. If nothing else BFG might allow you to send the video card in to them for testing, just to verify if it works properly or not.


XFX Support

Jon
06-07-07, 02:43 AM
I reinstalled the nvidia display drivers Tuesday. Tuesday and Wednesday its been running all games without a problem...

I'll wait until after a weekend using it before deciding whether to rma it though...

Jon
06-22-07, 05:43 AM
In the end I decided to RMA it... and I have to say I'm most impressed with BFG.

Got an RMA number next day, sent it to the address in Wales they gave me, 5 working days later I have a new 8600.

Installed it last night and all is good so far.

stncttr908
06-22-07, 08:13 AM
When I had to RMA my 6800GT they were nothing but helpful. :)

fraggelrock
06-22-07, 05:52 PM
Glad you had a positive RMA experience with BFG, sounds like a solid company.

Cool of XFX support for being professional. :cool:

Jon
06-23-07, 06:44 AM
Spoke too soon... the replacement card is now having the same problem. Fortunately I am able to test it in another PC this time and it is definately the card that is faulty. Looks like I will be testing their rma service next week too!

jcniest5
06-24-07, 09:45 PM
Keep track of it, if it keeps doing that to your video (second one, third one, etc...) you may need to swap out the PSU, I think it's killing the video card.

Jon
06-25-07, 04:49 AM
I'm a bit worried about it at the moment cause this is 2 cards both with exactly the same fault. My RMA# just came through for the 2nd card.

However, I have a 7900GT in the PC at the moment and that works great. But I'm still thinking what are the chances of getting 2 bad cards in a row with the possibility of a 3rd!

The PSU I'm using is an Antec Truepower 550w... and theres not many extras in the pc (1 hard disc, 1 PCI card, 2 dvd drives). The voltages in the bios are all above spec. But what concerns me is that the 7900GT and 8800GTS I have tried in it both have external power connectors where the 8600GT doesn't... I wonder if that is the problem!

Jon
07-06-07, 03:07 AM
3rd BFG 8600 GT OC arrived yesterday... still the exact same problem - tested on 3 computers! Whats the chances of that!? I'm just emailing support now, am thinking of asking if I can pay the difference and have a 8600 GTS instead. I've really got no confidence in the GT anymore!

ATOJAR
07-06-07, 06:36 AM
what are the chances of getting 2 bad cards in a row

They cant be that slim m8, its happened to me i bought a 7900GTX 512MB a while back that was having what sounded like the same problems as you, i RMA'd the card only to get exactly the same problem with my second card, yet my 6800GT worked just fine in the same system!

I decided to go with a eVGA 7950GT 512MB instead and that card ran just fine also in the same system, after that i decided eVGA was the only brand i will buy, my current eVGA 8800GTS 640MB is overclocked and runs sweet! :D

Jon
08-10-07, 10:20 AM
3rd 8600GT has gone back to BFG... this time spoke to someone in charge, they've sent me back an 8600GTS to apologise for the problems I've had. No problems with the GTS so far. Heres hoping anyway.

Madpistol
08-10-07, 12:56 PM
If it's happened 3 times now, is it possible that this problem is driver level? I remember having an FX 5900, and I RMA'd it because the shadows didn't show up properly on Splinter Cell. It turns out that all I had to do was revert the drivers to an earlier one, and the problem solved itself. There was nothing physically wrong with the card.

Anyway, if you put up with all that, I'm sure you deserve an 8600 GTS. Well played mate. :D