PDA

View Full Version : Newer Detonator denies me to play DVDs


ltcarneiro
03-31-03, 09:26 AM
I have a lot of problems if the newer drivers from Nvidia on my GF2mx.

When i try to play an DVD, i cannot, and the PowerDVD says it if because my TV-OUT is on.
This is an Macrovision issue, i know, but it show this error everytime i try to play an DVD, and with my TV-OUT totally disabled, whithout the cables!!!

My system works fine with version 40.72, and this version is WHQL! And dont work with all newer versions.

I am running Windows XP Professional with Service Pack 1

The manufactor of my graphic card is XFX. I send a lot of emails to that guys and they say to me it is an incompatibility with this newer drivers and older card, but it is nonsense! The driver is for ALL cards from Riva TNT2 to GF Fx!

Anyone have seen this problem before?

Thanks in advance for any help.

Numpsy
04-02-03, 01:28 PM
Not exactly the same thing, but i had exactly the same problem with my gf3 (only worked with 40.72 and earlier).
The 43.45s seem to have sorted it for me :)

R.Carter
04-02-03, 03:04 PM
Well, according to this INQUIRER article (http://www.theinquirer.net/?article=8425).

Drivers from Nvidia starting with 41.09 will include stringent checks to comply with Macrovision. So if your video card has a TV encoder that doesn't comply then you'll have problems with DVD playback. It could be that this change affects all GeForce and not just the newer GF4 and FX cards.

So your video card manufacturer could be correct.

Some other threads on this forum are:

Many DVD movies WILL NOT display any video... (http://www.nvnews.net/vbulletin/showthread.php?s=&threadid=8534)
41.09's and PowerDVD (http://www.nvnews.net/vbulletin/showthread.php?s=&threadid=8793)

ltcarneiro
04-02-03, 10:39 PM
Thank you for your answer. I have asked for this the manufactor of my card and they dont give me this clear reply.

Now, Anyone know some way to crack this? Or, someway to mix the files from 40.72 and 43.xx to build an mixed driver? Maybe this can be a solution... i dont know....

For anyone to sugest the use of the excelent tool called TVTOOL, this one dont solves the problem... I think the Nvida guys have fked up all !!!

I think this is why the post 40.72 drivers are not WHQL! This canīt be certifyed because it denies to user a legal use of DVDs on you monitor screen. This protection only make sense with TV-OUT enabled!!!

The only way this work is with Remote Selector, but the version i have only works with WinDVD 3 or PowerDVD 4. It does more than simply bypass macrovision, it can disable other DVDs protections, like the Warning at the begining, and more.

But, nothing is perfect... In my humble computer (PIII 550MHz, 256Mb, LG 16x DVD, GF2 MX200) the remote selector uses an huge CPU time, about 25%!!! This alone!!! When i start the player and the DVD playback, the experience is not so good... sometimes i see little "hangs" in the playback....

Well, is this... Thank you all who help me in this issue, and sorry abou this duplicate post!

Bye,

Leandro

BRMSlash
04-03-03, 09:17 AM
Have you tried updating the wdm drivers to the latest version 1.22? That might be your problem?

ltcarneiro
04-03-03, 10:48 PM
>Have you tried updating the wdm drivers to the latest version
>1.22? That might be your problem?

BRMSlash, thank you for your help, and, sorry about my dullness but are you talking about personal cinema? But this is a hardware feature, or not? Well, if i am right, i don't have the hardware for this....