PDA

View Full Version : OpenGL & Dual Monitors


OliverRedfox
06-24-07, 11:03 PM
On my 8600gt, under Vista x64, when I run an OpenGL based game, my second monitor turns off and I only get display on my primary. I keep a lot of my system monitoring and productivity apps running on the second screen so I keep keep an eye on things when gaming. Is this just a flaw with Vista and OpenGL or is there a setting I can change to fix this issue?

OliverRedfox
06-26-07, 05:30 PM
Solved it. I don't know why I didn't think of this before. It works fine if I turn off Aero. Whenever a DirectX game runs, it automatically turns off Aero, but for some reason, OpenGL games aren't shutting it off. So it just stops rendering the other desktop and visable apps. But with Aero turned off, it works fine.

ikjadoon
06-26-07, 07:20 PM
Don't know how much help this is to you, but in the Power Settings (I think) there is an option to turn Aero off/on when an application is maximized.

~Ibrahim~

OliverRedfox
06-26-07, 11:13 PM
It looks like transparency gets turned off on my maximized windows but I don't see any setting to disable Aero on maximize.

Now I'm just curious who I should be filling a bug report with. I'd assume it's Windows fault, but there might be a way for Nvidia to send a kill Aero command to Vista when OpenGL is in use. But until someone patches it, running Appearance as Vista Basic fixes it.

ikjadoon
06-26-07, 11:18 PM
Weird. I'll have to look at it again, I was pretty sure that it was there, but it might've been transparency.

It's nVidia, for sure. You specifically mention OpenGL, so I assume everything is OK with DirectX games? That is nVidia's problem, I would say. But it does a fair bit of play in Microsoft's playground.

~Ibrahim~

OliverRedfox
06-26-07, 11:59 PM
Yeah, everything is peachy with DirectX. I hadn't played an OpenGL game in ages, but I started playing ET:QW Beta a few days ago and that's when I noticed it. I installed Riddick just to see if it was OpenGL or ET:QW causing the issue and it had the same problem.

I didn't see the power setting, but with a little searching around I figured out how to make the app auto-shut off Aero. By right clicking it and going into properties. Under Compatibility, I check "Disable desktop composition". This forces Vista to use Vista Basic display when the app is being run. :)

I'll file a bug with Nvidia just to cover my bases. But this seems like a perfectly reasonable solution. Kinda funny that I've got to run an app in compatibility mode, that should be 100% compatible with Vista.

ikjadoon
06-27-07, 09:35 AM
Hey, that is a good way. Thankfully there is a workaround for this bug, but its good you filed it with nVidia.

~Ibrahim~

P.S. I checked the power settings. It was Dreamscene, not Aero. lol, sorry!