PDA

View Full Version : Does Vsync work in Vista?


SpunkyXL
08-22-07, 12:43 PM
I try new drivers every week, and VSYNC still doesn't work in games..I try setting game profiles via Control Panel, and still VSYNC doesn't work..I hate seeing tearing in my games!!! What is the workaround for this?


Specs:

Processor: Intel Core 2 Duo E6800
Vid Card: 8800GTX
Memory: 4 Gig Corsair TWIN2X2048-8500C5
OS: Vista 64-bit

DRen72
08-22-07, 01:40 PM
I can't speak for Vista 64-bit, but it works fine in 32-bit. I routinely enable or disable V-sync depending on the game.

chiklit
08-22-07, 05:12 PM
Are they DirectX games? I think it says the setting in the control panel only works for OpenGL games now, and for DirectX games to use the in-game setting.

Fats_43
08-22-07, 05:53 PM
I try new drivers every week, and VSYNC still doesn't work in games..I try setting game profiles via Control Panel, and still VSYNC doesn't work..I hate seeing tearing in my games!!! What is the workaround for this?


Specs:

Processor: Intel Core 2 Duo E6800
Vid Card: 8800GTX
Memory: 4 Gig Corsair TWIN2X2048-8500C5
OS: Vista 64-bit

Works for me on Vista x64, hell even bioshock defaults to having it on when I reload it. I want it off but some reason doesn't want to save that setting.

AdamK47
08-22-07, 06:30 PM
Works for me on Vista x64, hell even bioshock defaults to having it on when I reload it. I want it off but some reason doesn't want to save that setting.

That's odd. I have the opposite problem. Every time I start the game vsync is turned off. I have to turn it on.

Nick7
08-23-07, 04:21 AM
Vsync-On works in Vista OK.
Some older drivers (2-3+ months old) had issues with it.

corny
08-23-07, 05:25 AM
Yes works no problems generally on Vista x64.

DRen72
08-23-07, 08:36 AM
Are they DirectX games? I think it says the setting in the control panel only works for OpenGL games now, and for DirectX games to use the in-game setting.It does say something like that, but it works nontheless. The one game that its the most noticeable to me is Overlord. I get massive slowdoes with Vsync On, so I force it Off in the control panel. Works fine everytime. Then there is Oblivion, which for me is the exact opposite. I get huge tearing with Vsync Off, so I force it On in the control panel along with Triple Buffering. Works fine.